给你一个 配置吧,GNS测过好用,应该没啥问题,具体细化自己做做
GW路由器配置
实现双出口双NAT + SLA监控链路有效性实验
GW#sh run
Building configuration...
Current configuration : 1871 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname GW
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
ip dhcp excluded-address 10.1.1.1 10.1.1.10
ip dhcp excluded-address 10.1.2.1 10.1.2.20
!
ip dhcp pool P1
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
!
ip dhcp pool P2
network 10.1.2.0 255.255.255.0
default-router 10.1.2.1 255.255.255.0
!
!
ip sla monitor 10
type echo protocol ipIcmpEcho 60.30.1.2 source-interface FastEthernet1/0
frequency 10
ip sla monitor schedule 10 start-time now recurring
!
track 100 rtr 10 reachability
!
interface FastEthernet0/0
ip address 202.100.1.1 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 60.30.1.1 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 10.1.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet1/0 track 100
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 2
!
ip nat inside source route-map LianTong interface FastEthernet1/0 overload
ip nat inside source route-map Yidong interface FastEthernet0/0 overload
!
access-list 100 permit ip 10.1.0.0 0.0.255.255 any
!
route-map LianTong permit 10
match ip address 100
match interface FastEthernet1/0
!
route-map LianTong permit 20
!
route-map Yidong permit 10
match ip address 100
match interface FastEthernet0/0
!
route-map Yidong permit 20
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end