cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1953
Views
0
Helpful
6
Replies
syedumairali
Participant

unable to access APIC simulator.

Hi

I have a APIC simulator installed on vmware but i cant able to ping my gateway. Any help wold be much apprecited.

I have also place another test machine on the same port group, it can ping the default gateway but cant ping aci simulator. 

PING error is operation not permitted

Screen Shot 2018-05-05 at 01.46.31.png

 

6 REPLIES 6
ncfb-awarsame
Beginner

Hi Syedumairali,

did you resolve this issue?  I have the same issue 

seamtr01333
Beginner

Has anyone determined a solution for this?

zipho0001
Beginner

Hi, were you able to get this resolved? Also what version of the simulator are you running? I see this on 5.0 and Im tempted to download 4.2


Having the same issue. Downloaded and installed 5.1-1h.  I go through and accept all defaults except for the management interface. I specify an IP on the network and correct default gateway.  While other VMs on the same network work, I cannot ping the mgmt IP specified in the simulator setup. 

When going into the APIC for my physical ACI environment, I see the MAC addresses assigned in VMWare to the simulator VM.  Basically this is telling me the simulator is NOT communicating with anything outside the simulator. 

Hi @dmcquestion,

Ae you enabling Promiscuous Mode on the VMware vSwitch to which the ACI simulator is connected? (NOTE: if this is a production environment, make sure you understand the impact of this setting before modifying it).

Have a look at Step 2 under "Installing ACI Simulator Virtual Machine" in this doc: https://www.cisco.com/c/en/us/td/docs/switches/datacenter/aci/apic/sw/3-x/simulator/install_vm/b_Cisco_ACI_Simulator_VM_Install_Guide.html

In my VMware vCenter lab, I have the ACI Simulator's Network adapter 1 assigned to VM Network port group part of Standard Switch: vSwitch0. If in the Standard Switch settings I set Promiscuous mode to Reject, I lose access to my ACI Simulator (I lose access to ACI Simulator APIC's GUI and a ping from my laptop to ACI Simulator's mgmt IP breaks) as soon as I set Promiscuous mode to Accept (screenshot attached), I can again communicate with my ACI Simulator.

One more thing, a ping performed from the ACI simulator's CLI seems to be prohibited but you can do a traceroute after entering bash mode.

apic1# bash
admin@apic1:~> traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets

I hope this helps.

Regards.

@Hector Gustavo Serrano Gutierrez 

 

Thank you for the reply!  I compared your screen shot to what I had configured (see screen shot).  I set Promiscuous mode to Accept but I did NOT set MAC Address Changes and Forged Transmits to Accept.  When I set those to Accept, I was able to ping the simulator.  I am pretty literal so I only changed the Promiscuous Mode as called out in the documentation.  Mentioning the other two settings in the documentation or adding a screen shot of the settings in the documentation couldn't hurt. 

 

@zipho0001 

@syedumairali 

@seamtr01333 

@ncfb-awarsame 

 

If you have not already done so, check your vSwitch in VMware and set MAC Address Changes and Forged Transmits to Accept.

Content for Community-Ad