Showing results for 
Search instead for 
Did you mean: 

ACE eliminate insertion of http-header in some case

Alex Labuta

Hi All!

I have already configure loadbalance for http proxy servers (squid with NTLM) on ACE

with NAT and http header-insertion

If browser send clear request without username and password all done, i see client ip source into x-forward header.

Else nothing insert.

All recommendation from forum and guides applyed  and over.

ACE2/proxy# show parameter-map HTTP_PARAMETER_MAP

Parameter-map : HTTP_PARAMETER_MAP

Description : -

Type : http

    server-side connection reuse       : disabled

    case-insensitive parsing           : enabled

    persistence-rebalance              : enabled

    inspect non-persistence            : enabled

    header modify per-request          : enabled

    parsing non-strict                 : enabled

    header-maxparse-length             : 16384

    content-maxparse-length            : 32768

    parse length-exceed action         : continue

    urlcookie-delimiters               : /&#+

    urlcookie-start                    : ?

What I do wrong?

I have ACE20 with 2.3.5 software

3 Replies 3

Daniel Arrondo Ostiz
Cisco Employee
Cisco Employee

Hi Alex,

I would suggest you to do a SPAN session of the internal TenGig interface connecting the ACE with the switch backplane. Seeing the differences between the working and failing scenarios will probably give you some hints on why the header insertion is not working.

If you need help to analyze the traffic capture, you can always open a TAC case



Hi Daniel,

I am already have sniffers at client and serverside, it's insufficiently?

Best regard, Alex.

Hi Alex,

It's always better to get the captures on the backplane to really see what the ACE is sending/receiving (including the vlan tags), but having captures on the client and server may also be enough.


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: