02-20-2013 02:53 PM
Hi All
I am trying to move to real server's from the current configuration and adding to a new VIP, does anyone know what changes I would need to make.
I am trying to move the 2 proxies BCPROXY1 and BCPROXY2.
Any help much appreciated
Regards MJ
Solved! Go to Solution.
02-20-2013 04:03 PM
MJ;
I tried to open your txt file but I could not.
Could you paste the configuration in question?
Anyway, if you just have 2 rservers currently in use and you want to remove them to add them under another serverfarm, that´s possible.
You need to go to the serverfarm and do the following:
host1/Admin(config)# serverfarm SFARM1
host1/Admin(config-sfarm-host)# no rserver server1
host1/Admin(config-sfarm-host)# no rserver server1
host1/Admin(config)# serverfarm SFARM2
host1/Admin(config-sfarm-host)# rserver server1
host1/Admin(config-sfarm-host-rs)# inservice
host1/Admin(config-sfarm-host-rs)# exit
host1/Admin(config-sfarm-host)# rserver SERVER2
host1/Admin(config-sfarm-host-rs)# inservice
host1/Admin(config-sfarm-host-rs)# exit
Additionally, you can just remove the serverfarm from the VIP which you do not want to use anymore and just configure the serverfarm under the new VIP.
Please specify what you are looking and the configuration and I can do it for you.
Jorge
02-20-2013 05:16 PM
conf t
serverfarm host PROXY-PRODUCTION
rserver BCPROXY1
no inservice
rserver BCPROXY2
no inservice
no rserver BCPROXY1
no rserver BCPROXY2
Create a new server farm
serverfarm host BCPROXY
rserver BCPROXY1
inservice
rserver BCPROXY2
inservice
! Create a new classmap with new VIP address
class-map match-all BCPROXY-VIP
2 match virtual-address
policy-map type loadbalance first-match BCPROXY-POLICY-L7
class class-default
serverfarm BCPROXY
Create a new class instance under existing policy map
policy-map multi-match INCOMING-WEB-TRAFFIC
class BCPROXY-VIP
loadbalance vip inservice
loadbalance policy BCPROXY-POLICY-L7
loadbalance vip icmp-reply
02-20-2013 06:05 PM
MJ,
***This is how you should remove the rservers:
host1/Admin(config)# serverfarm PROXY-PRODUCTION
host1/Admin(config-sfarm-host)# no rserver BCPROXY1
host1/Admin(config-sfarm-host)# no rserver BCPROXY2
Once you have done that, you can create the new serverfarm, but there are some scenarios where you can have
different serverfarms configured with the same rservers but different VIPs(class-maps) hearing on another ports.
Then you may have something like this after configuring that.
class-map match-all NEW-VIP
2 match virtual-address 10.100.101.X tcp eq 8080
policy-map type loadbalance first-match WEB-POLICY-L7-NEW
class class-default
serverfarm PROXY-PRODUCTION-NEW
policy-map multi-match INCOMING-WEB-TRAFFIC
class CLASSIFY-INCOMING-TRAFFIC
loadbalance vip inservice
loadbalance policy WEB-POLICY-L7
loadbalance vip icmp-reply
class NEW-VIP
loadbalance vip inservice
loadbalance policy WEB-POLICY-L7-NEW
loadbalance vip icmp-reply
As you can see the policy multimatch called: INCOMING-WEB-TRAFFIC can have the old class-map:CLASSIFY-INCOMING-TRAFFIC and the new one which I called: NEW-VIP.
It is not required that you configure a new policy-map multi-match, you can just "reuse" it, and the ACE will match class by class analyzing if what it matches is what it looks for and will continue doing that until it finally finds what configuration related to what it is supposed to do.
Do not hesitate to let me know any query you have!
Hope this helps!
Jorge
02-20-2013 04:03 PM
MJ;
I tried to open your txt file but I could not.
Could you paste the configuration in question?
Anyway, if you just have 2 rservers currently in use and you want to remove them to add them under another serverfarm, that´s possible.
You need to go to the serverfarm and do the following:
host1/Admin(config)# serverfarm SFARM1
host1/Admin(config-sfarm-host)# no rserver server1
host1/Admin(config-sfarm-host)# no rserver server1
host1/Admin(config)# serverfarm SFARM2
host1/Admin(config-sfarm-host)# rserver server1
host1/Admin(config-sfarm-host-rs)# inservice
host1/Admin(config-sfarm-host-rs)# exit
host1/Admin(config-sfarm-host)# rserver SERVER2
host1/Admin(config-sfarm-host-rs)# inservice
host1/Admin(config-sfarm-host-rs)# exit
Additionally, you can just remove the serverfarm from the VIP which you do not want to use anymore and just configure the serverfarm under the new VIP.
Please specify what you are looking and the configuration and I can do it for you.
Jorge
02-20-2013 04:13 PM
Hi Jorge
Thanks for the response, please see the configuration.
access-list ALL line 1 extended permit ip any any
probe icmp icmp_probe
interval 5
passdetect interval 60
rserver host BCPROXY1
description NEW HBC WEB PROXY 1
ip address 10.100.102.22
probe icmp_probe
inservice
rserver host BCPROXY2
description NEW HBC WEB PROXY 2
ip address 10.100.102.23
probe icmp_probe
inservice
rserver host PROXY1
description WEB PROXY 1
ip address 10.100.102.20
probe icmp_probe
inservice
rserver host PROXY2
description WEB PROXY 2
ip address 10.100.102.21
probe icmp_probe
inservice
serverfarm host PROXY-PRODUCTION
description PRODUCTION WEB PROXY
predictor response app-req-to-resp
rserver BCPROXY1
inservice
rserver BCPROXY2
inservice
rserver PROXY1
inservice
rserver PROXY2
inservice
class-map match-all CLASSIFY-INCOMING-TRAFFIC
2 match virtual-address 10.100.101.10 tcp eq 8080
policy-map type loadbalance first-match WEB-POLICY-L7
class class-default
serverfarm PROXY-PRODUCTION
policy-map multi-match INCOMING-WEB-TRAFFIC
class CLASSIFY-INCOMING-TRAFFIC
loadbalance vip inservice
loadbalance policy WEB-POLICY-L7
loadbalance vip icmp-reply
interface vlan 1111
description ACE-VIPS-MAIL - Incoming Traffic
ip address 10.100.101.253 255.255.255.0
alias 10.100.101.254 255.255.255.0
peer ip address 10.100.101.252 255.255.255.0
access-group input ALL
service-policy input remote_management_access
service-policy input INCOMING-WEB-TRAFFIC
no shutdown
interface vlan 1112
description ACE-SERVER-VLAN
ip address 10.100.102.3 255.255.255.0
alias 10.100.102.1 255.255.255.0
peer ip address 10.100.102.2 255.255.255.0
access-group input ALL
service-policy input remote_management_access
no shutdown
ip route 0.0.0.0 0.0.0.0 10.100.101.1
All I am wanting to do is remove the to test proxy servers to a new VIP for (for test before putting back into production)
will I need a new service policy or can I use the existing one (INCOMING-WEB-TRAFFIC)
Regards MJ
02-20-2013 05:16 PM
conf t
serverfarm host PROXY-PRODUCTION
rserver BCPROXY1
no inservice
rserver BCPROXY2
no inservice
no rserver BCPROXY1
no rserver BCPROXY2
Create a new server farm
serverfarm host BCPROXY
rserver BCPROXY1
inservice
rserver BCPROXY2
inservice
! Create a new classmap with new VIP address
class-map match-all BCPROXY-VIP
2 match virtual-address
policy-map type loadbalance first-match BCPROXY-POLICY-L7
class class-default
serverfarm BCPROXY
Create a new class instance under existing policy map
policy-map multi-match INCOMING-WEB-TRAFFIC
class BCPROXY-VIP
loadbalance vip inservice
loadbalance policy BCPROXY-POLICY-L7
loadbalance vip icmp-reply
02-20-2013 06:05 PM
MJ,
***This is how you should remove the rservers:
host1/Admin(config)# serverfarm PROXY-PRODUCTION
host1/Admin(config-sfarm-host)# no rserver BCPROXY1
host1/Admin(config-sfarm-host)# no rserver BCPROXY2
Once you have done that, you can create the new serverfarm, but there are some scenarios where you can have
different serverfarms configured with the same rservers but different VIPs(class-maps) hearing on another ports.
Then you may have something like this after configuring that.
class-map match-all NEW-VIP
2 match virtual-address 10.100.101.X tcp eq 8080
policy-map type loadbalance first-match WEB-POLICY-L7-NEW
class class-default
serverfarm PROXY-PRODUCTION-NEW
policy-map multi-match INCOMING-WEB-TRAFFIC
class CLASSIFY-INCOMING-TRAFFIC
loadbalance vip inservice
loadbalance policy WEB-POLICY-L7
loadbalance vip icmp-reply
class NEW-VIP
loadbalance vip inservice
loadbalance policy WEB-POLICY-L7-NEW
loadbalance vip icmp-reply
As you can see the policy multimatch called: INCOMING-WEB-TRAFFIC can have the old class-map:CLASSIFY-INCOMING-TRAFFIC and the new one which I called: NEW-VIP.
It is not required that you configure a new policy-map multi-match, you can just "reuse" it, and the ACE will match class by class analyzing if what it matches is what it looks for and will continue doing that until it finally finds what configuration related to what it is supposed to do.
Do not hesitate to let me know any query you have!
Hope this helps!
Jorge
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide