05-16-2012 01:57 AM
We use JDE and up to now part of the tools was Apache which would redirect as follows
http://alias.server to http://real.server:13333/main.maf
the latest version no longer uses Apache so I was wondering how I can do it on the ACE
of course there is no problem going from alias.server port 80 to real.server:13333 but how can I add the URI main.maf?
Solved! Go to Solution.
05-17-2012 02:24 AM
Hi
The configuration would look like the following:
rserver host CHIJTW55
description CHIJTW55
ip address 172.16.98.106
inservice
rserver redirect JDEDV_RED
webhost-redirection http://172.16.73.10:13333/main.maf 301
serverfarm host JDEDV
description JDEDV servers
failaction purge
probe tcp13333
rserver CHIJTW55 13333
inservice
serverfarm redirect REDIRECT_FARM
rserver JDEDV_RED
inservice
class-map match-any JDEDV_vip_80
2 match virtual-address 172.16.73.10 tcp eq www
class-map match-any JDEDV_vip_13333
2 match virtual-address 172.16.73.10 tcp eq 13333
policy-map type loadbalance first-match JDEDV_80
class class-default
serverfarm REDIRECT_FARM
policy-map type loadbalance first-match JDEDV_13333
class class-default
serverfarm JDEDV
policy-map multi-match MULTI_POLICY
class JDEDV_vip_80
loadbalance vip inservice
loadbalance policy JDEDV_80
class JDEDV_vip_13333
loadbalance vip inservice
loadbalance policy JDEDV_13333
interface vlan X
service-policy input MULTI_POLICY
I hope this helps
Daniel
05-16-2012 02:26 AM
Good morning,
If what you are trying to do is just rewriting the request so that the "/main.maf" sting is added to the URL, then, I'm afraid the answer is that it's not possible.
What you could do is first doing a redirect (not rewrite) from "http://vip_ip/" to "http://vip_ip:13333/main.maf" and then be load-balanced to the servers (for which the request would be "http://server_ip:13333/main.maf")
For more details on how to configure the redirection, you can refer to the link below
If you need more details on how to achieve this configuration, please, let me know.
Regards
Daniel
05-16-2012 02:59 AM
Daniel,
Ok Just need some help in getting it right
This is what I have at the moment
rserver host CHIJTW55
description CHIJTW55
ip address 172.16.98.106
inservice
serverfarm host JDEDV
description JDEDV servers
failaction purge
probe tcp13333
rserver CHIJTW55 13333
inservice
class-map match-any JDEDV_vip
2 match virtual-address 172.16.73.10 tcp eq www
so do I add the following to change the VIP?
rserver redirect JDEDV_RED
webhost-redirection http://172.16.73.10:13333/main.maf 301
what else do I need?
05-16-2012 03:37 AM
Hi,
You first need to associate the redirect rserver with the JDEDV_vip. Then create a new VIP for the same IP address but port 13333 and associate the JDEDV serverfarm to it.
Daniel
05-16-2012 04:04 PM
Daniel,
Sorry to be a pain, but you could you give me the configuration on how to do above
regards
05-16-2012 10:51 PM
Daniel,
been looking at this further. I am using the ACE in one arm mode, so there is only one interface.
I can't see how it works, i can create a policy map for the redirect server and the original VIP, but does that get applied to the vlan interface, if so how does the second part work, when I use another Vip with the real server that would also need to be applied to the interface...this is where I am getting lost.
05-17-2012 02:24 AM
Hi
The configuration would look like the following:
rserver host CHIJTW55
description CHIJTW55
ip address 172.16.98.106
inservice
rserver redirect JDEDV_RED
webhost-redirection http://172.16.73.10:13333/main.maf 301
serverfarm host JDEDV
description JDEDV servers
failaction purge
probe tcp13333
rserver CHIJTW55 13333
inservice
serverfarm redirect REDIRECT_FARM
rserver JDEDV_RED
inservice
class-map match-any JDEDV_vip_80
2 match virtual-address 172.16.73.10 tcp eq www
class-map match-any JDEDV_vip_13333
2 match virtual-address 172.16.73.10 tcp eq 13333
policy-map type loadbalance first-match JDEDV_80
class class-default
serverfarm REDIRECT_FARM
policy-map type loadbalance first-match JDEDV_13333
class class-default
serverfarm JDEDV
policy-map multi-match MULTI_POLICY
class JDEDV_vip_80
loadbalance vip inservice
loadbalance policy JDEDV_80
class JDEDV_vip_13333
loadbalance vip inservice
loadbalance policy JDEDV_13333
interface vlan X
service-policy input MULTI_POLICY
I hope this helps
Daniel
05-17-2012 02:55 AM
Daniel
I had just about worked it out a couple of hours ago, the only thing left is
when I go to http://JDEDV the URL is displayed as
http://172.16.73.10:13333/main.maf instead of http://JDEDV/main.maf
05-17-2012 03:06 AM
Hi
The redirection is currently pointing to the IP address of the VIP. If you want the browser to display the DNS name, you should use that in the redirect statement.
Regards
Daniel
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide