cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
345
Views
0
Helpful
1
Replies

ACE withot NAT

RICARDO SANCHEZ
Beginner
Beginner

Hello

I have a configuration in the ACE module to NOT perform NAT with the command transparent in a serverfarm configuration mode, but it is not working.

 

rserver host MXMTYIPR

  ip address 172.19.127.131

  inservice

serverfarm host _Front

  transparent

  rserver MXMTYIPR 443

    inservice

 

sticky ip-netmask 255.255.255.255 address source STICKY_FR

  timeout 10

  timeout activeconns

  replicate sticky

  serverfarm _Front

 

class-map match-all CLASS_LYN

  2 match virtual-address 172.19.127.1 tcp eq https

 

policy-map type management first-match POLICY-ADMIN

  class CLASS-ADMIN

    permit

 

policy-map type loadbalance first-match POLICY_FR

  class class-default

    sticky-serverfarm STICKY_FR

 

policy-map multi-match PM_FR

  class CLASS_LYN

    loadbalance vip inservice

    loadbalance policy POLICY_FR

    loadbalance vip icmp-reply

 

interface vlan 550

  ip address 172.18.50.139 255.255.255.240

  alias 172.18.50.141 255.255.255.240

  peer ip address 172.18.50.140 255.255.255.240

  service-policy input PM_FR

  no shutdown

 

Does anybody have any recommendation to this?

 

Thanks for your help.

 

Regards

1 Reply 1

Kanwaljeet Singh
Cisco Employee
Cisco Employee

Hi,

You should disable normalization on client side interface and also configure server so that it returns the traffic with VIP as the source IP. Please visit the below link for more details:

https://supportforums.cisco.com/document/91121/configure-ace-direct-server-return-mode

Regards,

Kanwal

Note: Please mark answers if they are helpful.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: