Showing results for 
Search instead for 
Did you mean: 

Cisco AnyConnect User Interface has stopped working


So I have an MS Surface Pro (Windows 8.1 x64) has been running AnyConnect 3.1.04066 for several months without incident.  All of a sudden a couple of weeks ago, when you load the software and then click 'Connect' a pop-up stating that "Cisco Any Connect User Interface has stopped working" with an app crash.  Have attempted:


- Uninstall & Reinstall

- Install of latest release, v3.1.05182

- Install back to v2.5.2019


No change in behaviour with any of these (just the v2 crashes with a different error message).  We have several hundred other people connecting to our corporate VPN system without issue, so I know our VPN connectivity is good.  I have 2 other MS Surface's out and both of those are working fine.  Machine has all MS updates installed, nothing has been installed or changed during the time period between when it was working to where it was not working.  Computer appears to be virus\malware free.  I've smacked my head against this for a while and I'm completely stumped.  Any direction would be appreaciated.


Here's the app error log:

Log Name:      Application

Source:        Application Error

Date:          2014-10-14 2:17:26 PM

Event ID:      1000

Task Category: (100)

Level:         Error

Keywords:      Classic

User:          N/A



Faulting application name: vpnui.exe, version: 3.1.5160.0, time stamp: 0x5320c86f

Faulting module name: vpnapi.dll, version: 3.1.5160.0, time stamp: 0x5320c746

Exception code: 0xc0000005

Fault offset: 0x0000e359

Faulting process id: 0x1114

Faulting application start time: 0x01cfe7db1ab77104

Faulting application path: C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\vpnui.exe

Faulting module path: C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\vpnapi.dll

Report Id: 594fe6e1-53ce-11e4-be98-281878489656

Faulting package full name:

Faulting package-relative application ID:

Event Xml:

<Event xmlns="">


    <Provider Name="Application Error" />

   <EventID Qualifiers="0">1000</EventID>




    <TimeCreated SystemTime="2014-10-14T18:17:26.000000000Z" />




    <Security />













    <Data>C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\vpnui.exe</Data>

    <Data>C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\vpnapi.dll</Data>










I also have this issue on a IBM thinkpad


go to C:\Users\username\AppData\Local, delete folder "Cisco" and open vpn client again, the folder should be rebuild and cisco vpn client working fine.

Thanks DannyZeng9 - that worked for me!

I have the same issue. I deleted the file, restarted my Windows Surface Pro 2 (8.1) and still the same result as I can no longer connect.


Any one else still have this issue or a different resolution?

I just started getting this error on my WIndows 7 laptop last week and its really frustrating.

I have tried:

1. Uninstalling and reinstalling the latest version - 4.3.05017

2.Recreating my certificate

3. Deleting all related folders

4. Copying the profile.xml from another copy

5. Checking my admin rights on the files

Anyone got any other ideas?

Chris Thompson

Another Thinkpad user with the same problem - most likely started after this (patch) Tuesday.  Deleting the %userprofile%\appdata\local\Cisco does not reliably resolve the issue although it did work once or twice.


Problem signature:

Problem Event Name: APPCRASH

Application Name: vpnui.exe

Application Version:

Application Timestamp: 54c966f4

Fault Module Name: vpnapi.dll

Fault Module Version:

Fault Module Timestamp: 54c965ae

Exception Code: c0000005

Exception Offset: 00039be2

OS Version: 6.3.9600.

Locale ID: 1033

Additional Information 1: 5861

Additional Information 2: 5861822e1919d7c014bbb064c64908b2

Additional Information 3: a10f

Additional Information 4: a10ff7d2bb2516fdc753f9c34fc3b069

Read our privacy statement online:

If the online privacy statement is not available, please read our privacy statement offline:


Also having this issue after installing the latest windows updates/patches.  Deleting the %userprofile%\appdata\local\Cisco only works once, then you have to do it again, re-install, etc.  The problem is pretty widespread for us on variety of HP laptops.  

I opened a case with TAC and found that this problem is introduced by KB3023607 (a 2/10/15 security patch). It’s a bug in Windows 8.1 & Windows 7 (w/IE11 Installed) and Cisco is waiting on Microsoft to release a fix.  Here’s the BugID from Cisco:

Workaround #1: 
Close the Cisco AnyConnect Window and the taskbar mini-icon
Right click vpnui.exe in the 'Cisco AnyConnect Secure Mobility Client' folder. (C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\)
Click on the 'Run compatibility troubleshooter' button
Choose 'Try recommended settings'
The wizard suggests Windows 8 compatibility.
Click 'Test Program'. This will open the program.

Some customers have reported that they needed to also set up compatibility mode for the vpnagent.exe executable.

Workaround #2: 
Customers can uninstall the KB3023607 update from Microsoft. However, this will also remove any other security fixes provided by Microsoft as part of the update. This can be removed under:

Control Panel / Programs / Programs and Features, click "View installed updates" on the left and locate and uninstall the updated labeled with KB3023607. This update is not visible when you try to locate it through the Windows Update application's history as it appears to have been bundled with another update, but it is singly accessible via Control Panel as noted here.



Indeed, I am having the same issue since the Windows update and it's referenced in the following bug CSCus89729 :


The workaround of changing the compatibility mode of vpngui.exe is working fine. Let's wait for the Windows' fix :

"Microsoft is planning to release a Windows Update patch on 03/10/15 for this issue. Microsoft's dates are subject to change."

Yes that worked for me under Win 8.1  (Workaround #1) on v 3.1.05160 as had same issue after Feb MS Updates. Thanks - Bob.

I'll throw my hat in the "me too" ring. Deleting the file at %userprofile%\appdata\local\Cisco has worked so far, but must be deleted before every connection. What's strange is the file it recreates is exactly the same as what was there before.


I'm on Windows 8.1 Enterprise x64. I've tried initially with version 3.1.06073 of the AnyConnect client and still having the issue with 3.1.06079. I'm wont to blame patches from Microsoft in Februrary 2015 as well because that's around the time my issues started.


I just encountered this problem and almost sent the person's machine to be reimaged. I tried the following:

Uninstalling and re-installing
removing AnyConnect from registry (all things I could find that were related)
Researching and trying all fixes online (Including the hotfix, though Win7 so didn't apply)
Running compatibility mode on the .exe (Again Win7 but I tried it)
Nothing seems to work.

I did eventually get it to work. 

I stumbled into my fix. I logged in as the local administrator account (we use a domain) and tried the VPN. Received "Failed to load preferences" followed what I knew about that which lead to:

C:\ProgramData\Cisco\Cisco AnyConnect Secure Mobility Client\Profile

In here there was .xml file (Employee.xml, but I assume it could be named differently for different organizations). This xml file had lost all security permissions and it's owner.

I forced the Owner to be the local Administrators Group and re-added that same group to have Full Control. With the VPN client exited, I opened a CMD and ran "runas /user:[domain]\[users domain account] "C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\vpnui.exe"

ex. In CMD window:
C:\Windows\System>runas /user:DM\abc12345 "C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\vpnui.exe"

This ran the VPN client as the affected user while I was signed into the Admin profile. It ran successfully without the error. I signed out and had the user sign in as himself and test and it ran successfully signed into his profile.

Try looking in C:\ProgramData\Cisco\Cisco AnyConnect Secure Mobility Client\Profile for an xml file and check the security permissions to make sure they haven't been lost. Reset them if they have and have the user test afterwards.

For whatever reason, my system didn't have permission to this xml file.  I added permission so that I could delete it.  Reinstalled the client and a new xml file from my company showed up.  Everything works now.  Thanks for the tip! 

PS: I've watched this thread for over a year hoping for a fix that would work.  Glad it paid off.

Daggum.......lots of folks having this problem at work.  Thank you  houstonjosh

for the info , worked like a charm!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: