cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
722
Views
0
Helpful
2
Replies
Highlighted
Beginner

GSS stuck in "waiting for configuration data"

One of my clients have 2 GSS 4900 running ver 4.1(1)

I can not get the gss service running properly in the one running gssm-secondary. Gssm service looks like it starts but if I check "gss status" och "show system status" in it is waiting for configuration data

NTM-GSS-002.nt.se#show system-status

Cisco GSS - 4.1(1) GSSM - standby [Tue Nov 12 16:10:21 UTC 2013]

Registered to primary GSSM: 10.16.0.15

Routing component waiting for configuration data (wait a minute). [runmode = 3]

START  SERVER

16:01  Config Agent (crdirector) 

16:01  Config Server (crm)       

16:01  Database                  

16:01  GUI Server (tomcat)       

16:01  Node Manager              

16:01  Web Server (apache)       

Ping works fine between the the GSS:es and there is no firewall involved (both are located on the same ip subnet).

I did gss stop and then gss start. Waited for 24 hours but the status is the same.

If I run tcpdump on the secondary I can see TCP and UDP traffic between the primary and the secondary though all UDP packets have a bad checksum warning.

I have no idea on how to t-shoot this. Should I do gss disable,  remove this gss from the primary gssm and enable gss again in the  secondary?

Any takers?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Hi,

There seems to be some communication problem. You can do the following and see if GSS goes to runmode=5.

On the standby:

gss stop

gss disable

Then, go into the GUI of the GSSM and delete the standby GSS from the
resources tab 

Then go to standby:

gss enable gssm-standby x.x.x.x (IP of primary )

Then in the GUI of primary GSSM, you will again see the standby in the resources tab. Click on it, and check on the activate button, then hit submit. Make sure the standby goes to runmode 5 under "gss status" output.

If this doesn't work then you can try the below:

Go to the GUI of the GSSM and delete the standby GSS from the resources tab. 

On the standby:
gss stop
restore-factory-defaults

Make sure you have a console connection so you can do the initial config on the Standby
GSS (add IP, etc). Once done, enter standby:


gss enable gssm-standby x.x.x.x Then in the GUI of primary GSSM, you will again see the standby in the  resources tab.

Click on it, and check on the activate button, then hit submit. Make sure the standby goes to runmode 5.

Regards,

Kanwal

View solution in original post

2 REPLIES 2
Highlighted
Cisco Employee

Hi,

There seems to be some communication problem. You can do the following and see if GSS goes to runmode=5.

On the standby:

gss stop

gss disable

Then, go into the GUI of the GSSM and delete the standby GSS from the
resources tab 

Then go to standby:

gss enable gssm-standby x.x.x.x (IP of primary )

Then in the GUI of primary GSSM, you will again see the standby in the resources tab. Click on it, and check on the activate button, then hit submit. Make sure the standby goes to runmode 5 under "gss status" output.

If this doesn't work then you can try the below:

Go to the GUI of the GSSM and delete the standby GSS from the resources tab. 

On the standby:
gss stop
restore-factory-defaults

Make sure you have a console connection so you can do the initial config on the Standby
GSS (add IP, etc). Once done, enter standby:


gss enable gssm-standby x.x.x.x Then in the GUI of primary GSSM, you will again see the standby in the  resources tab.

Click on it, and check on the activate button, then hit submit. Make sure the standby goes to runmode 5.

Regards,

Kanwal

View solution in original post

Highlighted

Thanks a lot Kanwal! It was that last thing - activate the standby gss - we had forgot.

This widget could not be displayed.