cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
516
Views
0
Helpful
0
Replies
Highlighted

Reverse proxy problem

Hello.

I have a setup where a CSS is working with a content engine (WAE) to provide reverse proxy service to a web farm.

The problem is that although i see on the CSS the requests being redirected to the WAE, the engine does not retrieve

content from the web servers (there is connectivity with the farm). The configs i have are the following.

CSS:

service wae1
  type transparent-cache
  no cache-bypass
  ip address 10.70.1.10
  active

service web1
  keepalive type tcp
  keepalive port 80
  ip address 10.60.1.10
  active

service web2
  keepalive type tcp
  keepalive port 80
  ip address 10.60.1.11
  active

eql Cacheable
  extension jpeg

  extension gif
  extension jpg
  extension jpe
  extension txt

  extension doc

owner customer

  content reverse_proxy_rule
    add service wae1
    port 80
    protocol tcp
    url "/*" eql Cacheable
    vip address x.x.x.x

    active

  content second_rule
    add service web1
    add service web2
    protocol tcp
    port 80
    vip address x.x.x.x
    active

  content wae_miss_rule
    add service web1
    add service web2
    protocol tcp
    port 80
    url "/*"
    vip address 10.70.1.20
    active

And the WAE config is:

http proxy incoming 80
http max-ttl days text 1 binary 1
http proxy outgoing host 10.70.1.20 80 primary
http l4-switch enable

interface GigabitEthernet 1/0
ip address 10.70.1.10 255.255.255.0
exit

ip default-gateway 10.70.1.1

no bypass load enable

On the content engine i see the requests coming but the engine reports them all as "client errors".

See below.

WAE-Primary#sh stat http req
                              Statistics - Requests
                                                Total             % of Requests
                            ---------------------------------------------------
        Total Received Requests:     10                         -
                 Forced Reloads:           0                       0.0
                  Client Errors:              10                     100.0
                  Server Errors:               0                       0.0
            URL Blocked (Reset):         0                       0.0
                    URL Blocked:             0                       0.0
         Sent to Outgoing Proxy:          0                       0.0

These are the recommended configs i found on CCO.

Has anyone else made this work?

Thanks in advance

Kostas

0 REPLIES 0
Content for Community-Ad
This widget could not be displayed.