cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

866
Views
0
Helpful
10
Replies
JAMES HAYNES
Beginner

Virtual Server Operational Status

As a newbie to the ACE I was wondering if someone could explain the following behavior?

I am troubleshooting a connectivity issue where a Virtual Server has been setup associated with a ServerFarm.

The ServerFarm contains a single RealServer. This server has a Health Check via an SSL Layer 4 (443) probe.

When looking at the probe in ANM it says success. The ServerFarm in turn shows the server being probed with an Operational Status

of InService. If I then look at the Virtual Server associated with the ServerFarm it has a configured state of InService, but an Operational State of  N/A

and a last polled of N/A.

I don't understand this as the RealServer is up via the health check, and the ServerFarm shows this, but the Virtual Server doesn't indicate this.

Can anyone share any insight as to how this works?

Thanks for your help in advance.

10 REPLIES 10
Surya ARBY
Enthusiast

please post your config

Hi Surya,

I would love too but that would require alot of scrubbing as there are many company specific items configured.

I realize it would make things alot easier and I can try going through it to scrub, but I was just wondering what sorts

of things might cause the behavior and I could look at them.

So can you just post the config related to the port 443 ? with the output of the show probe detail command

I have cleaned up what you asked for.

Thanks for your help.

When you issue a "telnet ABC.DEF.GHI.JKL 82" do you get the prompt ?

Actually, if we go to the web site link without going through the ACE it works just fine.

I have tried telnetting from the ACE and I get connection refused.

I'm sorry Surya I am trying to do too many things at once.

The IP address with port 82 is the VIP that the outside site see all requests coming from.

So when someone wants to go to the web page in question they go to the ABC.DEF.GHI.JKL port 82 and the

ACE makes the conenction to the outside server

rserver host XXX-SSLINIT-TEST1

on port 443.

Sorry for the confusion.

Yes I understood that.

To be honest I don't see what's going wrong in your config

cpomeroy
Beginner

James,

It is possible that you are hitting bug CSCte12130.  The stated work around is to reboot the ACE.  However, you may want to open a TAC Case first.

Thanks,

Chris

Thanks all for the help. we figured out the problem.

The server team did not need two way auth like we were using previously and forgot to tell us.

So, once we found out we created a new ssl-proxy with no options and that worked like a charm.

Content for Community-Ad
This widget could not be displayed.