Showing results for 
Search instead for 
Did you mean: 

A question about using Jabber API on a sandbox server.

Cisco Employee
Cisco Employee


According to I can get info for two "jabber sandbox" user accounts via email. Who/where should I request these accounts from?

Thank you,


8 Replies 8


Hi Alex,

If you go to devNet sandbox here,

  1. 1. Login with your account/password (If not yet sign up, you will be asked to sign up)
  2. 2. Click on Available Now on the left side, then click on a little bubble icon on the bottom right  over “Shared Endpoint Lab”.
  3. 3. Click on “Reserve Now”, then “Reserve”
  4. 4. On your right side, you will see a list of commands, click on “Add_Jabber_SDK_for_Web”. Or, you can add something else such as Jabber for iPad, or for Windows (MAC address needed)
  5. 5. You will be receiving an email with VPN access and account name that’s created for you
  6. 6. If you wish to add another account, you will need to repeat step 2-4 to reserve again to be able to get to the commands

Please let me know if you have any question



Thank you for the info, Howard.

So I can navigate to the XMPP server now on my reserved lab and it gives me back the following:

This URI is for XMPP communication via the BOSH protocol.

Please reference the following protocols:

  • RFC 3920<>: Extensible Messaging and Presence Protocol (XMPP): Core

  • RFC 3921<>: Extensible Messaging and Presence Protocol (XMPP): Instant Messaging and Presence

  • XEP-0124<>: Bidirectional-streams Over Synchronous HTTP (BOSH)

  • XEP-0206<>: XMPP Over BOSH

This looks good. After reserving the instance I received two user-related credential sets - one for VPN access, the other is for connecting to the allocated device. I am guessing, I would use the latter to experiment with the XMPP server and jabber sample code. Assuming this is correct, I would expect the XMPP server accept the these credentials. Instead it produces an error to the tune of

When I use them to run the sample from the following page:

For the sake of it I have also tried to use the credentials that grant VPN access with the same result. So, it looks like the user/pass pair sent to me after reservation is not valid. Is this something you can help me to figure out or someone else or perhaps you can point me at some info to read that would help me figure this out?

Thank you very much,


Hi Alex,

The only thing you have to change from that page will be the BOSH URL. The BOSH url information should be in the email that you received I believe.

var demo_config = {

    domain: "",

    unsecureAllowed: true,

    httpBindingURL: ""


Give it a try with above setting and login with your account.

If you are still having issue, bring up the browser console logs (F12) post it here.



Yes, Howard, I have been using the server name that came with the email. It is the same name that you have in your code below. Needless to say, pasting your code into the demo html didn't yield anything different. The server still rejects the user/pass pair I received in email.

Is there a way to cancel my current lab reservation and repeat the process and make another reservation? Though, the server is clearly there, it just doesn't like the user/pass pair I'm giving it.



Could you please provide me your username to me? Let me check on the server to see what happened.


Here you go



For some reason the auto generated account didn't get to assign to CUP server.

I have manually added it and tested to make sure it's working fine now.

Please give it a try.



Hi ,

Could you do same for me too. I have not received the automated mail.



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: