cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3517
Views
0
Helpful
4
Replies

Cisco Jabber Bot - Rich Text (CSS - Bootstrap) Doesn't Work With Current Jabber Version?

A_
Beginner
Beginner

Hello,

 

since Cisco Jabber 12.0 we can use botkit for interaction with users. Cisco Jabber also supports HTML5 and CSS (Bootstrap) elements. With Cisco Jabber 12.0 there is no problem. But with Cisco Jabber 12.5.0 (and .1) I don't get the elements.Cisco Jabber 12.0 - "robot-submit" exampleCisco Jabber 12.0 - "robot-submit" exampleCisco Jabber 12.5 - "robot-submit" exampleCisco Jabber 12.5 - "robot-submit" example

As you can see in this picture, the examples from Cisco doesn't work with 12.5 (the yellow "Topics" was just a test). For both the same command and the same code were used.

 

Is this a bug or I'm missing something?

 

Thanks

 

 

2 Accepted Solutions

Accepted Solutions

dstaudt
Cisco Employee
Cisco Employee

This appears to affect Jabber Win/Mac versions >12.1, tracking via defect #s CSCvo27149 & CSCvo27156

View solution in original post

Add the  AdminConfiguredBot tag as per the document here. it appears only bots configured via the tag get to use the rich media features ( i mean robot-buttons etc.).. perhaps a security measure. It worked for me.

https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/jabber/12_1/cjab_b_parameters-reference-guide-for-cisco_12_1/cjab_b_parameters-reference-guide-for-cisco_12_1_chapter_0100.html#reference_2FE6D654BBC50867DFDB6703F971CE0C

View solution in original post

4 Replies 4

dstaudt
Cisco Employee
Cisco Employee

This appears to affect Jabber Win/Mac versions >12.1, tracking via defect #s CSCvo27149 & CSCvo27156

Thank you. It also doesn't work with Jabber 12.5(1). I will wait for an update

Defect https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvo27149 is changed to fixed with Cisco Jabber version 12.6.0.31246. I installed it, but it's still not working.

Add the  AdminConfiguredBot tag as per the document here. it appears only bots configured via the tag get to use the rich media features ( i mean robot-buttons etc.).. perhaps a security measure. It worked for me.

https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/jabber/12_1/cjab_b_parameters-reference-guide-for-cisco_12_1/cjab_b_parameters-reference-guide-for-cisco_12_1_chapter_0100.html#reference_2FE6D654BBC50867DFDB6703F971CE0C

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers