cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
944
Views
3
Helpful
7
Replies
Highlighted
Beginner

Problem with Path Trace

Hello,

I have problem with path trace, in one direction it can discover path of the flow and in another it can't. Problem is always in the same interface of the switch.

What could be wrong with the configuration of the switch or path trace?

Thank you in advance!

Path_Trace_fail_ 01.JPG

Path_Trace_fail_ 02.JPG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi gcheria,

problem was in lab network topology. We tried to make topology that would be compliant with IWAN app design. We tried to simulate LAN network in the Hub site over the switch that didn't work because layer 2 switch was between two layer 3 routers and path trace didn't work with that topology. We also tried to simulate the provider's VPNs with hubs. but we didn't have enough hubs to separate them, so routers had overlapping paths between them that confused path trace.

In the end we simplified network topology as in the following picture. We connected only one branch router on each hub router and now path trace works.

Capture4.PNG

View solution in original post

7 REPLIES 7
Highlighted
Cisco Employee

Hi Dominik,

  I need to discuss with my team and get back to you.

What I think is that while return path trace its taken as unknown device Please find page 19 of this url- http://www.cisco.com/assets/global/DK/seminarer/pdfs/cisco_tech_update_apic-em_sdn_18_og_20_august_2015.pdf

But one way it's  showing - not sure.

Thanks and Regards,

Geevarghese

Highlighted

Hi,

today after reseting APIC-em and discovery of all devices it shows only this error every time:

"Unable to construct path: 7ad10f68-159a-40a7-818a-d5b5d058ada9 : Topology information changed during Path Calculation. Path link is missing in topology"


Thank You for your time!


Capture.PNG

Highlighted

Hi Dominik,

  Can you please ensure that CDP is enabled on the interfaces that link the devices and  Also SNMP read on all devices.

Thanks and Regards,

Geevarghese

Highlighted

I checked CDP and SNMP read and it is all enabled.

Highlighted

Hi Dominik,

  If that is the case I need to get some expert advice. In mean time  would request to collect RCA logs  For that you need to ssh into APIC-EM and run "rca" command.Since the log file is large you may need to upload it to Dropbox and post here the shared URL.

Thanks and Regards,

Geevarghese

Highlighted

Do you see the "Managed" status on all the network devices in the inventory? If you see partial collection failure then some of the links may not have been discovered by APIC-EM.

Highlighted

Hi gcheria,

problem was in lab network topology. We tried to make topology that would be compliant with IWAN app design. We tried to simulate LAN network in the Hub site over the switch that didn't work because layer 2 switch was between two layer 3 routers and path trace didn't work with that topology. We also tried to simulate the provider's VPNs with hubs. but we didn't have enough hubs to separate them, so routers had overlapping paths between them that confused path trace.

In the end we simplified network topology as in the following picture. We connected only one branch router on each hub router and now path trace works.

Capture4.PNG

View solution in original post