cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1930
Views
0
Helpful
1
Replies
achan2012
Beginner

using python SDK

Hi,

I am new to UCS platform. I have been trying out the different programming interfaces to Cisco UCS XML API.

I am trying to get the Cisco Python SDK to work and running into the roadblocks.

i installed by running python3 setup.py install.

I followed the simple script in the documentation.

from UcsSdk import *

if __name__ == "__main__":

     handle = UcsHandle()

     handle.Login("10.7.193.10","mon","mon")

     handle.Logout()

The error i am getting is:

Traceback (most recent calls last):

   File "./testucs.py", lin 3, in <module>

          from UcsSdk import *

  File "/usr/local/lib/python3.3/dist-packages/UcsSdk/__init__.py", line 1, in <module>

          from MoMeta import _VersionMeda,_ManagedObjectMeta

ImportError: No module named 'MoMeta'

I can see MoMeta.py package in /usr/local/lib/python3.3/dist-packages/UcsSdk

I am running Ubuntu 13.04 with Python 3.3

Has anyone encountered this issue?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
reswaran
Cisco Employee

Hi Allen,

UCS SDK is compatible only with Python 2.x. There are lot of fundamental changes in python 3.x which breaks backward compatibility. More details on http://docs.python.org/3/whatsnew/3.0.html

SDK for python 3.x is in the plan. But we don't have any timeline yet.

Thanks,

Ravikumar

View solution in original post

1 REPLY 1
reswaran
Cisco Employee

Hi Allen,

UCS SDK is compatible only with Python 2.x. There are lot of fundamental changes in python 3.x which breaks backward compatibility. More details on http://docs.python.org/3/whatsnew/3.0.html

SDK for python 3.x is in the plan. But we don't have any timeline yet.

Thanks,

Ravikumar

View solution in original post

Content for Community-Ad
This widget could not be displayed.