09-05-2023 01:16 AM - edited 09-05-2023 03:50 AM
Hi everyone! Noob here,
I have a relatively simple question (I think).
We have a Core switch with a few different port-channels configured and we're adding two new switches to an adjacent office building. So here's the gist:
There's multiple port-channels configured on the core, can I use one that's already set to one other port?
Core port-channel:
interface Port-channel4
switchport trunk allowed vlan 10,30
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
Core interface:
interface TenGigabitEthernet2/1/4
description EXAMPLE-SW-1
switchport trunk allowed vlan 10,30
switchport mode trunk
switchport nonegotiate
channel-group 4 mode active
ip dhcp snooping trust
What I would want to do is instead of creating more channels on the core (not that it would hurt, probably) is use the channel group 4 which already exists on the core SW and configure it to another ports that'll go to the new SW's at the office. I obviously already did the channels on the two new switches but the same applies to those as well I guess, so I would also use the same channel groups on the new ones in the aforementioned manner.
Also related question, if I want to do a redundant connection with 2 interfaces configured from the new SW's to core SW, should I just do identical configurations on the new SW's interfaces and shutdown the secondary port or is there a more elegant way?
BR-
09-05-2023 03:56 AM
I take this way - you mean to say the Port-channel 4 already congfigured with ports (which is not Live ) and you want to connect to new Switch ( that is fine you can do that)
Make sure VLAN 10, 30 created on CORE and Edge switch for Layer 2 traffic to flow.
Also related question, if I want to do a redundant connection with 2 interfaces configured from the new SW's to core SW, should I just do identical configurations on the new SW's interfaces and shutdown the secondary port or is there a more elegant way?
i would not advise until they are going to different CORE switch, instead why not club all the ports in One Port-channel so you have more bandwidth and more high availability - rather shutdown and bring up as secondary link.
09-05-2023 10:45 PM
Hi! Thanks for your answer!
Maybe I was a bit unclear on how to word this, but I'll try again.
The core SW is live and operational, it has four port-channels configured one of which already carries over the correct Vlans for the two new SW's that they need. Port-channel 4, which I intended to use is already configured on the core stack on ports:
1/1/4 - Example-SW-1 (Channel 4)
2/1/4 - Example-SW-1 (Channel 4)
What I would like to do is configure four more ports on the core for the 2 new SW's, so there's 2 separate fiber connections going to each new switch from the core stack using the same port-channel. So in addition to the one already live and operational Example-SW-1 that is connected to the core stack and configured for port-channel 4 carrying over Vlan 10, 30, I would configure four more ports on the core to use the same port-channel and connect them, 2 for each new SW from the core.
Like so:
Existing port configurations on the core stack using channel 4 on a live SW:
interface TenGigabitEthernet1/1/4
description EXAMPLE-SW-1
switchport trunk allowed vlan 10,30
switchport mode trunk
switchport nonegotiate
channel-group 4 mode active
ip dhcp snooping trust
interface TenGigabitEthernet2/1/4
description EXAMPLE-SW-1
switchport trunk allowed vlan 10,30
switchport mode trunk
switchport nonegotiate
channel-group 4 mode active
ip dhcp snooping trust
New additions:
interface TenGigabitEthernet1/1/6
description NEW-SW-1
switchport trunk allowed vlan 10,30
switchport mode trunk
switchport nonegotiate
channel-group 4 mode active
ip dhcp snooping trust
interface TenGigabitEthernet1/1/7
description NEW-SW-2
switchport trunk allowed vlan 10,30
switchport mode trunk
switchport nonegotiate
channel-group 4 mode active
ip dhcp snooping trust
and
interface TenGigabitEthernet2/1/6
description NEW-SW-1
switchport trunk allowed vlan 10,30
switchport mode trunk
switchport nonegotiate
channel-group 4 mode active
ip dhcp snooping trust
interface TenGigabitEthernet2/1/7
description NEW-SW-2
switchport trunk allowed vlan 10,30
switchport mode trunk
switchport nonegotiate
channel-group 4 mode active
ip dhcp snooping trust
Using already configured port-channel on core:
interface Port-channel4
switchport trunk allowed vlan 10,30
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
The new SW's that are going to have 2SFP's occupied and connected to the available ports at the core stack SW's.
Regarding your last point about my question on shutting down the port, you're saying I should just leave the configs as is shown above and not shutdown the secondary link? So that all four ports are online simultaneously?
BR-
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide