cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Gateway Configuration Guide

534
Views
6
Helpful
6
Comments
Cisco Employee
6 Comments
Cisco Employee

Please be noted the commands related to “packet-forwarder” in this guide only work on Actility LRR, not other vendors’ packet-forwarder.

Hi Jun Wen,

I'm working with the IXM-LPWA-800-16-K9 LoRa gateway, where:

The system version is:

Corsica Software, Version 2.0.11, RELEASE SOFTWARE

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 2012-2014, 2017 by Cisco Systems, Inc.

Compiled 18-Sep-2017.16:19:04UTC-07:00 by Corsica Team

ROM: Bootstrap program is Corsica boot loader

Firmware Version  : 2.0.11, RELEASE SOFTWARE

Bootloader Version: 20170515_cisco

cisco model: IXM-LPWA-800-16-K9

Processor  : ARMv7 Processor rev 1 (v7l) with 1027308K bytes of memory.

The FPGA versione is:

INFO: SPI speed set to 2000000 Hz

checking FPGA version...

FPGA version: 58

HAL version: 5.0.0

SX1301 #0 version: 103

SX1301 #0 chip ID: 1

SX1301 #1 version: 103

SX1301 #1 chip ID: 1

##PASS: FPGA version check OK

The packet forwarder version is

PublicKeyStatus : Installed

FirmwareStatus : Installed

PacketFwdVersion : 1.8.19

LRRID : 68ba4729

PartnerID : 0001

If I perform the following command (from configure terminal):

packet-forwarder start

or

packet-forwarder restart

I have a Radio issue.

17:46:21.404  (1825) [../lgw_x8.c:733] RADIO configured

17:46:21.404  (1825) [../lgw_x8.c:755] RADIO starting ...

17:46:21.404  (1825) [../lgw_x8.c:760] BOARD0 RADIO cannot be started ret=-1 'Invalid version number for the top FPGA'



So the packet forwarder doesn't start.

How could I solve this issue?

Regards.

Cisco Employee

Please read the release notes of 2.0.11 for LRR support version.

Hi Jun,

no I didn't.

I found this packet forwarder version on the cisco gateway. I didn't perform any kind of upgrade.

How could I upgrade the pktfwd to the lastest 2.2.46?

best regards.

Cisco Employee

Hi Ivano,

We would expect that you receive Thingpark LRR package through your standard channel.

If not, please, send me an e-mail, I will forward you a no-config LRR package.

Regards

Patrick

Cisco Employee

Our software image never pre-install any LRR from manufacturing. No idea how you got this unit with LRR pre-installed, it is abnormal.

CreatePlease to create content
Ask the Expert- Webex Hybrid Services Solutions