cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

If your Cloud Collaboration question is not answered quickly, please email devsupport@webex.com for additional help

523
Views
0
Helpful
6
Replies
napalm699
Beginner

Webex XML DelUser API error with an unhelpful error message

Hello,

I am calling the DelUser API but am getting an error. I can deactivate the user through the web UI, but can not from the API.

I am POSTing to https://OMITTED.webex.com/WBXService/XMLService with a body of:

<?xml version="1.0"?>

<message xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://www.webex.com/schemas/2002/06/service">

  <header>

    <securityContext>

      <password xmlns="http://www.webex.com/schemas/2002/06/common">OMITTED</password>

      <siteName xmlns="http://www.webex.com/schemas/2002/06/common">OMITTED</siteName>

      <email xmlns="http://www.webex.com/schemas/2002/06/common">OMITTED</email>

    </securityContext>

  </header>

  <body>

    <bodyContent xmlns:q1="http://www.webex.com/schemas/2002/06/service/user" xsi:type="java:com.webex.service.binding.user.DelUser">

      <webExId>e@clouddev.test</webExId>

    </bodyContent>

  </body>

</message>

The response is:

<?xml version="1.0" encoding="UTF-8"?>

<serv:message xmlns:serv="http://www.webex.com/schemas/2002/06/service" xmlns:com="http://www.webex.com/schemas/2002/06/common" xmlns:use="http://www.webex.com/schemas/2002/06/service/user">

    <serv:header>

        <serv:response>

            <serv:result>FAILURE</serv:result>

            <serv:reason>validation: Null Point Error</serv:reason>

            <serv:gsbStatus>PRIMARY</serv:gsbStatus>

            <serv:exceptionID>000000</serv:exceptionID>

        </serv:response>

    </serv:header>

    <serv:body>

        <serv:bodyContent/>

    </serv:body>

</serv:message>

What does this error message mean? I know I am calling the API correctly because if I change "DelUser" to "GetUser", then I get the expected response.

1 ACCEPTED SOLUTION

Accepted Solutions
ryanhunt
Contributor

this behavior is a bug that is being fixed in our June release for XML 8.0.0 (it will actually roll out sometime in late July, I believe). Thanks for your patience.

View solution in original post

6 REPLIES 6
ryanhunt
Contributor

this behavior is a bug that is being fixed in our June release for XML 8.0.0 (it will actually roll out sometime in late July, I believe). Thanks for your patience.

View solution in original post

Thanks for the reply, is there a workaround for this?

Did we find out if there was a workaround for this? If not, do we know the exact date of the API update?

The work around would be logging into site admin and deleting/deactivating the account manually.

Are you getting this error on every user?

no exact dates are avilable at this time.

Yes this is happening for every user.

David,

Since we cant have private conversations on these forums, can you email webex-meetings-api-dev@cisco.com with the the same subject as this thread, and include your site-name so we can do some deeper investigation on your issue.

Regards,

-Ryan

Create
Recognize Your Peers
Content for Community-Ad