cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1221
Views
0
Helpful
2
Replies
yingguan
Beginner

Problem with vPC-HM vlan configuration

In Nexus1000v, the "VM-Uplink" ethernet port profile is set to "switchport truck allowed vlan 861-863" which is using vPC-HM with four vmnics, two sub-groups, two links to one upstream, and two for the another upstream switch . But on vCenter -> Home -> Inventory -> Networking -> then select the "Uplink" profile on left column of vSphere, then select "Ports" tab on main window, it shows three vmnics within under "VM-Uplink" profile show VLAN access:861-863, but one vmnics shows VLAN access: 1.

Supposed all vmnics within that port profile will show the same VLAN access:861-863. We fould that by removed and then re-add vmnic to that port profile "VM-Uplink", the VLAN status resumed normal  from VLAN 1 back to VLAN 861-863.

It is still unknown about how to trigger this.

2 REPLIES 2
Robert Burns
Cisco Employee

Please paste your running config.  Feel free to remove any sensitive information.

Thanks,

Robert

Here is the config.

Thanks.

Darren

version 4.2(1)SV1(4a)

no feature telnet

no feature http-server

feature tacacs+

username admin password 5 $XXXXXXX  role network-admin

banner motd #Nexus 1000v Switch#

ssh key rsa 2048

ip domain-lookup

ip domain-lookup

tacacs-server key 7 "XXXXXXXX"

tacacs-server host X.X.X.X

aaa group server tacacs+ tacacs

    server X.X.X.X

    use-vrf management

    source-interface mgmt0

switchname N1000V-03

ip access-list SNMP_TO_NMS

  10 permit ip X.X.X.X/32 any

  20 permit ip X.X.X.X/32 any

  30 permit ip X.X.X.X/32 any

  40 permit ip X.X.X.X/32 any

  50 permit ip X.X.X.X/32 any

vem 3

  host vmware id 35383339-3134-5347-4831-323058413135

vem 4

  host vmware id 35383339-3134-5347-4831-323058413133

vem 5

  host vmware id 34393433-3239-5347-4830-31395844324d

vem 6

  host vmware id 34393433-3239-5347-4830-313958443253

snmp-server source-interface trap loopback0

snmp-server source-interface inform loopback0

snmp-server user admin network-admin auth md5 X.X.X.X priv X.X.X.X localizedkey

snmp-server host X.X.X.X traps version 2c XXXXX

snmp-server community XXXXX group network-operator

snmp-server community XXXXX use-acl SNMP_TO_NMS

ntp server X.X.X.X prefer

aaa authentication login default group tacacs

aaa authentication login console local

vrf context management

  ip route 0.0.0.0/0 X.X.X.X

vlan 1,844,851,861-863,871-878

port-channel load-balance ethernet source-dest-ip-vlan

port-profile default max-ports 253

port-profile type ethernet Unused_Or_Quarantine_Uplink

  vmware port-group

  shutdown

  max-ports 32

  description Port-group created for Nexus1000V internal usage. Do not use.

  state enabled

port-profile type vethernet Unused_Or_Quarantine_Veth

  vmware port-group

  shutdown

  max-ports 32

  description Port-group created for Nexus1000V internal usage. Do not use.

  state enabled

port-profile type ethernet VEM-Uplink

  vmware port-group

  switchport mode trunk

  switchport trunk allowed vlan 851

  cdp enable

  speed 1000

  duplex full

  channel-group auto mode on mac-pinning

  no shutdown

  system vlan 851

  max-ports 32

  description Connection to VSM

  state enabled

port-profile type ethernet UTM-VLAN-Uplink

  vmware port-group

  switchport mode trunk

  switchport trunk allowed vlan 861-863

  channel-group auto mode on sub-group manual

  no shutdown

  max-ports 32

  description Uplink profile for vlan 861-863 traffic

  state enabled

port-profile type ethernet NetBackup-Uplink

  vmware port-group

  switchport mode trunk

  switchport trunk allowed vlan 844

  no shutdown

  max-ports 32

  description Uplink profile for NetBackup-Uplink

  state enabled

port-profile type ethernet FW-VLAN-Uplink

  vmware port-group

  switchport mode trunk

  switchport trunk allowed vlan 871-878

  channel-group auto mode on sub-group manual

  no shutdown

  max-ports 32

  description Uplink profile for FW-VLAN-Uplink

  state enabled

port-profile type vethernet VLAN-861

  vmware port-group

  switchport mode access

  switchport access vlan 861

  no shutdown

  state enabled

port-profile type vethernet VLAN-862

  vmware port-group

  switchport mode access

  switchport access vlan 862

  no shutdown

  state enabled

port-profile type vethernet VLAN-863

  vmware port-group

  switchport mode access

  switchport access vlan 863

  no shutdown

  state enabled

port-profile type vethernet VLAN-844

  vmware port-group

  switchport mode access

  switchport access vlan 844

  no shutdown

  description NetBackup Network

  state enabled

port-profile type vethernet VLAN-871

  vmware port-group

  switchport mode access

  switchport access vlan 871

  no shutdown

  state enabled

port-profile type vethernet VLAN-872

  vmware port-group

  switchport mode access

  switchport access vlan 872

  no shutdown

  state enabled

port-profile type vethernet VLAN-873

  vmware port-group

  switchport mode access

  switchport access vlan 873

  no shutdown

  state enabled

port-profile type vethernet VLAN-874

  vmware port-group

  switchport mode access

  switchport access vlan 874

  no shutdown

  state enabled

port-profile type vethernet VLAN-875

  vmware port-group

  switchport mode access

  switchport access vlan 875

  no shutdown

  state enabled

port-profile type vethernet VLAN-876

  vmware port-group

  switchport mode access

  switchport access vlan 876

  no shutdown

  state enabled

port-profile type vethernet VLAN-877

  vmware port-group

  switchport mode access

  switchport access vlan 877

  no shutdown

  state enabled

port-profile type vethernet VLAN-878

  vmware port-group

  switchport mode access

  switchport access vlan 878

  no shutdown

  state enabled

vdc SVTN1000V-03 id 1

  limit-resource vlan minimum 16 maximum 2049

  limit-resource monitor-session minimum 0 maximum 2

  limit-resource vrf minimum 16 maximum 8192

  limit-resource port-channel minimum 0 maximum 768

  limit-resource u4route-mem minimum 32 maximum 32

  limit-resource u6route-mem minimum 16 maximum 16

  limit-resource m4route-mem minimum 58 maximum 58

  limit-resource m6route-mem minimum 8 maximum 8

interface port-channel1

  inherit port-profile UTM-VLAN-Uplink

  vem 3

  description XXXXXXXX-07 UTM-VLAN-Uplink

interface port-channel2

  inherit port-profile VEM-Uplink

  vem 3

  no shutdown

interface port-channel3

  inherit port-profile FW-VLAN-Uplink

  vem 3

  description XXXXXXXX-07 FW-VLAN-Uplink

interface port-channel4

  inherit port-profile VEM-Uplink

  vem 4

interface port-channel5

  inherit port-profile UTM-VLAN-Uplink

  vem 4

  description XXXXXXXX-06 UTM-VLAN-Uplink

interface port-channel6

  inherit port-profile FW-VLAN-Uplink

  vem 4

  description XXXXXXXX-06 FW-VLAN-Uplink

interface port-channel7

  inherit port-profile FW-VLAN-Uplink

  vem 5

  description XXXXXXXX-03 FW-VLAN-Uplink

interface port-channel8

  inherit port-profile VEM-Uplink

  vem 5

interface port-channel9

  inherit port-profile UTM-VLAN-Uplink

  vem 5

  description XXXXXXXX-03 UTM-VLAN-Uplink

interface port-channel10

  inherit port-profile FW-VLAN-Uplink

  vem 6

  description XXXXXXXX-04 FW-VLAN-Uplink

interface port-channel11

  inherit port-profile VEM-Uplink

  vem 6

interface port-channel12

  inherit port-profile UTM-VLAN-Uplink

  vem 6

  description XXXXXXXX-04 UTM-VLAN-Uplink

port-channel cdp-map XXXXXXXXXXXX 0

interface mgmt0

  ip address XXXXXX/24

interface loopback0

  ip address XXXXXX/32

interface Vethernet1

  inherit port-profile VLAN-871

  description XXXXXX, Network Adapter 1

  vmware dvport 1500 dvswitch uuid "XXXXXX"

  vmware vm mac XXXXXX

interface Vethernet2

  inherit port-profile VLAN-862

  description XXXXXX, Network Adapter 1

  vmware dvport 626 dvswitch uuid "XXXXXX"

  vmware vm mac XXXXXX

interface Vethernet3

  inherit port-profile VLAN-871

  description XXXXXX, Network Adapter 1

  vmware dvport 256 dvswitch uuid "XXXXXX"

  vmware vm mac XXXXXX

interface Vethernet4

  inherit port-profile VLAN-871

  description XXXXXX, Network Adapter 1

  vmware dvport 258 dvswitch uuid "XXXXXX"

  vmware vm mac XXXXXX

interface Ethernet3/8

  inherit port-profile VEM-Uplink

  description XXXXXXXX-07 VEM-Uplink-XXXXXX

interface Ethernet3/9

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-07 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 1

interface Ethernet3/10

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-07 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 1

interface Ethernet3/12

  inherit port-profile FW-VLAN-Uplink

  description XXXXXXXX-07 FW-VLAN-Uplink-XXXXXX

  sub-group-id 1

interface Ethernet3/13

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-07 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 2

interface Ethernet3/14

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-07 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 2

interface Ethernet3/15

  inherit port-profile VEM-Uplink

  description XXXXXXXX-07 VEM-Uplink-XXXXXX

interface Ethernet3/16

  inherit port-profile FW-VLAN-Uplink

  description XXXXXXXX-07 FW-VLAN-Uplink-XXXXXX

  sub-group-id 2

interface Ethernet4/8

  inherit port-profile VEM-Uplink

  description XXXXXXXX-06 VEM-Uplink-XXXXXX

interface Ethernet4/9

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-06 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 1

interface Ethernet4/10

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-06 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 1

interface Ethernet4/12

  inherit port-profile FW-VLAN-Uplink

  description XXXXXXXX-06 FW-VLAN-Uplink-XXXXXX

  sub-group-id 1

interface Ethernet4/13

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-06 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 2

interface Ethernet4/14

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-06 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 2

interface Ethernet4/15

  inherit port-profile VEM-Uplink

  description XXXXXXXX-06 VEM-Uplink-XXXXXX

interface Ethernet4/16

  inherit port-profile FW-VLAN-Uplink

  description XXXXXXXX-06 FW-VLAN-Uplink-XXXXXX

  sub-group-id 2

interface Ethernet5/8

  inherit port-profile VEM-Uplink

  description XXXXXXXX-03 VEM-Uplink-XXXXXX

interface Ethernet5/9

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-03 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 1

interface Ethernet5/10

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-03 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 2

interface Ethernet5/12

  inherit port-profile FW-VLAN-Uplink

  description XXXXXXXX-03 FW-VLAN-Uplink-XXXXXX

  sub-group-id 1

interface Ethernet5/13

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-03 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 1

interface Ethernet5/14

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-03 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 2

interface Ethernet5/15

  inherit port-profile VEM-Uplink

  description XXXXXXXX-03 VEM-Uplink-XXXXXX

interface Ethernet5/16

  inherit port-profile FW-VLAN-Uplink

  description XXXXXXXX-03 FW-VLAN-Uplink-XXXXXX

  sub-group-id 2

interface Ethernet6/8

  inherit port-profile VEM-Uplink

  description XXXXXXXX-04 VEM-Uplink-XXXXXX

interface Ethernet6/9

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-04 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 1

interface Ethernet6/10

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-04 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 2

interface Ethernet6/12

  inherit port-profile FW-VLAN-Uplink

  description XXXXXXXX-04 FW-VLAN-Uplink-XXXXXX

  sub-group-id 1

interface Ethernet6/13

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-04 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 1

interface Ethernet6/14

  inherit port-profile UTM-VLAN-Uplink

  description XXXXXXXX-04 UTM-VLAN-Uplink-XXXXXX

  sub-group-id 2

interface Ethernet6/15

  inherit port-profile VEM-Uplink

  description XXXXXXXX-04 VEM-Uplink-XXXXXX

interface Ethernet6/16

  inherit port-profile FW-VLAN-Uplink

  description XXXXXXXX-04 FW-VLAN-Uplink-XXXXXX

  sub-group-id 2

interface control0

clock timezone HKT 8 0

line vty

  exec-timeout 5

line console

  exec-timeout 1

boot kickstart bootflash:/nexus-1000v-kickstart-mz.4.2.1.SV1.4a.bin sup-1

boot system bootflash:/nexus-1000v-mz.4.2.1.SV1.4a.bin sup-1

boot kickstart bootflash:/nexus-1000v-kickstart-mz.4.2.1.SV1.4a.bin sup-2

boot system bootflash:/nexus-1000v-mz.4.2.1.SV1.4a.bin sup-2

svs-domain

  domain id 3841

  control vlan 851

  packet vlan 851

  svs mode L2 

svs connection VC

  protocol vmware-vim

  remote ip address X.X.X.X port 80

  vmware dvs uuid "5b 58 39 50 6e 16 ef de-e1 8a 45 84 07 c5 7b 32" datacenter-name XXXXXX

  max-ports 8192

  connect

vsn type vsg global

  tcp state-checks

vnm-policy-agent

  registration-ip 0.0.0.0

  shared-secret **********

  log-level

N1000V-03# exit