cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
232
Views
30
Helpful
6
Replies
Highlighted
Beginner

Trouble changing credentials

Hello

I'm a junior network engineer and i'm having issues changing the snmp credentials on a 9000 series.

I'm trying to change SNMP credentials and get the following error.

I don't know what the problem is and can't seem to fix this.

snm.png

Does it expect a hash value for the auth and priv?

Any help is greatly appreciated.

Thanks in advance!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi @fmoghimi 

 It's expected behavior.  Localized key simply means password encrypted and in HEX format. In the running config you will see the snmp-user password always with localized key format password.

The only thing you should be careful: when you configure a snmp user, automatically, NXOS will create a username with it which can be used for switch management. However, if you configure the snmp user using localized key format (like for example copy pasting the command on multiple switches), if there is already a username created for that snmp user, the command will not synchronize the password with it.

 

Stay safe,

Sergiu

 

 

View solution in original post

6 REPLIES 6
Highlighted
Rising star

Saludos SNMP es un protocolo que ayuda al gestión de información entre dispositivos de redes, pero en muchos caso se ha visto que proporcionan una seguridad Debil, exite una mejora en la versión SNMP3 para el caso del Cisco 9000 te cargo un link done aparece el paso a paso para configurar el SNMP en el disposotivo.

Recurda calificar esta respuesta ya que esto motiva a seguir apoyando en la comunidad.

 

 

https://www.cisco.com/en/US/docs/storage/san_switches/mds9000/sw/rel_3_x/configuration/guides/cli_3_3_1/snmp.html#wp1351705

 

Saludos 

Highlighted
Beginner

Yes the thing is, the switch is asking for hexadecimal format even when I don't use the 'localizedkey' at the end of the command.

Highlighted
VIP Engager

Hi @fmoghimi 

It asks for a localized key, and implicitly for a HEX value, because most likely the user is already created with "localizedkey"

Use the "show run | grep <username>" command (so in your case " show run | grep admin256 ") and see if the user is already present.

 

Cheers,

Sergiu

Highlighted

Thank you, I tried that and I saw the user was created with localizedkey.

So I deleted the user and then I tried to make a new one without, and used the "show run | grep SIadmin" command and it also showed with localizedkey.

So it seems that it automatically creates the snmp user with localized key even if I dont tell it to.

Is this a bug or a setting that I need to turn off?

Thanks!

Highlighted

Hi @fmoghimi 

 It's expected behavior.  Localized key simply means password encrypted and in HEX format. In the running config you will see the snmp-user password always with localized key format password.

The only thing you should be careful: when you configure a snmp user, automatically, NXOS will create a username with it which can be used for switch management. However, if you configure the snmp user using localized key format (like for example copy pasting the command on multiple switches), if there is already a username created for that snmp user, the command will not synchronize the password with it.

 

Stay safe,

Sergiu

 

 

View solution in original post

Highlighted

Thank you!

I'll just delete the user and make it again with the new credentials.

Seems to work.

Thanks again.

Content for Community-Ad