cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
692
Visitas
5
ÚTIL
6
Respuestas
Carmen
Beginner

Ayuda, Todos los switch de la red trabajan bien pero no consigo conectar uno por el puerto troncal

Buenas tardes, necesito la ayuda de la comunidad de nuevo, así que muchas gracias de antemano por estar ahí.

Sé que es muy largo el mensaje, he intentado poner toda la información que creo relevante. Ya no se me ocurre nada máa así que espero que puedan darme algo de luz.

Estoy configurando una red en la que un switch 3750 es el equipo central de la red, y a él se conectan en estrella varios switch 2960 y 3560.

cada uno de los switch está configurado para ofrecer una vlan básicamente, con alguna excepción.

El problema que tengo es que el switch que ofrece la vlan 120 no se conecta al switch central 3750.

He hecho muchos intentos por solucionarlo y no funciona ninguno:

  • El cableado está bien,
  • No es problema físico del switch porque lo he cambiado por otro (3560 y 2960) con la misma configuración varias veces (poniéndole la misma imagen IOS y poniéndole otra distinta) y sigue igual,
  • He cambiado de puerto en el 3750 y en el que no se conecta, incluso he conectado el switch a uno de los troncales del switch central que funcionan con otros
  • Inicialmente se conecta  y toma la configuración VLAN y MSTP por VTP, pero después no vuelve a conectarse más, por lo que creo que el problema está ahí, aunque la configuración es igual al resto de switch de la red.

El resultado siempre es el mismo, desde todos los switch hago ping al central menos del switch del aula B12.

 

Configuración del switch que tengo ahora conectado al central, un Catalyst 2960 Series:

Version IOD

 

Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
* 1 26     WS-C2960-24TT-L      12.2(55)SE12      C2960-LANBASEK9-M

 

running-config:

Current configuration : 6788 bytes
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
hostname RPB12-SW1
boot-start-marker
boot-end-marker
enable secret 5 $1$iUfD$WSlcfArxwQb5bwBlzRCFA0
username admin privilege 15 password 7 052A040C25
no aaa new-model
clock timezone CET 1
clock summer-time CET recurring last Sun Mar 2:00 last Sun Oct 3:00
system mtu routing 1500
no ip domain-lookup
ip domain-name ciclos.local
spanning-tree mode mst
spanning-tree extend system-id
spanning-tree mst configuration
name MSTP
revision 1
instance 1 vlan 10, 20, 33, 44, 55
instance 2 vlan 80, 90, 110, 120, 130, 140, 150
vlan internal allocation policy ascending
ip ssh time-out 30
ip ssh version 2
interface FastEthernet0/1
 description Interfaz de acceso a la VLAN 120 AULA12
 switchport access vlan 120
 switchport mode access
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
.......

interface FastEthernet0/24
 description Interfaz de Administracion
 switchport access vlan 55
 switchport mode access
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable

interface GigabitEthernet0/1
 description Interfaz troncal con switch RPrincipal-SW1
 switchport trunk native vlan 44
 switchport trunk allowed vlan 2-32,34-4094
switchport mode trunk
interface GigabitEthernet0/2
 description Interfaz de conexion del punto de acceso para docentes RPB12-AP1
 switchport access vlan 20
 switchport mode access
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
interface Vlan55
 description Interfaz para administracion
 ip address 10.55.0.12 255.255.255.224


ip http server
ip http secure-server
vstack
banner motd ^C
Este es un sitio seguro. Solo se permiten usuarios autorizados.
Para acceder, pongase en contacto con el soporte tecnico.
^C
line con 0
 password 7 013204075F
 logging synchronous
 login

line vty 0 4
 password 7 1543595F50
 logging synchronous
 login local
 transport input ssh
line vty 5 15
 no login
 transport input ssh


ntp source Vlan55
ntp server 10.55.0.1
end

 

Interfaces troncales en 2960

RPB12-SW1#sh int trun

Port Mode Encapsulation Status Native vlan
Gi0/1 on 802.1q trunking 44

Port Vlans allowed on trunk
Gi0/1 2-32,34-4094

Port Vlans allowed and active in management domain
Gi0/1 10,20,55,80,90,110,120,130,140,150

Port Vlans in spanning tree forwarding state and not pruned
Gi0/1 10,20,55,80,90,110,120,130,140,150

 

VTP Status

RPB12-SW1#sh vtp status
VTP Version capable : 1 to 3
VTP version running : 3
VTP Domain Name : Dpto-Inf
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 0024.9871.a400

Feature VLAN:
--------------
VTP Operating Mode : Client
Number of existing VLANs : 16
Number of existing extended VLANs : 0
Configuration Revision : 5
Primary ID : 9caf.ca2f.e380
Primary Description : RPrincipal-ML1
MD5 digest : 0x1E 0x58 0xF8 0xC1 0x8A 0x07 0x00 0x6E
0xD4 0x2E 0xD1 0x60 0xB3 0x22 0xA6 0x44


Feature MST:
--------------
VTP Operating Mode : Client
Configuration Revision : 2
Primary ID : 9caf.ca2f.e380
Primary Description : RPrincipal-ML1
MD5 digest : 0xD3 0x2C 0xC3 0x2F 0xF3 0xFA 0x01 0xE2
0xD5 0x21 0x8B 0x43 0x3F 0x20 0x3E 0xC0


Feature UNKNOWN:
--------------
VTP Operating Mode : Transparent

 

VLAN

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active
10 SERVICIOS active
20 DOCENTES active Gi0/2
33 DESUSO suspended
55 ADMINISTRACION active Fa0/24
80 AULAB08 active
90 AULAB09 active
110 AULAB11 active
120 AULAB12 active Fa0/1, Fa0/2, Fa0/3, Fa0/4,Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12,Fa0/13, Fa0/14, Fa0/15, Fa0/16,Fa0/17, Fa0/18, Fa0/19, Fa0/20,Fa0/21, Fa0/22, Fa0/23
130 AULAB13 active
140 AULAB14 active
150 AULAB15 active
1002 fddi-default act/unsup
1003 trcrf-default act/unsup
1004 fddinet-default act/unsup

 

MST conf 

Name [MSTP]
Revision 1 Instances configured 3

Instance Vlans mapped
-------- ---------------------------------------------------------------------
0 1-9,11-19,21-32,34-43,45-54,56-79,81-89,91-109,111-119,121-129
131-139,141-149,151-4094
1 10,20,33,44,55
2 80,90,110,120,130,140,150

 

Configuración del switch central 3750E:

Version IOS

Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
* 1 54    WS-C3750E-48TD     15.2(4)E10     C3750E-UNIVERSALK9-M

 

Running-config

Current configuration : 15079 bytes
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
hostname RPrincipal-ML1
boot-start-marker
boot-end-marker
enable secret 5 $1$jaK0$DxuRh11JeO1R7uB2fiSxg1
username admin privilege 15 password 7 106F0B1A01
no aaa new-model
clock timezone CET 1 0
clock summer-time CET recurring last Sun Mar 2:00 last Sun Oct 3:00
switch 1 provision ws-c3750e-48td
system mtu routing 1500
ip routing
ip dhcp excluded-address 10.2.0.1 10.2.0.10
ip dhcp excluded-address 10.2.0.250 10.2.0.254
ip dhcp excluded-address 10.8.0.1 10.8.0.200
ip dhcp excluded-address 10.8.0.254
ip dhcp excluded-address 10.9.0.1 10.9.0.200
ip dhcp excluded-address 10.9.0.254
ip dhcp excluded-address 10.11.0.1 10.11.0.200
ip dhcp excluded-address 10.11.0.254
ip dhcp excluded-address 10.12.0.1 10.12.0.200
ip dhcp excluded-address 10.12.0.254
ip dhcp excluded-address 10.14.0.1 10.14.0.200
ip dhcp excluded-address 10.14.0.254
ip dhcp excluded-address 10.15.0.1 10.15.0.200
ip dhcp excluded-address 10.15.0.254
ip dhcp pool DHCPDocentes
network 10.2.0.0 255.255.255.0
default-router 10.2.0.254
dns-server 10.1.0.1
ip dhcp pool DHCPAULAB14
network 10.14.0.0 255.255.255.0
default-router 10.14.0.254
dns-server 10.1.0.1
ip dhcp pool DHCPAULAB08
network 10.8.0.0 255.255.255.0
default-router 10.8.0.254
dns-server 10.1.0.1
ip dhcp pool DHCPAULAB09
network 10.9.0.0 255.255.255.0
default-router 10.9.0.254
dns-server 10.1.0.1
ip dhcp pool DHCPAULAB11
network 10.11.0.0 255.255.255.0
default-router 10.11.0.254
dns-server 10.1.0.1
ip dhcp pool DHCPAULAB15
network 10.15.0.0 255.255.255.0
default-router 10.15.0.254
dns-server 10.1.0.1
no ip domain-lookup
ip domain-name ciclos.local
crypto pki trustpoint TP-self-signed-3392136064
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3392136064
revocation-check none
rsakeypair TP-self-signed-3392136064
crypto pki certificate chain TP-self-signed-3392136064
spanning-tree mode mst
spanning-tree extend system-id
spanning-tree mst configuration
 name MSTP
 revision 1
 instance 1 vlan 10, 20, 33, 44, 55
 instance 2 vlan 80, 90, 110, 120, 130, 140, 150
spanning-tree mst 0-1 priority 28672
spanning-tree mst 2 priority 24576
vlan internal allocation policy ascending
interface FastEthernet0
 no ip address
 no ip route-cache
 shutdown
interface GigabitEthernet1/0/1
 description conexion a internet
 no switchport
 ip address 192.168.1.254 255.255.255.0
interface GigabitEthernet1/0/2
 description Interfaz Servidor
 switchport access vlan 10
 switchport mode access
 no cdp enable
 spanning-tree portfast edge
 spanning-tree bpduguard enable
interface GigabitEthernet1/0/3
 description Interfaz Servidor
 switchport access vlan 10
 switchport mode access
 no cdp enable
 spanning-tree portfast edge
 spanning-tree bpduguard enable
interface GigabitEthernet1/0/4

 description Interfaz no utilizada
 switchport access vlan 33
 switchport 

 mode access
 shutdown
 no cdp enable
 spanning-tree portfast edge
 spanning-tree bpduguard enable
.....
interface GigabitEthernet1/0/8
 description Interfaz troncal con switch Cisco 2960 50P RPB08-SW1
 switchport trunk allowed vlan 2-32,34-4094
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 44
 switchport trunk pruning vlan 10-20,90-150
 switchport mode trunk
 switchport nonegotiate
interface GigabitEthernet1/0/9
 description Interfaz troncal con switch Cisco 2960 50P RPB09-SW1
 switchport trunk allowed vlan 2-32,34-4094
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 44
 switchport trunk pruning vlan 10-20,80,110-150
 switchport mode trunk
 switchport nonegotiate

....
interface GigabitEthernet1/0/11
 description Interfaz troncal con switch Cisco 3560 24P 1SFP RPB11-SW1
 switchport trunk allowed vlan 2-32,34-4094
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 44
 switchport trunk pruning vlan 10,80-90,120-150
 switchport mode trunk
 switchport nonegotiate
interface GigabitEthernet1/0/12
 description Interfaz troncal con switch Cisco ... AULAB12
 switchport trunk allowed vlan 2-32,34-4094
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 44
 switchport trunk pruning vlan 10,80-110,130-150
 switchport mode trunk
 switchport nonegotiate
interface GigabitEthernet1/0/13
 description Interfaz de acceso con el switch KTI no administrable RPB13-SW1
 switchport access vlan 130
 switchport mode access
 no cdp enable
 spanning-tree portfast edge
 spanning-tree bpduguard enable
interface GigabitEthernet1/0/14
 description Interfaz troncal con switch Cisco 2960 24P 100Mbps 2P 1Gbps RPB14-SW1
 switchport trunk allowed vlan 2-32,34-4094
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 44
 switchport trunk pruning vlan 10-20,80-130,150
 switchport mode trunk
 switchport nonegotiate
interface GigabitEthernet1/0/15
 description Interfaz troncal con switch switch Cisco 2960 24P 100Mbps 2P 1Gbps RPB15-SW1
 switchport trunk allowed vlan 2-32,34-4094
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 44
 switchport trunk pruning vlan 10-20,80-140
 switchport mode trunk
 switchport nonegotiate
...
interface GigabitEthernet1/0/47
 description Interfaz Punto de Acceso para Docentes CSR-AP1
 switchport access vlan 20
 switchport mode access
 no cdp enable
 spanning-tree portfast edge
 spanning-tree bpduguard enable
interface GigabitEthernet1/0/48
 description Interfaz para administracion del switch
 switchport access vlan 55
 switchport mode access
 no cdp enable
 spanning-tree portfast edge
 spanning-tree bpduguard enable
interface GigabitEthernet1/0/49
interface GigabitEthernet1/0/50
interface GigabitEthernet1/0/51
interface GigabitEthernet1/0/52
interface TenGigabitEthernet1/0/1
interface TenGigabitEthernet1/0/2
interface Vlan1
no ip address

interface VLAN10
 description Interfaz Puerta Enlace VLAN 10
 ip address 10.1.0.14 255.255.255.240
interface Vlan20
 description Interfaz Puerta Enlace VLAN 20
 ip address 10.2.0.254 255.255.255.0
interface Vlan55
 description Interfaz para administracion
 ip address 10.55.0.1 255.255.255.224
interface Vlan80
 description Interfaz Puerta Enlace VLAN 80
 ip address 10.8.0.254 255.255.255.0
interface Vlan90
 description Interfaz Puerta Enlace VLAN 90
 ip address 10.9.0.254 255.255.255.0
interface Vlan110
 description Interfaz Puerta Enlace VLAN 110
 ip address 10.11.0.254 255.255.255.0
interface Vlan120
 description Interfaz Puerta Enlace VLAN 120
 ip address 10.12.0.254 255.255.255.0
interface Vlan130
 description Interfaz Puerta Enlace VLAN 130
 ip address 10.13.0.254 255.255.255.0
interface Vlan140
 description Interfaz Puerta Enlace VLAN 140
 ip address 10.14.0.254 255.255.255.0
interface Vlan150
 description Interfaz Puerta Enlace VLAN 150
 ip address 10.15.0.254 255.255.255.0
ip forward-protocol nd
ip http server
ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip ssh version 2
banner motd ^C
Este es un sitio seguro. Solo se permiten usuarios autorizados.
Para acceder, pongase en contacto con el soporte tecnico.
^C
line con 0
password 7 0025110500
logging synchronous
login
line vty 0 4
logging synchronous
login local
transport input ssh
line vty 5 15
no login
transport input ssh
ntp master 2
ntp server 162.159.200.1
ntp server 5.56.160.3
ntp server 162.159.200.123
ntp server 81.19.96.148
ntp server 150.214.94.5
ntp server 51.105.208.173
pnp profile pnp_cco_profile
transport https host devicehelper.cisco.com port 443
end

Interfaces troncales en 3750

RPrincipal-ML1#sh int trun

Port Mode Encapsulation Status Native vlan
Gi1/0/8 on 802.1q trunking 44
Gi1/0/9 on 802.1q trunking 44
Gi1/0/11 on 802.1q trunking 44
Gi1/0/12 on 802.1q trunking 44
Gi1/0/14 on 802.1q trunking 44
Gi1/0/15 on 802.1q trunking 44

Port Vlans allowed on trunk
Gi1/0/8 2-32,34-4094
Gi1/0/9 2-32,34-4094
Gi1/0/11 2-32,34-4094
Gi1/0/12 2-32,34-4094
Gi1/0/14 2-32,34-4094
Gi1/0/15 2-32,34-4094

Port Vlans allowed and active in management domain
Gi1/0/8 10,20,55,80,90,110,120,130,140,150
Gi1/0/9 10,20,55,80,90,110,120,130,140,150
Gi1/0/11 10,20,55,80,90,110,120,130,140,150
Gi1/0/12 10,20,55,80,90,110,120,130,140,150
Gi1/0/14 10,20,55,80,90,110,120,130,140,150

Port Vlans allowed and active in management domain
Gi1/0/15 10,20,55,80,90,110,120,130,140,150

Port Vlans in spanning tree forwarding state and not pruned
Gi1/0/8 10,20,55,80,90,110,120,130,140,150
Gi1/0/9 10,20,55,80,90,110,120,130,140,150
Gi1/0/11 10,20,55,80,90,110,120,130,140,150
Gi1/0/12 none
Gi1/0/14 10,20,55,80,90,110,120,130,140,150
Gi1/0/15 10,20,55,80,90,110,120,130,140,150
RPrincipal-ML1#

1 SOLUCIÓN ACEPTADA

Soluciones aceptadas

Por si al alguien le viene bien, tras un apagón de luz la solución de deshabilitar MST y poner Rapid-PVST tampoco funcionó. Ya había cambiado un 3560 por el 2960 y ahora he vuelto a intentar el cambio poniendo otro 3750 y funciona todo perfectamente con MST.  

Para mi sigue siendo un misterio, lo único que cambia es que el último switch tiene puertos GigabitEthernet mientras que los otros eran FastEthernet. 

 

Ver la solución en mensaje original publicado

6 RESPUESTAS 6
Carmen
Beginner

He encontrado que MSTP bloquea el puerto pero no se como solucionarlo


RPrincipal-ML1#sh span blockedports

Name Blocked Interfaces List
-------------------- ------------------------------------
MST0 Gi1/0/12
MST1 Gi1/0/12
MST2 Gi1/0/12

 

 

He visto que el switch central 3750 bloquea el puerto hacia el switch final 2960 porque hay una disputa de roles en el protocolo MSTP.

Tenía designado como root primario el switch 2960 y como secundario el central, para descargar al central del control de spanning-tree. Como bloqueaba el puerto, puse como root el switch central 3750 pero no se ha solucionado nada.

La captura es del puerto Gi1/0/12 en el switch central 3750 (RPrincipal-ML1 - MAC: 9caf.ca2f.e380)


GigabitEthernet1/0/12 of MST2 is designated blocking (dispute)
Port info port id 128.12 priority 128 cost 20000
Designated root address 9caf.ca2f.e380 priority 24578 cost 0
Designated bridge address 9caf.ca2f.e380 priority 24578 port id 128.12
Timers: message expires in 0 sec, forward delay 14, forward transitions 0
Bpdus (MRecords) sent 1029, received 0

 

Hola Carmen

Como estas?

A simple vista no se ve problema en la configuracion, unicamente elimina esto y agrega esto:

 

2960

spanning-tree mode mst
spanning-tree extend system-id
spanning-tree mst configuration
name MSTP
revision 1
instance 1 vlan 10, 20, 33, 44, 55
instance 2 vlan 80, 90, 110, 120, 130, 140, 150

 

interface GigabitEthernet0/1
no switchport trunk allowed vlan 2-32,34-4094  

switchport mode trunk

 

 

3750

spanning-tree mode mst
spanning-tree extend system-id
spanning-tree mst configuration
name MSTP
revision 1
instance 1 vlan 10, 20, 33, 44, 55
instance 2 vlan 80, 90, 110, 120, 130, 140, 150
spanning-tree mst 0-1 priority 28672
spanning-tree mst 2 priority 24576

 

interface GigabitEthernet1/0/12
description Interfaz troncal con switch Cisco ... AULAB12
no switchport trunk allowed vlan 2-32,34-4094  <--- eliminalo
switchport trunk encapsulation dot1q
switchport trunk native vlan 44
switchport trunk pruning vlan 10, 44, 80-110,130-150 <--- agrega la vlan 44
 

Imagino que la prioridad en el switch 2960 el MST tiene una prioridad por defecto. No cabe de mas también revisar el cableado. Revisa con un show cdp nei, para ver si ve al switch en ese puerto 12. 

 

Prueba y me cuentas.

Gracias. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hola @Julio E. Moisa , ya revisé el cableado, hasta el punto de que me llevé el switch 2960 al lado del central y le puse un latiguillo (revisado por supuesto), también cambié la prioridad spanning-tree en los dos switch, antes para la instancia 2 era primario el 2960 y ahora he borrado la configuración de los dos switch y he vuelto a ponerla con el 3750 como primario.

Para borrar la configuración he usado estos comandos

Write erase

Delete vlan.dat 

reload 

Pero imagino que la configuración de spanning-tree sigue guardada en algún archivo del sistema porque al configurar de nuevo los sistemas, el resultado ha sido peor, el 3750 sigue bloqueando el puerto del sw 2960 y además no gestiona la instancia 2.

¿Tendría que hacer algo más para borrar la configuración del todo?

El lunes probaré lo que me has dicho y espero que se solucione!!!

 

Hola de nuevo, he probado lo que me dijiste, sin novedad.

Lo único que ha funcionado ha sido dehabilitar MST y poner PVST-rapid, por lo que sea el 3750 bloquea el puerto del 2960 siempre. He probado a cambiar la configuración reseteándolo y poniendole la configuración de otro equipo que si funciona, además lo he conectado a otro puerto. No se porque lo sigue bloqueando, debería interpretar que es un equipo distinto. Imagino que lo bloquea porque lo asocia a la MAC.

 

 

Por si al alguien le viene bien, tras un apagón de luz la solución de deshabilitar MST y poner Rapid-PVST tampoco funcionó. Ya había cambiado un 3560 por el 2960 y ahora he vuelto a intentar el cambio poniendo otro 3750 y funciona todo perfectamente con MST.  

Para mi sigue siendo un misterio, lo único que cambia es que el último switch tiene puertos GigabitEthernet mientras que los otros eran FastEthernet. 

 

Ver la solución en mensaje original publicado