cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
561
Visitas
2
ÚTIL
8
Respuestas

Choosing the predetermined path

demon_ir80
Level 1
Level 1

Hi.
I have encountered a problem, and I would appreciate it if you could tell me what to do. According to the diagram, we have two PCs, and I want each of them, if they want to ping routers RA4 and Router5, to take different paths.
It means PC 0 wants to ping the router with IP 172.16.1.3 and send the packet to Router RA2.
And similarly, PC 0 wants to ping 172.16.1.4, but this time, only send the packet to RA3.
The routing protocol on the routers is OSPF, and it's active in Area 0.
The Layer 3 switch also has an active VLAN that connects the routers RA2-4, and OSPF is active on them as well.

2 SOLUCIONES ACEPTADAS

Soluciones aceptadas

can you use different process or you must use one OSPF process ?

Thanks A Lot
MHM 

Ver la solución en mensaje original publicado

M02@rt37
VIP
VIP

Hello @demon_ir80,

To achieve different paths for PC0 to ping routers RA4 and RA5, you can use policy-based routing 'PBR' on the Layer 3 switch that connects the PCs and routers.

For PC0 to ping Router RA4 (172.16.1.4) via Router RA2:

ip access-list extended PC0-RA4
permit ip host PC0-IP host 172.16.1.4

route-map PBR-RA4 permit 10
match ip address PC0-RA4
set ip next-hop Router-RA2-IP

interface VLANX # The VLAN interface connecting PC0
ip policy route-map PBR-RA4

For PC0 to ping Router RA5 (172.16.1.3) via Router RA3:

ip access-list extended PC0-RA5
permit ip host PC0-IP host 172.16.1.3

route-map PBR-RA5 permit 10
match ip address PC0-RA5
set ip next-hop Router-RA3-IP

interface VLANX # The VLAN interface connecting PC0
ip policy route-map PBR-RA5

--This configuration will direct traffic from PC0 to the desired routers based on the destination IP address, allowing you to achieve different paths for pinging RA4 and RA5.

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

Ver la solución en mensaje original publicado

8 RESPUESTAS 8

can you use different process or you must use one OSPF process ?

Thanks A Lot
MHM 

just ospf

M02@rt37
VIP
VIP

Hello @demon_ir80,

To achieve different paths for PC0 to ping routers RA4 and RA5, you can use policy-based routing 'PBR' on the Layer 3 switch that connects the PCs and routers.

For PC0 to ping Router RA4 (172.16.1.4) via Router RA2:

ip access-list extended PC0-RA4
permit ip host PC0-IP host 172.16.1.4

route-map PBR-RA4 permit 10
match ip address PC0-RA4
set ip next-hop Router-RA2-IP

interface VLANX # The VLAN interface connecting PC0
ip policy route-map PBR-RA4

For PC0 to ping Router RA5 (172.16.1.3) via Router RA3:

ip access-list extended PC0-RA5
permit ip host PC0-IP host 172.16.1.3

route-map PBR-RA5 permit 10
match ip address PC0-RA5
set ip next-hop Router-RA3-IP

interface VLANX # The VLAN interface connecting PC0
ip policy route-map PBR-RA5

--This configuration will direct traffic from PC0 to the desired routers based on the destination IP address, allowing you to achieve different paths for pinging RA4 and RA5.

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

can you fix That?

Hola

Hasta donde se, en PT no se puede configurar PBR.

Lo que solicitas se puede lograr en PT configurando rutas estáticas a las IP de destino que indicas, apuntando como siguiente salto a los router  para el camino deseado.

RA1(config)#ip route 172.16.1.3 255.255.255.255 192.168.1.2

RA1(config)#ip route 172.16.1.4 255.255.255.255 192.168.2.2

Con eso los paquetes tomaran el camino deseado.(esto sucede porque las rutas estáticas tienen un AD menor a OSPF y son elegidos como mejor camino en la tabla de ruteo).

Espero que esto te sea de utilidad.

Saludos

Hi, thanks for the help
What if I want to implement inside EVE-NG?Does eve-ng support?
Because in that environment, I RUN the router's own IOS
Ty

Hola

Claro, en EVE-NG o en GNS3 se puede lograr configurar PBR, pues los dispositivos corren el IOS completo, no el IOS emulado de Packet Tracer.

Saludos

Hello @demon_ir80 

Thanks for sharing your PT project.

Like I suggest to you in private, PBR is not available on PT ; PT has limitations in the IOS of the devices.

On RA1, route /32 (host) directly  to the desired next-hop:

 

M02rt37_1-1699265491620.png

 

 

 

 

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.