Showing results for 
Search instead for 
Did you mean: 
Cisco Secure Email Support Community

Product Support Talos Support Cisco Support Reference + Current Release
Gateway Reputation Lookup Open a support case Secure Email Guided Setup
Gateway: 14.0.2-020
Cloud Gateway Email Status Portal Support & Downloads
Email and Web Manager: 14.1.0-239
Email and Web Manager Web & Email Reputation Worldwide Contacts Product Naming Quick Reference
Reporting Plug-in:
Encryption Bug Search
Encryption Plug-in:
Cloud Mailbox Notification Service
Outlook Add-in(s): More info


IronPort Outlook Plugin 7.2 SCCM Silent Install

I followed the instructions from the adminiguide to create an .iss file and create an application package/advertisement in SCCM. I used the command line from the guide and get the error ResultCode=-3. When I run the command line locally it is successful, however when deploying through SCCM it always returns ResultCode=-3. The following is the command line I used to install.

CiscoEmailSecurity-7-2-0-039.exe /s /v /qn /f1"setup.iss" /f2"C:\ironport.log"

Andreas Mueller

Hi David,

ResultCode=-3 would mean that required data has not been found in  the setup.iss file. I have also seen cases where the permission to  access this data weren't sufficient, i.e. on some setups the command  needs to be run as an administrator. What I have also spotted is that  you use the /v without stating a specific folder for customized configs, i.e.


Maybe running the command again without this option will work better.

Hope that helps,


Hi Andreas, thanks for the reply.

I guess I should have stated this earlier but I've tried quite a few different command lines to install, I just noted the one from the Admin Guide since I thought that one should work if I followed the guide for creating the setup.iss file.

As a reference, I've tried using just the /s option alone, and almost every combination of the previous options with the /s switch, all returning ResultCode=-3. I have never used /v"UseCustomConfigs=\" though.

When you say it needs to be run as an Administrator, does that mean I need to set it to "Run with user's rights" in SCCM with a local administrator logged in? I have it set to "Run with administrative rights" "Whether or not a user is logged on". Could this cause an issue with permissions?

Hello David,

Have you found a resolution to this issue?  I am having an almost identical issue. The only difference is that I am deploying the package through LANDesk instead of SCCM.  It works for me as well, if I run the command locally.  My command line is    CiscoEmailSecurity-7-2-0-039.exe /s /qn /f1"setup.iss"

I have tried almost every combination of switches in the command.  My target machines are Windows 7 64bit.

Hi Terrell,

I just found a resolution to this last week. You can get an msi installation by using

CiscoEmailSecurity-7-2-0-039.exe /a

then go through the setup to extract the files to a selected location. It should extract an .msi installer, and two folders called CommonAppData and program files. You will need all three of these in the same directory.

After getting the msi, you can just install using

msiexec.exe /i "msiname.msi" /qn

for a silent install. I still had to use an msi editor (installshield) to create a transform to remove two custom actions that were causing errors during the msi installtion: CheckLanguageUpdaterResult and CheckUpdateFeaturesResult. The application still installed correctly before removing those errors, I just needed to remove them so SCCM would not report a failed installation.

I was suprised though that it wasn't noted in thier documentation that you could obtain an msi installation using the /a switch, it is just something that you would have to know is available in some installshield installations.

I'm having the same issue here.  For every 10 machines I advertise the Ironport plugin to, I have two that return exit code -3.  Originally I thought it was because those users had Outlook open, and in some cases, that was the cause, but for others, they were notified to shut Outlook down first.  Below is the command I'm sending via the package...

CiscoEmailSecurity-7-2-0-039.exe /s /v"UseCustomConfigs=\"\\OURSERVER.FQDN\Ironport\Cisco IronPort Email Security Plug-In"" /qn /f1"\\OURSERVER.FQDN\Ironport\setup.iss"

This seems to be hit or miss on failures, and the error code isn't telling me much as far as how to go about fixing the issues......

Starla Rivers

Utilizing LANDesk and running the process previously mentioned to solve our common problem:

CiscoEmailSecurity-7-2-0-039.exe /a

msiexec.exe /i "msiname.msi" /qn

We receive a "This installation cannot be run by directly launching the MSI package.  You must run setup.exe." error.  We would like to see Cisco set in and help the community with what should be an easy install.


Hey Starla,

Try using an MSI editor and look in the Custom Actions table for something that looks like it's checking if setup.exe was run or if it was run from the msi. Delete that cutsom action and save as a transform file, then try running it again with TRANSFORMS="transform-name.mst" added to your command line.


Any chance you can post the steps to edit the msi for those of us who are n00bs when it comes to editing msi files. I open the msi in super orca but I'm not exactly sure what/how to edit the msi to get this working. It runs manually no problem. I am trying to install this during an OSD Task sequence and 7.1 worked great.

This problem is very frustrating. Any assistance would be greatly appreciated.



I followed the instructions and created the transform as specified.  Upon installation, I find that I now have two encryption buttons - both for the same add-in version.

Has anyone else seen this, or if so, found a way around it?

Thanks in advance

Recognize Your Peers
Content for Community-Ad