cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1823
Views
0
Helpful
5
Replies

Unable to see Cisco Reporting Plugin after successful installation

EmailMig35230
Level 1
Level 1

Hi,

I have been trying to install Cisco Email Reporting Plugin (Version 1-1-0-119) for the last few days on my Windows 10 64bit OS on x64 hardware and office 2016 64 bit version with the latest Public Update (Nov 2019). The version is certified by Cisco in the release notes. However, after successful installation, I could not see the add-in in Outlook either under Add-ins or Disabled Add-ins. Tried with multiple attempts of uninstalling and installing the different versions of Email Reporting Plugin. No success. BTW, I'm the local administrator of the desktop in which I tried this installation.

 

Further investigation reveals that all the add-in should be available under registry Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\ in 64 bit systems.

However, I noticed only Cisco plugin is available under Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Office\Outlook\Addins\Cisco.EmailReporting.Framework.MsOutlook.Connect

 

The following Microsoft Article has been referred for the above conclusion.

https://support.microsoft.com/en-us/help/2778964/addins-for-office-programs-may-be-registered-under-the-wow6432node

 

Is I'm missing something here? Anyone had experienced similar issue? Appreciate your support. Thank you.

5 Replies 5

dmccabej
Cisco Employee
Cisco Employee

Hello,

 

The article you referenced brings up a point where you may be running Office 32-bit on a 64-bit OS in order for that particular registry key to be updated. 

 

If you have a 32-bit version of Office installed on a 64-bit version of Windows, add-ins that are registered under HKEY_LOCAL_MACHINE will be registered under the \Wow6432Node subkey.

 

Could you perhaps be running into that issue? Coincidentally, the only time I've seen this particular issue is when multiple versions of Office are installed (ie: 32-bit and 64-bit) and the installer essentially doesn't know where/how to update the registry keys. 

 

Thanks!

-Dennis M.

Thanks for your insight. I ensured that there is no trace of 32-bit Office 2016 installation in the laptop best to my knowledge. Further to that the plug-ins from other vendors are getting installed perfectly and work as expected.

Hello,

 

The Microsoft article is pretty clear about the cause of the registry entry being in that location. If you're able to open a Cisco TAC case then we can help take a look at the machine in question and confirm. If not, then uninstalling and reinstalling maybe your best option.

 

Thanks!

-Dennis M.

Thank you. Will open a TAC case to get it checked. However, as I mentioned in the post, we have tried with several uninstallation and installation on the affected desktop as well as on another laptop.

Thanks again for your guidance here. Appreciated.

There is an issue with Outlook plug-ins , many vendors and users have no admin rights.

The most common way to push add-ins would be with the normal deployment mechanism and use the admin privileges to push it out. This will not work any longer.

 

The only workaround we have found is to script a deployment package like:

a) add user to local admin group

b) deploy the package in the user context as it will need to start Outlook in the user context to finalize the plugin deployment

c) remove user from local admin group

 

Hope that helps

-Marc

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: