cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
120
Views
0
Helpful
0
Replies

PfR true load-balancing for C1111-8P

im_skennedy
Level 1
Level 1

Please help with the configuration and errors I'm getting when attempting to configure:


c1111#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
c1111(config)#interface GigabitEthernet0/0/1
c1111(config-if)#no standby 1 ip 192.168.1.254
c1111(config-if)#exit
c1111(config)#interface GigabitEthernet0/0/0
c1111(config-if)#description WAN Interface 1
c1111(config-if)#no shutdown
c1111(config-if)#ip address 192.168.1.201 255.255.255.0
c1111(config-if)#ip nat outside
c1111(config-if)#standby 1 ip 192.168.1.254
c1111(config-if)#standby 1 priority 110
c1111(config-if)#standby 1 preempt
c1111(config-if)#negotiation auto
c1111(config-if)#exit
c1111(config)#interface GigabitEthernet0/0/1
c1111(config-if)#description WAN Interface 2
c1111(config-if)#ip address 10.1.2.2 255.255.255.0
c1111(config-if)#ip nat outside
c1111(config-if)#standby 1 ip 192.168.1.254
% Address 192.168.1.254 in group 1 - interface GigabitEthernet0/0/0
c1111(config-if)#standby 1 preempt
c1111(config-if)#negotiation auto
c1111(config-if)#exit
c1111(config)#no ip route 0.0.0.0 0.0.0.0 10.1.2.1
%No matching route to delete
c1111(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1
c1111(config)#route-map PBR-WAN1 permit 10
c1111(config-route-map)#match ip address LAN_IN
c1111(config-route-map)#set ip next-hop 192.168.1.1!
c1111(config-route-map)#route-map PBR-WAN2 permit 10
c1111(config-route-map)#match ip address LAN_IN
c1111(config-route-map)#set ip next-hop 10.1.2.1!
c1111(config-route-map)#interface GigabitEthernet0/0/0
c1111(config-if)#ip policy route-map PBR-LIST-1
c1111(config-if)#exit!
c1111(config)#interface GigabitEthernet0/0/1
c1111(config-if)#ip policy route-map PBR-LIST-2
c1111(config-if)#exit!
c1111(config)#route-map list PBR-LIST-1
^
% Invalid input detected at '^' marker.

c1111(config)#set weight 2
^
% Invalid input detected at '^' marker.

c1111(config)#route-map PBR-WAN1!
c1111(config-route-map)#route-map list PBR-LIST-2
^
% Invalid input detected at '^' marker.

c1111(config)#set weight 1
^
% Invalid input detected at '^' marker.

c1111(config)#route-map PBR-WAN2!
c1111(config-route-map)#ip access-list extended LAN_IN
c1111(config-ext-nacl)#permit tcp any any eq www
c1111(config-ext-nacl)#permit tcp any any eq 443
c1111(config-ext-nacl)#permit icmp any any
c1111(config-ext-nacl)#permit tcp any any eq 22
c1111(config-ext-nacl)#deny ip any any!
c1111(config-ext-nacl)#end
c1111#
*Feb 13 21:57:59.607: %SYS-5-CONFIG_I: Configured from console by console
c1111#
c1111#
c1111#


sh ver | i IOS
Cisco IOS XE Software, Version 16.09.08
Cisco IOS Software [Fuji], ISR Software (ARMV8EB_LINUX_IOSD-UNIVERSALK9_IAS-M), Version 16.9.8, RELEASE SOFTWARE (fc4)
Cisco IOS-XE software, Copyright (c) 2005-2021 by cisco Systems, Inc.
All rights reserved. Certain components of Cisco IOS-XE software are
documentation or "License Notice" file accompanying the IOS-XE software,
or the applicable URL provided on the flyer accompanying the IOS-XE
ROM: IOS-XE ROMMON
c1111#
c1111#
c1111#
c1111#sh run b
Building configuration...


Current configuration : 3195 bytes
!
! Last configuration change at 21:57:59 UTC Thu Feb 13 2025
!
version 16.9
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
platform punt-keepalive disable-kernel-core
!
hostname c1111
!
boot-start-marker
boot-end-marker
!
!
logging buffered 20000
!
no aaa new-model
!
ip name-server 8.8.8.8 8.8.4.4
ip domain name home.local
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool LAN_DHCP
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 8.8.8.8 8.8.4.4
!
!
!
login on-success log
!
!
!
!
!
!
!
subscriber templating
multilink bundle-name authenticated
!
!
!
crypto pki trustpoint TP-self-signed-846397863
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-846397863
revocation-check none
rsakeypair TP-self-signed-846397863
!
!
crypto pki certificate chain TP-self-signed-846397863
certificate self-signed 01
!
!
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
!
!
redundancy
mode none
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface GigabitEthernet0/0/0
description WAN Interface 1
ip address 192.168.1.201 255.255.255.0
ip nat outside
standby 1 ip 192.168.1.254
standby 1 priority 110
standby 1 preempt
ip policy route-map PBR-LIST-1
negotiation auto
!
interface GigabitEthernet0/0/1
description WAN Interface 2
ip address 10.1.2.2 255.255.255.0
ip nat outside
ip access-group LAN_IN in
standby 1 preempt
ip policy route-map PBR-LIST-2
negotiation auto
!
interface GigabitEthernet0/1/0
!
interface GigabitEthernet0/1/1
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
!
interface GigabitEthernet0/1/4
!
interface GigabitEthernet0/1/5
!
interface GigabitEthernet0/1/6
!
interface GigabitEthernet0/1/7
!
interface Vlan1
no ip address
!
interface Vlan10
description LAN Interface
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip access-group LAN_IN in
no autostate
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http client source-interface GigabitEthernet0/0/0
ip tftp source-interface GigabitEthernet0/0/0
ip nat inside source list NAT_ACL interface GigabitEthernet0/0/1 overload
ip route 0.0.0.0 0.0.0.0 10.1.2.100
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip ssh version 2
!
!
ip access-list extended LAN_IN
permit tcp any any eq www
permit icmp any any
permit tcp any any eq 22
permit tcp any any eq 443
permit ip any any
permit tcp any any eq domain
permit udp any any eq domain
deny ip any any
ip access-list extended NAT_ACL
permit ip 192.168.10.0 0.0.0.255 any
!
!
!
route-map PBR-WAN1 permit 10
match ip address LAN_IN
set ip next-hop 192.168.1.1
!
route-map PBR-WAN2 permit 10
match ip address LAN_IN
set ip next-hop 10.1.2.1
!
route-map PBR-WAN1! permit 10
!
route-map PBR-WAN2! permit 10
!
!
!
control-plane
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
login local
transport input ssh
!
!
!
!
!
!
end

c1111#$
c1111#
c1111#

0 Replies 0