Showing results for 
Search instead for 
Did you mean: 

Failed HTTP Request " cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher."


I'm trying to figure out to work out HTTP Requests with CPO to CPO's own API.

I'm trying to kill a process so i use the following endpoint:

I use a runtime user with my own credentials for authorization.

I make a Post call with this XML request

<soapenv:Envelope xmlns:soapenv="" xmlns:tem="">

I run this with SoapUI and it works fine.

On CPO I get the following error... I don't know if i'm configuring something wrong. If you guys need a .tap i could gladly add one.

The remote server returned an error: (500) Internal Server Error.
<s:Envelope xmlns:s=""><s:Body><s:Fault><faultcode xmlns:a="">a:ActionNotSupported</faultcode><faultstring xml:lang="de-DE">The message with Action '' cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver.  Check that sender and receiver have the same contract and the same binding (including security requirements, e.g. Message, Transport, None).</faultstring></s:Fault></s:Body></s:Envelope>

Would you guys help me figure out what this error is about?


Jonathan Gil Santillan

1 Reply 1

Tuan Tran
Cisco Employee
Cisco Employee

Which version of CPO are you using? Is it an HA environment?  Can you send me a TAP file? I can check it out.
If you are using a newer version of the product, have you tried out the REST API?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers