cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2877
Views
0
Helpful
4
Replies

Can't get ipv6 address from router set up as a dhcpv6 server

mandolordian
Spotlight
Spotlight

Hello, 

I can't get an ipv6 address from a router set up as a dhcpv6 server. I've got both a stateful and stateless server setup for the router, and I don't know what I'm doing wrong.

 

Attached is the pkt file

4 Replies 4

mandolordian
Spotlight
Spotlight

can a mod delete this thread, please? i posted in the wrong sub. I meant to post it in the IPv6 sub.

Harold Ritter
Cisco Employee
Cisco Employee

Hi @mandolordian ,

 

On R1, you need to apply the IPv6 configuration under the sub interface rather than under the main interface.

 

interface GigabitEthernet0/0/1

description Link to LAN 1

ip address 10.0.0.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/0/1.100

description Client Network

encapsulation dot1Q 100

ip address 192.168.1.1 255.255.255.192

ipv6 address 2001:DB8:ACAD:1::1/64

ipv6 dhcp server IPv6-STATEFUL

!

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hello,

 

the IPv6 DHCP config is on the physical interface, there is nothing connected on the physical interface, you need to put it under the Vlan 100 subinterface. Also, the DHCP server you are referencing has no address prefix, you need to use the other one that does:

 

interface GigabitEthernet0/0/1.100
description Client Network
encapsulation dot1Q 100
ip address 192.168.1.1 255.255.255.192
ipv6 address 2001:DB8:ACAD:1::1/64
ipv6 nd other-config-flag
ipv6 address autoconfig
ipv6 enable
ipv6 dhcp server IPV6-STATEFUL

siskum
Spotlight
Spotlight

 

Hi,

I hope that you have already solved your problem but I would like to inform that where the problem exist in your network topology. I attached here a scenario for your easy understand.

ROAS wrong configurationROAS wrong configuration

There are more than two options you can correct this without any problem, Switch1-client machines will be assigned IPv6 address by Router1-DHCP Server R1-STATELESS. Under below described all tree options.

1. First Option: (easy one)

You have already connected PC0 to Switch1-F0/6 port and assinged switch port to Vlan 100 (switchport access vlan 100). Remove it (no switchport access vlan 100) or change it to swithport access vlan 1. The PC0 at Switch1 will be received IPv6 address from DHCP server pool now.

  • Do you have to understand that each interfaces should have a uniq network address, two interfaces cannot have same network address. In yours G0/0/1 interface have assigned to IPv6 address 2001:DB8:ACAD:1::1/64 and also same time G0/0/1.100 sub-interface pointing to same network Prefix at IPv6 DHCP server pool R1-STATELESS. This is wrong.
  • When you configured G0/0/1 (main) inteface with IPv6/IPv4 addresses it sends packet automaticaly to Default Vlan1 not to the Vlan100 or any other Vlan therefore Switch1-F0/6 port not receiving IPv4/IPv6 addresses from DHCP pool. 

 IPv6-ROAS.PNG VLAN1-Laptop receives IPv6 address from DHCPv6 poolVLAN1-Laptop receives IPv6 address from DHCPv6 pool

2. Second Option: (add new DHCPv6 pool to Vlan 100)

You have to work out creating new IPv6 DHCP pool name for Vlan 100 as exempel (ipv6 dhcp pool Vlan100) use new network Prefix 2001:DB8:ACAD:6::/64 as a address pool and assigned to IPv6 interface address to sub-interface G0/0/1.100 as 2001:DB8:ACAD:2::1/64. It should be changed IPv6 DHCP server name that newly created pool name (ipv6 dhcp poll Vlan100). Then Switch1-port F0/6 client automatically recives IPv6 host address from DHCPv6 server pool.

Two different Network address for each interfacesTwo different Network address for each interfaces Vlan100-Receives IPv6 from DHCPv6Vlan100-Receives IPv6 from DHCPv6

3. Third Option: (restucturing existing configuration)

Remove all the configuration you have done in (main) interface of G0/0/1 and issue no shutdown command.

no ip address 10.0.0.1 255.255.255.0   <--- //you have not created IPv4 DHCP pool name therefore APIPA address assigned to Vlan1 client (in first option)
no ipv6 address 2001:DB8:ACAD:1::1/64
no ipv6 nd other-config-flag
no ipv6 address autoconfig      
no ipv6 dhcp server R1-STATELESS

Then go to sub-interface mode of G0/0/1.100 and issue same commands under sub-interface while existing configuration remain as it is. 

ip address 192.168.1.1 255.255.255.192 <--should be this IPv4 address,   
ipv6 address 2001:DB8:ACAD:1::1/64
ipv6 nd other-config-flag
ipv6 address autoconfig         <--- //this command not neccesssay at all because you have already assign static IPv6 address 2001:DB8:ACAD:1::1/64
ipv6 dhcp server R1-STATELESS

Thanks for you all. If this solution helpful and solve your problem give me a helpful vote. It will be more valuable for other uses learn things.

Regards/Sisira

Sisira