cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5078
Views
10
Helpful
2
Replies

IPV6 address implementation for VLANs Clients by DHCPv6 Server

siskum
Spotlight
Spotlight

IPV6 addresses are the solution for future IPV4 address exhaustion problem for client machines. This implementation tested with production routers, switches and client machines. Topology has created using Packet tracer v.8.xxx.

  • This proto type topology uses Global Unicast IPV6 address (2001:DB8:nnnn:mmmm::1/64) for each interfaces. (nnnn and mmmm can be replaces with hexadecimal numbers). It can use Global Unicast address or Unique Local Unicast address (FD00:nnnn:mmmm:pppp::2/64)
  •  DHCP server IPV6 Prepix is 2001:DB8:nnnn:mmmm::/64
  • Client machine obtained IPV6 address from DHCP server. DHCP Sever generates IPV6 address, injecting FF FE to client's mac-address and formulating together with IPV6 Prefix(2001:DB8:170:10:) + Random number(02E0:F9FF:FEC1:A4B5).
  • Finally Client machine obtained unique local unicast IPV6 address as 2001:DB8:170:10:02E0:F9FF:FEC1:A4B5.
  • Random number creates by using client machine's mac-address of 12 hexadecimal numbers (00E0:F9C1:A4B5).
  • In this mac-address middel part of 4 hexadecimal numbers (F9C1) split into two "F9" and "C1" then inject FFFE to middle that means to add "FF" and "FE" behind and front of splitted 4 hexadecimal numbers as F9FF and FEC1.
  • Finally flipping the 7th bit of first part of mac-address (00E0) the second hexa number from left 00 = bits 0000 0000 -> 0000 0010 (after change 7th bit, if it is 0->1; 0x8 0x4 1x2 0x1 and if it is 1->0; 0x8 0x4 0x2 0x1) then new two hexa generated as 02. After that first part of mac-address two hexadecimal changed from "00E0" to "02E0".
  • IPV6 generated random number will become 02E0:F9FF:FEC1:A4B5.
  • Then this random number will add to behind of IPV6 Prefix number, after it will become client IPV6 address.

Configuration of Router and implementig IPV6 DHCP server for VLANS.

Step 1: Creates sub-interfaces for each VLANs (VLAN 10, 20,30) and assigns IPV6 addresses:

# int G0.10
# encapsulation dot1Q 10
# IPV6 Address 2001:db8:170:10::1/64
# IPV6 DHCP server vlan10                     //Pointing to IPv6 DHCP pool name & IPv6 Prefix
# ipv6 nd other-config-flag                     //Pointing to IPv6 DHCP DNS-Server address
!
# int G0.20
# encapsulation dot1Q 20
# ipv6 address 2001:DB8:170:20::1/64
# ipv6 dhcp server vlan20                      //Pointing to IPv6 DHCP pool name & IPv6 Prefix
# ipv6 nd other-config-flag                    //Pointing to IPv6 DHCP DNS-Server address
!
# int G0.30
# encapsulation dot1Q 30
# ipv6 address 2001:DB8:170:30::1/64
# ipv6 dhcp server vlan30                      //Pointing to IPv6 DHCP pool name & IPv6 Prefix
# ipv6 nd other-config-flag                    //Pointing to IPv6 DHCP DNS-Server address

Step 2: Creates IPV6 DHCP pools, add address prefix, dns-server, domain-name

# ipv6 dhcp pool vlan10
# address prefix 2001:db8:170:10::/64
# dns-server 2001:DB8:170:254::254
# domain-name statefullDHCPv6.com
!
# ipv6 dhcp pool vlan20
# address prefix 2001:db8:170:20::/64
# dns-server 2001:DB8:170:254::254
# domain-name statefullDHCPv6.com
!
# ipv6 dhcp pool vlan30
# address prefix 2001:db8:170:30::/64
# dns-server 2001:DB8:170:254::254
# domain-name statefullDHCPv6.com

Configuration of Switch and implementig VLANS (VLAN 10, 20, 30).

Step 1: Creates trunk link and assign VLANs to Switchports

# vlan 10
# vlan 20
# vlan 30
#

# int G1/1/1
# Description BOSwitch1-to-BORouter1 connection - trunk link
# switchport mode trunk
!
# int rang g1/0/1-8
# Switchport mode access
# Switchport access Vlan 10
!
# int rang g1/0/9-16
# Switchport mode access
# Switchport access Vlan 20
!
# int rang g1/0/16-24
# Switchport mode access
# Switchport access Vlan 30

Implementing IPV6 Address obtained for VLANs client from DHCP serverImplementing IPV6 Address obtained for VLANs client from DHCP server

BO-Router1 Configuration in production level
==================================
BO-Router1#conf t
BO-Router1(config)#
BO-Router1(config)#int G0.10
BO-Router1(config-subif)# encapsulation dot1Q 10                 //Router-On-A-Stick (ROAS)
BO-Router1(config-subif)# ip address 10.170.10.1 255.255.255.0
BO-Router1(config-subif)# ipv6 address 2001:DB8:170:10::1/64
BO-Router1(config-subif)# ipv6 nd other-config-flag              //Pointing to IPv6 DHCP DNS-Server address
BO-Router1(config-subif)# ipv6 dhcp server vlan10                //Pointing to IPv6 DHCP pool name & IPv6 Prefix
BO-Router1(config-subif)#
BO-Router1(config-subif)#int G0.20
BO-Router1(config-subif)# encapsulation dot1Q 20                 //Router-On-A-Stick (ROAS)
BO-Router1(config-subif)# ip address 10.170.20.1 255.255.255.0
BO-Router1(config-subif)# ipv6 address 2001:DB8:170:20::1/64
BO-Router1(config-subif)# ipv6 nd other-config-flag              //Pointing to IPv6 DHCP DNS-Server address
BO-Router1(config-subif)# ipv6 dhcp server vlan20                //Pointing to IPv6 DHCP pool name & IPv6 Prefix
BO-Router1(config-subif)#
BO-Router1(config-subif)#int G0.30
BO-Router1(config-subif)# encapsulation dot1Q 30                  //Router-On-A-Stick (ROAS)
BO-Router1(config-subif)# ip address 10.170.30.1 255.255.255.0
BO-Router1(config-subif)# ipv6 address 2001:DB8:170:30::1/64
BO-Router1(config-subif)# ipv6 nd other-config-flag               //Pointing to IPv6 DHCP DNS-Server address
BO-Router1(config-subif)# ipv6 dhcp server vlan30                 //Pointing to IPv6 DHCP pool name & IPv6 Prefix
BO-Router1(config-subif)# exit
BO-Router1(config)#
BO-Router1(config)#ipv6 dhcp pool vlan10
BO-Router1(config-dhcpv6)# address prefix 2001:db8:170:10::/64
BO-Router1(config-dhcpv6)# dns-server 2001:DB8:170:254::254
BO-Router1(config-dhcpv6)# domain-name statefullDHCPv6.com
BO-Router1(config-dhcpv6)#
BO-Router1(config-dhcpv6)#ipv6 dhcp pool vlan20
BO-Router1(config-dhcpv6)# address prefix 2001:db8:170:20::/64
BO-Router1(config-dhcpv6)# dns-server 2001:DB8:170:254::254
BO-Router1(config-dhcpv6)# domain-name statefullDHCPv6.com
BO-Router1(config-dhcpv6)#
BO-Router1(config-dhcpv6)#ipv6 dhcp pool vlan30
BO-Router1(config-dhcpv6)# address prefix 2001:db8:170:30::/64
BO-Router1(config-dhcpv6)# dns-server 2001:DB8:170:254::254
BO-Router1(config-dhcpv6)# domain-name statefullDHCPv6.com
BO-Router1(config-dhcpv6)# exit
BO-Router1(config)#
BO-Router1(config)#ip dhcp pool Vlan10
BO-Router1(dhcp-config)# network 10.170.10.0 255.255.255.0
BO-Router1(dhcp-config)# default-router 10.170.10.1
BO-Router1(dhcp-config)# dns-server 8.8.8.8
BO-Router1(dhcp-config)#ip dhcp pool Vlan20
BO-Router1(dhcp-config)# network 10.170.20.0 255.255.255.0
BO-Router1(dhcp-config)# default-router 10.170.20.1
BO-Router1(dhcp-config)# dns-server 8.8.8.8
BO-Router1(dhcp-config)#ip dhcp pool Vlan30
BO-Router1(dhcp-config)# network 10.170.30.0 255.255.255.0
BO-Router1(dhcp-config)# default-router 10.170.30.1
BO-Router1(dhcp-config)# dns-server 8.8.8.8
BO-Router1(dhcp-config)#exit
BO-Router1(config)# ipv6 unicast-routing
BO-Router1(config)#


BO-Router show Run Command
===========================
BO-Router1>enable
BO-Router1#sh run
!
!
ip dhcp pool Vlan10
network 10.170.10.0 255.255.255.0
default-router 10.170.10.1
dns-server 8.8.8.8
ip dhcp pool Vlan20
network 10.170.20.0 255.255.255.0
default-router 10.170.20.1
dns-server 8.8.8.8
ip dhcp pool Vlan30
network 10.170.30.0 255.255.255.0
default-router 10.170.30.1
dns-server 8.8.8.8
!
!
ipv6 unicast-routing
!
!
ipv6 dhcp pool vlan10
address prefix 2001:db8:170:10::/64 lifetime 172800 86400
dns-server 2001:DB8:170:254::254
domain-name statefullDHCPv6.com
!
ipv6 dhcp pool vlan20
address prefix 2001:db8:170:20::/64 lifetime 172800 86400
dns-server 2001:DB8:170:254::254
domain-name statefullDHCPv6.com
!
ipv6 dhcp pool vlan30
address prefix 2001:db8:170:30::/64 lifetime 172800 86400
dns-server 2001:DB8:170:254::254
domain-name statefullDHCPv6.com
!
!
interface GigabitEthernet0
no ip address
ip nat inside
duplex auto
speed auto
!
interface GigabitEthernet0.10
encapsulation dot1Q 10
ip address 10.170.10.1 255.255.255.0
ipv6 address 2001:DB8:170:10::1/64
ipv6 nd other-config-flag
ipv6 dhcp server vlan10
!
interface GigabitEthernet0.20
encapsulation dot1Q 20
ip address 10.170.20.1 255.255.255.0
ipv6 address 2001:DB8:170:20::1/64
ipv6 nd other-config-flag
ipv6 dhcp server vlan20
!
interface GigabitEthernet0.30
encapsulation dot1Q 30
ip address 10.170.30.1 255.255.255.0
ipv6 address 2001:DB8:170:30::1/64
ipv6 nd other-config-flag
ipv6 dhcp server vlan30
!

BO-Switch1 Configurations in production level

Switch#
Switch#config t
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#exit
Switch(config)#
Switch(config)#int G1/1/1
Switch(config-if)#Description BOSwitch1-to-BORouter1 connection - trunk link
Switch(config-if)#switchport mode trunk
Switch(config-if)#
Switch(config-if)#int rang g1/0/1-8
Switch(config-if-range)#Switchport mode access
Switch(config-if-range)#Switchport access Vlan 10
Switch(config-if-range)#
Switch(config-if-range)#int rang g1/0/1-8
Switch(config-if-range)#Switchport mode access
Switch(config-if-range)#Switchport access Vlan 20
Switch(config-if-range)#
Switch(config-if-range)#int rang g1/0/1-8
Switch(config-if-range)#Switchport mode access
Switch(config-if-range)#Switchport access Vlan 30
Switch(config-if-range)#exit
Switch(config)#

 

Sisira
2 Replies 2

marcmontreal514
Level 1
Level 1

thank you for your time and share, i appreciate and I will try to practice this lab like the last one.

 

have good night 

Thanks Marc,

If it is helpfull pls make comment and give me a helpful vote.

Have a good night..!

Sisira

Review Cisco Networking for a $25 gift card