cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4003
Views
0
Helpful
2
Replies
jschaeffer
Beginner

IPv6 interface stays in tentative state

Greetings all,

I recently purchased a Catalyst 3650-48PD and I'm going through and setting up all my VLAN interfaces, LAGs, etc. I'm setting everything up on IPv6. When I set an IPv6 address on a VLAN interface and then show that interface it says IPv6 is tentative and it never actually assigns the IP address to the interface. Because it never assigns it to the interfaces it also never creates a connect route to it. I can't figure out how to get it to go from "tentative" to "enabled". Here is my config:

SFB01-NESWITCH02#show ipv6 interface | s Vlan100
Vlan100 is up, line protocol is down
IPv6 is tentative, link-local address is FE80::E6AA:5DFF:FE99:8851 [TEN]
No Virtual link-local address(es):
Description: "Management"
Global unicast address(es):
2620:5:E000:1064::1, subnet is 2620:5:E000:1064::/64 [TEN]
Joined group address(es):
FF02::1
FF02::2
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
Input features: Verify Unicast Reverse-Path
Output features: Check hwidb
IPv6 verify source reachable-via any
0 verification drop(s) (process), 0 (CEF)
0 suppressed verification drop(s) (process), 0 (CEF)
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds (using 30000)
ND advertised reachable time is 0 (unspecified)
ND advertised retransmit interval is 0 (unspecified)
ND router advertisements are sent every 200 seconds
ND router advertisements live for 1800 seconds
ND advertised default router preference is Medium
Hosts use DHCP to obtain routable addresses.
Hosts use DHCP to obtain other configuration.

SFB01-NESWITCH02#show ipv6 route
IPv6 Routing Table - default - 1 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
R - RIP, D - EIGRP, EX - EIGRP external, ND - ND Default
NDp - ND Prefix, DCE - Destination, NDr - Redirect, O - OSPF Intra
OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1
ON2 - OSPF NSSA ext 2
L FF00::/8 [0/0]
via Null0, receive

SFB01-NESWITCH02#show running-config | s Vlan100
interface Vlan100
description "Management"
no ip address
ipv6 address 2620:5:E000:1064::1/64
ipv6 enable
ipv6 nd prefix 2620:5:E000:1064::/64 no-advertise
ipv6 nd managed-config-flag
ipv6 nd other-config-flag
ipv6 verify unicast source reachable-via any

SFB01-NESWITCH02#show vlan brief

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi1/0/1, Gi1/0/2, Gi1/0/3
Gi1/0/4, Gi1/0/7, Gi1/0/8
Gi1/0/9, Gi1/0/10, Gi1/0/13
Gi1/0/14, Gi1/0/15, Gi1/0/16
Gi1/0/19, Gi1/0/20, Gi1/0/21
Gi1/0/22, Gi1/0/41, Gi1/0/47
Gi1/1/1, Gi1/1/2, Te1/1/3
Te1/1/4
100 Management active Gi1/0/42, Gi1/0/48
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

interface GigabitEthernet1/0/42
switchport access vlan 100
switchport mode access

interface GigabitEthernet1/0/48
switchport access vlan 100
switchport mode access

I've even tried disabling DAD, but it still stays in a tenative state. I'd appreciate any help.

Thanks,

Joshua Schaeffer

2 REPLIES 2
Ashwin Kotha
Beginner

Hi Joshua,

Are your physical ports Gig 1/0/42 and Gig 1/0/48 UP? 

Have you created VLAN 100 in config mode ? Please post the outputs for these two.

-Ash

It actually turned out to be a stupid mistake on my part. I misread the port numbers on the switch. I was reading the ports 1, 2 ,3 4, etc across the device instead of up/down (which in my defense was how my last cisco switch was). So what I thought was port 42 was actually port 47. When I updated all my config then ipv6 was actually enabled.