I have an issue with IPv6 prefix delegation over PPPoE. When my router gets his v6-prefix delegated, it automatically creates a null route for this prefix. The problem is that I also have a static route to my firewall for the whole prefix, so now the router has two equal routes for the prefix (the null route and my static route). All devices behind my firewall loosing packages. How can I fix this?
Topology: [ISP-BRIDGE] -{PPPoE} fa0/0- [ROUTER] -fa0/1- [Firewall]
show ipv6 route
IPv6 Routing Table - default - x entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
[...]
S 2001:DB8:1200::/48 [1/0]
via 2001:DB8:1200:A000::3
via Null0, directly connected
[...]
DHCPv6 prefix Debug output (proofs that the dhcp-client inserts the null route)
*Feb 24 17:25:52.959: [DHCPv6 client]IPv6RT[default]: static, Route add 2001:DB8:1200::/48 [owner]
*Feb 24 17:25:52.959: [DHCPv6 client]IPv6RT[default]: static, Added path ::/Null0
Configuration excerpt of my router
interface FastEthernet0/0 description Link-To-Bridge
no ip address
pppoe enable group 1
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
description Public
ip address 200.200.200.1 255.255.255.248
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:1200:A000::1/64
!
interface Dialer1
ip unnumbered FastEthernet0/1
[...]
encapsulation ppp
dialer pool 1
dialer persistent
dialer-group 1
ipv6 address autoconfig
ipv6 dhcp client pd ISP-PREFIX
[...]
ppp ipcp dns request
!
ip forward-protocol nd
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
ipv6 route 2001:DB8:1200::/48 2001:DB8:1200:A000::3
ipv6 route ::/0 Dialer1
Version
Cisco IOS Software, 2801 Software (C2801-SPSERVICESK9-M), Version 15.1(4)M3, RELEASE SOFTWARE (fc1)
[EDIT]
I found two other people with the same Problem, here and here. They both just configured two more specific routes. In my example it would be two /49 routes. But I don't think that is the proper solution for this problem.