cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
331
Views
0
Helpful
0
Replies

Product Specific Configuration

Vladislav Vyakin
Beginner
Beginner

Hello,

As describded to update Product Specific Configuration for phone I use procedure dbwritedevicexml

I get xml string with dbreaddevicexml from existing configured phone (Phone model Cisco 6945).

execute procedure dbwritedevicexml('b78aef9f-6084-7ef0-a012-0f559f430007','<disablespeaker>false</disablespeaker><disablespeakerandheadset>false</disablespeakerandheadset><pcport>0</pcport><settingsaccess>1</settingsaccess><voicevlanaccess>0</voicevlanaccess><videocapability>0</videocapability><webaccess>0</webaccess><daysbacklightnotactive>1,7</daysbacklightnotactive><backlightontime>08:00</backlightontime><backlightonduration>09:00</backlightonduration><backlightidletimeout>01:00</backlightidletimeout><backlightonwhenincomingcall>1</backlightonwhenincomingcall><spantopcport>1</spantopcport><loggingdisplay>1</loggingdisplay><recordingtone>0</recordingtone><recordingtonelocalvolume>100</recordingtonelocalvolume><recordingtoneremotevolume>50</recordingtoneremotevolume><recordingtoneduration></recordingtoneduration><morekeyreversiontimer>5</morekeyreversiontimer><logserver></logserver><g722codecsupport>0</g722codecsupport><enablecdpswport>1</enablecdpswport><enablecdppcport>0</enablecdppcport><enablelldpswport>1</enablelldpswport><enablelldppcport>1</enablelldppcport><lldpassetid></lldpassetid><powerpriority>0</powerpriority><eapauthentication>0</eapauthentication><linekeybarge>0</linekeybarge>')

executeSQLUpdate - executed successfully, but no result. No new configuration for phone

dbreaddevicexml - show everything is fine, config was applied.

execute procedure dbreaddevicexml('b78aef9f-6084-7ef0-a012-0f559f430007')

<disablespeaker>false</disablespeaker><disablespeakerandheadset>false</disablespeakerandheadset><pcport>0</pcport><settingsaccess>1</settingsaccess><voicevlanaccess>0</voicevlanaccess><videocapability>0</videocapability><webaccess>0</webaccess><daysbacklightnotactive>1,7</daysbacklightnotactive><backlightontime>08:00</backlightontime><backlightonduration>09:00</backlightonduration><backlightidletimeout>01:00</backlightidletimeout><backlightonwhenincomingcall>1</backlightonwhenincomingcall><spantopcport>1</spantopcport><loggingdisplay>1</loggingdisplay><recordingtone>0</recordingtone><recordingtonelocalvolume>100</recordingtonelocalvolume><recordingtoneremotevolume>50</recordingtoneremotevolume><recordingtoneduration></recordingtoneduration><morekeyreversiontimer>5</morekeyreversiontimer><logserver></logserver><g722codecsupport>0</g722codecsupport><enablecdpswport>1</enablecdpswport><enablecdppcport>0</enablecdppcport><enablelldpswport>1</enablelldpswport><enablelldppcport>1</enablelldppcport><lldpassetid></lldpassetid><powerpriority>0</powerpriority><eapauthentication>0</eapauthentication><linekeybarge>0</linekeybarge>


Phone realy backlightontime at 8:00 as I configure. I test it.


But CUCM Web Interface does not show this config for this phone, it show default

cucm.PNG

If I make some changes config this phone on Web Interface  CUMC override my config with this default config.

execute procedure dbreaddevicexml('b78aef9f-6084-7ef0-a012-0f559f430007')

<disableSpeaker>false</disableSpeaker><disableSpeakerAndHeadset>false</disableSpeakerAndHeadset><pcPort>0</pcPort><settingsAccess>1</settingsAccess><voiceVlanAccess>0</voiceVlanAccess><videoCapability>1</videoCapability><daysBacklightNotActive>7</daysBacklightNotActive><backlightOnTime>07:30</backlightOnTime><backlightOnDuration>10:30</backlightOnDuration><backlightIdleTimeout>01:00</backlightIdleTimeout><backlightOnWhenIncomingCall>1</backlightOnWhenIncomingCall><spanToPCPort>1</spanToPCPort><loggingDisplay>1</loggingDisplay><recordingTone>0</recordingTone><recordingToneLocalVolume>100</recordingToneLocalVolume><recordingToneRemoteVolume>50</recordingToneRemoteVolume><recordingToneDuration></recordingToneDuration><moreKeyReversionTimer>5</moreKeyReversionTimer><g722CodecSupport>0</g722CodecSupport><enableCdpSwPort>1</enableCdpSwPort><enableCdpPcPort>1</enableCdpPcPort><enableLldpSwPort>1</enableLldpSwPort><enableLldpPcPort>1</enableLldpPcPort><lldpAssetId></lldpAssetId><powerPriority>0</powerPriority><eapAuthentication>0</eapAuthentication><LineKeyBarge>0</LineKeyBarge><minimumRingVolume>0</minimumRingVolume><ehookEnable>0</ehookEnable><AutoSaveVolDuringCall>0</AutoSaveVolDuringCall>


What problem? Why CUCM not show right config?



0 REPLIES 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: