Showing results for 
Search instead for 
Did you mean: 

This community is for technical, feature, configuration and deployment questions.
For production deployment issues, please contact the TAC! We will not comment or assist with your TAC case in these forums.
Please see How to Ask the Community for Help for other best practices.


ACS v5.2 - Unable to update User integer attributes through File Operations


     I have created some internal users on ACS v5.2 and added some Unsigned Integer attributes for each user. I am trying to do a bulk update of these integer attributes using the File Operation facility. However no matter what number I put on the import template it doesn't get updated and displays a "0" in the user config.

The import template is validated successfully with no errors and also the string attributes are updated correctly.

There is a sort of work around of deleting the users and adding them back in with the updated values. But this is not feasible as it would reset their passwords. I have also tried saving the csv file in Open Ofifce instead of Excel

Has any one else come across this problem?

(I am unable to see this issue in the Release notes or Bug tool kit although there is a similar issue when updating devices in CSCth68051)

Rising star

I have just tried to recreate this and could not. Integer attributes in the user record were updated on the update operation correctly

If can provide some details on which attributes you have and a sample failing format (with changed username/passwords) I can take a further look


     Thanks for the reply. I have managed to recreate the problem to show you but it is a bit more complicated than I first thought. The problem only occurs when the integer attributes are added after the user is created.

I created a dummy user. The MTL and TLS attributes were present before the user was added. I then added the XXX and ZZZ attributes afterwards and assigned them default values. The default values show up in the GUI config.

However when I export the database to a csv file only the values of the MTL and TLS attributes show up in the export file:

I then downloaded an import template and updated the integer values for TLS,MTL, XXX and ZZZ for the dummy user:

The file imports successfully with no errors. However, when I display the user config only the MTL and TLS attributes have changed. The XXX and ZZZ attributes have stayed the same.

I thought it might be because I was assigning a default value of 0 to the new attributes but I assigned ZZZ a default value of 1 and the same thing occurred.

Just to update: I have also tested this with adding string and boolean attributes after the user is created and am getting the same issue.

Apoligies for the delays in responding after your hard work recreating; just needed to free a slot to work through it

I am able to recreate your issue. It occurs when you add a user attribute with a default value after you create the user and then attribute the attribute value for the user using an import as you described.

Couple other interesting points to note:

- After create the user and export the data the export file has an empty field although the GUI displays the default value (as you described).This is because the absense of a specific value for the user is what triggers the GUI (and policy processing) to use the default value.

- When I import the value as you describe it does not get updated in the GUI. However, if I look at the configuration audit it reports that the attribute value waas not changed.

- Actually just trying again I managed to recreate even withot creating a default value so I think happens when create attribute after the user

I did not find an exisiting CDETS for this and so created a new one: CSCtj89705

Thanks very much for looking into this. Hopefully there will be a patch that will fix this as soon.

There is in fact a patch that just became available and includes a fix for the issue referenced on this thread

Patch number is and can be downloaded from CCO.

Content for Community-Ad