cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

This community is for technical, feature, configuration and deployment questions.
For production deployment issues, please contact the TAC! We will not comment or assist with your TAC case in these forums.
Please see How to Ask the Community for Help for other best practices.

1028
Views
3
Helpful
3
Replies
Michael ONeil
Beginner

Deregistering node successful but it is still listed in deployment page

all-nodes.PNG

error-registering-node02.PNG

During an upgrade to 1.1.4, one of the Policy nodes didn't deregister successfully. The Primary shows it as now a standalone, but it seems to still be a part of the distributed deployment. I upgraded the Policy node and the rest of the nodes. I tried to add (register) the Policy node back but the error says the node is already listed. Is there a way to manually delete a node via the CLI?

Thanks

3 REPLIES 3
Jatin Katyal
Cisco Employee

If I understand your issue correctly, I think this is what happening. When you tried to deregister, it didn't work but secondary shows as STANDALONE on primary deployment page.

When you try to register secondary node you're getting the following exception on screen:

"An error occurred while registering node Large - java.net.UnknownHostException: Large"

When you click 'Save' again you're getting the following:

"An error occurred while registering node Large - HostConfig 'Large' already exist.; nested exception is: HostConfig 'Large' already exist."

To perform the operations (deregistering)  you must have one of the following roles assigned: Super Admin or System Admin.

In case the above suggestion doesn't work than we can probably look at the support bundle or reset the config.

I don't see any command that can help us to delete the NODE from the deployment.

http://www.cisco.com/en/US/docs/security/ise/1.0/cli_ref_guide/ise10_cli_app_a.html

Jatin Katyal
- Do rate helpful posts -

~Jatin

I actually promoted the Secondary Admin and Monitoring to Primary for both personas.

After it finished initializing, the failed standalone node was gone from the listing.

I was able to register it back to the new Primary, and did a application reset-config ise on the original Primary node to clear up the db. I then successfully added it back in as Primary for both personas.

I am up and running fine now. Thanks for the help.

Glad to know!  thanks for taking time and sharing the steps you performed to resolve this issue.

Jatin Katyal


- Do rate helpful posts -

~Jatin
Content for Community-Ad