Showing results for 
Search instead for 
Did you mean: 

Cannot connect to LMS 2.6 (Solaris)

Mohammed Tolib
Level 1
Level 1

Hi all,

We got the following error message on Ciscoworks LMS 2.6 on Solaris 5.9:

{diskWatcher} - Avialable space in /var of server xxx is less than 10 percent.

We stopped the Daemon Manager and delete some log files. After restarting the Daemon Manager it took about 45 min to came up but unfortunately when we tried to connect to the sever by IE we got "Internet Explorer cannot display the webpage" the pdshow shows that:

        Process= Apache

        State  = Never started

        Pid    = 0

        RC     = 0

        Signo  = 0

        Start  = N/A

        Stop   = Not applicable

        Core   = Not applicable

        Info   = Not applicable,

We tried to start the Apatche server with no luck.

We tried to change the port and the ssl configurations as follows:

/opt/CSCOpx/MDC/Apache/bin/changeport 1744

/opt/CSCOpx/bin/perl /opt/CSCOpx/MDC/Apache/bin/ -enable

/opt/CSCOpx/bin/perl /opt/CSCOpx/MDC/Apache/bin/ -disable

Now the Daemon Manager does not start at all (pdshow shows nothing for a longer time).

I will appreciate any help.

6 Replies 6

Vinod Arya
Cisco Employee
Cisco Employee

Mostly in these old LMS installations, i have seen issue with expired certificates. Please check the certificate state via :

NMSROOT/bin/perl   NMSROOT/MDC/Apache/bin/ and select option 1.

pdshow usually will never respond till the time Daemon manager is busy stop/start the services. You can see  NMSROOT/objects/dmgt/ready/ if there is any file/process lock. pdshow will work once this directory is empty or atlease dmgtd.lock is not there.


-Thanks Vinod **Rating Encourages contributors, and its really free. **

Thanks for the reply.

I checked the certificate and it is valid. Still cannot access LMS through the browser.

After further investigations I found from the /opt/CSCOpx/MDC/Apache/logs/error_log that the Apache shuts down during the Daemon Manager startup:

"[Tue May 22 09:23:41 2012] [notice] caught SIGTERM, shutting down"

So how can I start Apache again? And why it keeps shutting down like this?

I Also checked the Apache configuration syntax and the validity of the server certificate as described in:

and everything is OK. The problem still exists.

Please share more details from error_log (upload error_log). Also, please share the dmgtd.log as well.

They should shed more light on the error details.


-Thanks Vinod **Rating Encourages contributors, and its really free. **

Here you are.