cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1631
Views
9
Helpful
6
Replies

LMS 4.2.3 Device pack update

Hi

Im trying to update the device pack for LMS 4.2.3, since the existing pack doesnt include 3850s. I went to Device update -> clicked inventory config and image management -> check for updates. It gives me the following error:

A PSU Task is currently been executed by another user.Only one PSU Task can be executed at a time.Please wait for the current Task to complete. The details of the currently running PSU Task are as below:


PSU Task :

Device Updates

Task Started at:

Wed Mar 05 14:16:09 EST 2014

Task Started by:

admin


NOTE : If you are sure no other download is happening , please delete the file D:\CISCOW~1\Psu.Lock

If im doing the manual way, I went to CCO and downloaded this file:

Inventory Config and Image Management Device Package version 2.12.9 for SharedSwimIOS Over LMS 4.2.3

Login & Valid Contract Required

SharedSwimIOS.RME523.v2-12-9.zip

but there is no documentation on how to manually install this ? can someone help me solve this please ?

Raj

6 Replies 6

Marvin Rhoads
VIP Community Legend VIP Community Legend
VIP Community Legend

Whether you download + install or download and then install later, you will still have to kill the current process (delete the .lck file). Once you do that, you can run the GUI-based installation once again choosing the local copy of the update vs. going to cisco.com.

For manual installation you need to use the package support updater command line interface (psucli) utility. Instructions for that are in the Admin Guide here.

Hi Marvin

Thanks for the response.

I deleted the .lck file, and now it shows me the device package that I can download.. 2 issues :

The device package downloads that were available, didnt include 3850 ? pls find attached the screenshot..

device package.jpg

I tried downloading the Nexus device package (RME) and it went through and finally gave an error message that the installation failed.. when i looked at the error logs i found this:

installation failed for product [inventory config and image management] with message :com.cisco.nx.xms.psu.packagemgmt.InstallerException

WOuld you where where Im going wrong ? Should I try downloading the zip file and do it locally instead ?

Regards

Raj

Tried manual... downloaded the lates package from Cisco site:

Inventory Config and Image Management Device Package version 2.12.9 for SharedSwimIOS Over LMS 4.2.3

and uploaded it to c:\psu_download folder..

Then tried updating the device pack locally.. it failed too, but with a different error this time:

device package error.jpg

My initial aim was to support 3850 switches, and also get the latest device package for Nexus 5000 - since the existiing pack didnt support user tracking for N5K.

REgards

Raj

What is the exact model of 3850 switch you're trying to monitor?

Following are the supported models :

Device NamesysObjectIDSupported Software VersionSupport TypeDevice NamesysObjectIDSupported Software VersionSupport Type
Cisco Catalyst 3850-48P-E Switch1.3.6.1.4.1.9.1.1641 __
Device Update Cisco Catalyst 3850-48P-S Switch 1.3.6.1.4.1.9.1.1643 __ Device Update
Cisco Catalyst 3850-24P-E Switch1.3.6.1.4.1.9.1.1642 __
Device Update Cisco Catalyst 3850-24P-S Switch1.3.6.1.4.1.9.1.1644 __ Device Update
Cisco Catalyst 3850-24U-E Switch1.3.6.1.4.1.9.1.176703.11.35.EMPDevice  UpdateCisco Catalyst 3850-48U-E Switch1.3.6.1.4.1.9.1.176803.11.35.EMPDevice Update

If it is 3850-24p-L, it can be :

CSCuj61704    No support for 3850-24p-L in LMS 4.2.3

Try updating your mdf device package as well. Device package for Common Services.

For current Nexus device package issue, each device package is not individual, but has some dependant packages. Without which they are tend to fail during installation check.

You can select all the available device packages and try to install. It seems you dont have SharedDcmaIOS (3.1.7) installed and hence the package is failng due to pre-requisite.


You have to install each package which fails which consistancy check on other packages.

For mdf package update, you can select common service as well and check for update.

There may be some 3850 device packages already available, please share output of following command for us to see :

NMSROOT/bin/psucli -p rme -q -all

-Thanks

Vinod
**Rating Encourages contributors, and its really free. **

-Thanks Vinod **Rating Encourages contributors, and its really free. **

We are trying to do config & inventory management for WS-C3850-48P.

Ill try updating common services device package, and may be everything else. Ill let you know how it goes..

Thanks Vinod

I was able to update the common services device package and network services layer 2 user tracking after that.

Thanks Vinod & Marvin for your help in this.

Ill go ahead do others and get back if I have any more issues.

Raj

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers