Showing results for 
Search instead for 
Did you mean: 

Not able to select "all devices" in device selector

I am having a problem selecting "all devices" in device selector in most cases in lms4.1.  When selecting "all devices" it show up zero.  Instead i have to choose "device type groups"  and this takes about half a minute to show up.  In some cases I am able to select it, but in most cases I am not.  For instance : 

Reports > Inventory > Management Status>Credential Verification Errors


answer from TAC:

Thanks a lot for the provided data.

This can happen if there is something wrong with permissions casuser has , if this is the case then we need to reset casuser , the procedure to reset casuser is as below :

Navigate to : \CSCOpx\setup\support

example :


And issue the command : resetCasuser.exe

Please select the following option to proceed.


1. Randomly generate casuser password.

2. Enter casuser password.

3. Exit.



I had the same problem and I found your post really helpful! It also solved my issue!


I am glad it helped.  But this actually did not solve my problem.  It seems this issue comes back after about a day, and then I have to restart the server to be able to select "all devices" again.  This is the case when for instance trying to make reports about hardware or software.  It is not the issue when selecting devices under "inventory".

We have tried both lms4.1 on windows platform and linux and lms4.2 on linux.

The only thing that is similare in all installations is the import list for devices.

Anybody have a clue ?


You are right about the problem reappearing. The truth is that I was wondering if the problem was fully resolved in your case.

The answer that I got from our partner is that if the LMS server is in the domain (our case) then maybe casuser rights get overwritten by some global policy. So maybe the domain admins can create certain policy for the casuser (?).

To be on the safe side we have opened a case and we are waiting for feedback. I will update this post if a solution is found.


The problem is now solved.  But I had to do alot of reinstalling of lms to fix this.  In our case it seemed like there was some sort error when importing devices from  file when upgrading to a new release of lms 4.1.  and 4.2 which we are now running. 

I also had the same assumptions as you when it came to the domain.  And this was also the reply I got from TAC. 

To solve this I had to first delete all devices from the new lms installation that had some sort of fail under "inventory -> device status"  Either not supported, faulty backup og not able to collect inventory.  Then I did a export devices under "add/import/manage devices".  Then I returned to a previous snapshot of the server from before I imported the devices the first time and then imported the devices that are 100% compatible again.

Now i am manually adding the devices that where first deleted.

In our case it might have been sufficient to just delete the devices with faults, but I cannot confirm this.

Now I have not seen this issue for 4 days, and earlier I had to restart the server every day.  So I am very hopeful

This issue appeared when we first tried to upgrade from lms3.2 to lms4.1.  And we used an import file of the devices instead of the backup from from lms.  When we also tried to upgrade to 4.2 this issue still came back.  We have installed lms4.2 on a standalone server with VMware and the linux versjon.

Great news   Glad it worked out for you!!!!

Yesterday I removed the server from the domain, reset the casuser password and I was really hopeful. Today "All Devices" list was once again empty.

In our case we imported the devices from the LMS 3.2 backup, so there seems to be a different initial installation but same problem...

Let you know how it goes...

In our case it did not seem to have anything to do with the resetcasuser at all.  It was enough to restart the server.  Using dmgtd stop and start.

Maybe there are some timeouts that causes this problem.  Since we were managing some devices that was not completely compatible with lms.  Not sure how many devices you manage with lms, but I had to delete about 50 devices from 1200 total, and now I am going through the 50 and making sure they are not added through device discovery automatically.  Maybe you can try to delete the failed devices under "inventory -> device status -> collection summary" and then restart the server..

Finally got everything working! The original devices were imported from LMS 3.2 and it seems that something had gone wrong there. Taking your approach into consideration we decided to complete delete all devices from inventory and rediscover them, through the discovery procedure. Fortunately, we only have a few devices (~=300), so it wasn't such a big issue! The only drawback was that I had to recreate any device groups I had configured and also to reapply device credentials. Also any netshow job, automated action etc, that was created prior to the Inventory deletion, needed to be recreated.

Anyway... A full day has passed and the "All Devices" selection is still populated.



Just wondering if this issue has come back?  I have experienced this some times lately.  To me it seems like we have some sort of device in our net that maybe causes this error, but during the summer I will consider your approach.



It's been about a week since we rediscovered the net devices and "All Devices" is still populated.

In our case, I think that the error was caused because of devices that were removed from the network, but not form RME of 2.1, the database of which was migrated to LMS 4.1.

Full rediscovery seems to be the solution, but with an overhead as stated above (credentials, job reconfiguration, automated actions reconfiguration, groups etc).

I understand that your network is quite large, so good luck with that and have patience.



I have now deleted all the devices and made a complete reinitializing of all databases.  Then I have done the discovery and manually added the devices that the discovery did not find.  It has now been almost two weeks and this issue has not come back.  Hopefully it is gone forever.  Must be som kind of bug with the import of database from earlier versions or import of devices.  Atleast we found a good workaround..

Have a nice summer

Glad to hear that everything worked out fine!

Hopefully this is the last bug we encounter!

Have a nice summer