Showing results for 
Search instead for 
Did you mean: 

Ask the Expert- SD-WAN


Syslog EEM applet not working...

Hi everybody,

i have a problem with a quite simple EEM applet actually. It isn´t working, no exact idea why.

I have some other EEM applets configured on this router before also, each of them works...8 actually.

I f i check "sh event manager policy registered" the new applet doesn´t show up.

EDIT: Forgot to mention, it´s definitely included in the config!

Maybe i miss something quite simple, no idea...if i do the debug, i can´t see the new applet is working at all.

event manager applet CHANNELSFULL

event syslog pattern "CC_CHAN_GetIdleChanbri: All channels busy"

action 1.000  mail server "$MAILSRV" to "$MAILTO" from "$MAILFROM" subject "All channels busy" body "Circuits busy!"

action 1.010 syslog msg "Mail CHANNELSFULL sent!"

action 1.100 end

As you can see, really totally simple. The other applets are more "complicated", this is the simplest i running into a maximum number of EEM applets or sth like that?

Its a cisco 2811 with c2800nm-adventerprisek9-mz.124-24.T6.bin.

Thanks for the input,



Syslog EEM applet not working...

event manager applet CHNFULL

event syslog pattern "CC_CHAN_GetIdleChanbri"

action 1.005 mail server "$MAILSRV" to "$MAILTO" from "$MAILFROM" subject "All channels busy" body "Circuits busy!"

...then it worked 8O


hi guys,

hi guys,

Im trying to create a simple applet scripts but still does not show up when i run it.

this is the example:-

(config)#event manager applet set_ip
event none sync yes
action 1 cli command "enable"
action 2 cli command "configuration terminal"
action 3 cli command "interface gi1"
action 4 cli command "ip add 172.17.14.x"
action 5 cli command "no shutdown"
action 6 cli command "end"

vcpe20-01.rndlab#event manager run set_ip


when i checked from the log there is no activity on this

but when i try to add another scripts it appear


event manager applet cbtme
event none
action 1.0 syslog msg "cbtme welcome you"
event manager run cbtme

*Feb 16 09:01:07.973: %HA_EM-6-LOG: cbtme: cbtme welcome you


it works but not with IP.

Can you please advise.???

need help urgent asap

Hall of Fame Cisco Employee

Please start a new thread for

Please start a new thread for your issue.


Hi Joe, 

Hi Joe, 

Thanks for ur fast response.

may i know what do u mean by " start the new thread" ? can u elaborate?

really appreciate your feedback


Hall of Fame Cisco Employee

I mean start a new forum

I mean start a new forum topic as opposed to posting to an old thread that was for a different topic.


hi Joe,

hi Joe,

sorry for that, i taught it can be continue from the last topics, which at first i was trying to find the answer on the same issue which i facing now and reply on the top of the first main topics.

thanks n noted


Hi Joe | Team,

Hi Joe | Team,

just updated with the new thread topic."EEM Applet Scripts not working"

Please have some point of view from your end.


CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards