cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
588
Views
0
Helpful
7
Replies

5505 doesn't recognize ip address dhcp...

CSCO10936521
Beginner
Beginner

Hello.

Sorry for the dumb question but weirdly enough to me, my 5505 running on version 8.2.5 doesn't seem to recogize the simple command "ip address dhcp setroute......"

ciscoasa(config-if)# ip address dhcp

                                ^

ERROR: % Invalid Hostname

ciscoasa(config-if)# ip address ?  

configure mode commands/options:

  Hostname or A.B.C.D  Firewall's network interface address

being a complete newbie in firewall, I wonder what I have missed here, and how it can be resolved.

Thanks a lot!

1 Accepted Solution

Accepted Solutions

Hi,

Your firewall seems to be set to "firewall transparent"

So this command is not accepted. Its not possible to configure this setting while the firewall is in Transparent mode.

Was your purpose to configure the firewall as Transparent?

If not then you would have to issue the command

no firewall transparent

To first change the firewall to Router mode.

- Jouni

View solution in original post

7 Replies 7

Jouni Forss
Mentor
Mentor

Hi,

Would it be possible to see the current ASA configuration?

- Jouni

Certainly,

sh run

: Saved

:

ASA Version 8.2(5)

!

firewall transparent

hostname ciscoasa

domain-name selfip.com

enable password tp1T4TLV1xTHbvz9 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

!

interface Vlan2

nameif outside

security-level 0

!

regex test ".9746"

boot system disk0:/asa825-k8.bin

boot system disk0:/asa823-k8.bin

ftp mode passive

clock timezone EST -5

clock summer-time EDT recurring

dns server-group DefaultDNS

domain-name selfip.com

object-group service DM_INLINE_UDP_1 udp

port-object eq bootpc

port-object eq bootps

access-list out-in extended permit icmp any any

access-list out-in extended permit udp 192.168.0.0 255.255.255.0 192.168.0.0 255.255.255.0 object-group DM_INLINE_UDP_1

access-list inside_access_in extended permit ip any any

pager lines 24

logging enable

logging buffered debugging

logging asdm informational

mtu inside 1500

mtu outside 1500

ip address 192.168.0.249 255.255.255.0

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

access-group inside_access_in in interface inside

access-group out-in in interface outside

route outside 0.0.0.0 0.0.0.0 192.168.0.254 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

aaa authentication telnet console LOCAL

aaa authentication http console LOCAL

aaa authentication ssh console LOCAL

aaa authorization exec LOCAL

http server enable

http 192.168.0.0 255.255.255.0 inside

http 192.168.0.0 255.255.255.0 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

telnet 192.168.0.0 255.255.255.0 inside

telnet 192.168.0.0 255.255.255.0 outside

telnet 67.69.143.56 255.255.255.248 outside

telnet timeout 5

ssh 192.168.0.0 255.255.255.0 outside

ssh timeout 5

console timeout 0

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

ntp server 204.9.54.119 source outside

ntp server 72.51.27.50 source outside

username jjiang password 1q1CgPBVciJvU35H encrypted privilege 15

!

class-map type inspect sip match-all test

match calling-party regex test

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map type inspect h323 test

parameters

match calling-party regex test

  reset

!

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:809401b60fa5f98e2f82c6174d2c35ab

: end

Hi,

Your firewall seems to be set to "firewall transparent"

So this command is not accepted. Its not possible to configure this setting while the firewall is in Transparent mode.

Was your purpose to configure the firewall as Transparent?

If not then you would have to issue the command

no firewall transparent

To first change the firewall to Router mode.

- Jouni

Oh yes. I recalled that the first owner (this is the used one which I purchased more than two year ago but never played with it since... the owner warned me that there's some configs on it that was related to transparent something...

Thanks a million~!

Hi,

Can you mark the question as answered

- Jouni

sure I did.

My network was disconnected due to some unrelated issue and just got fixed so sorry for the delay.

No problem

If you are going to change the ASA to routed mode and configure it you can always post a question on these forums if you run into some problems with the configurations

- Jouni

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers