cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

698
Views
0
Helpful
11
Replies
Nazarevych
Beginner

Adding public block IPs to ASA

Hi all, I've got some public IPs from our ISP 154.x.x.x/24. Also, I have one IP address 149.x.x.x/30 that binds me with ISP. 154.x.x.x/24 subnet should be used for web servers. I'm trying to implement this configuration in ASAv(9.15 version). My goal: 149.x.x.x/30 use as ASA Default Gateway, 154.x.x.x/24 use as separate subnets with traffic forwarding via 149.x.x.x/30. This scenario I've done it successfully on L3 switch, but with ASA have some troubles. After the configuring outside interface as 149.x.x.x/30 I'm able to go outside, my outside interface 149.x.x.x/30 is also visible from global, but neither IP of 154.x.x.x/24 available from "world". Is it possible to implement this scenario on ASA or not? 

P.S. My ASA is not licensed, but I should know before purchasing if it's possible to make

1 ACCEPTED SOLUTION

Accepted Solutions

@Nazarevych 

Not much information regarding that message...but the message implies you've reached a limit!!

https://bst.cloudapps.cisco.com/bugsearch/search?kw=(rm-conn-limit)%20RM%20connection%20limit%20reached&pf=prdNm&sb=anfr

 

Do you have many connected devices behind the ASA right now?

How many current connections do you have? - use "show conn" command

If you do, disconnect the inside interface, clear the connections and try again from the web-srv209 network.

 

The error aside. There is no reason why this won't work when you have do have a license. All you are doing is routing from the 154.x.x.x network. You'll only need Dynamic PAT for the networks behind the inside interface.

View solution in original post

11 REPLIES 11
Rob Ingram
VIP Mentor

@Nazarevych 

You just need to create NAT objects in the 154.x.x.x/24 range and ensure the ISP routes this network to the outside interface IP 149.x.x.x/30 IP address of the ASA>

Thank you for your answer, NAT is working successfully, but I want each web server from subnet 154.x.x.x/24 will be accessible from global, not as single ip 149.x.x.x/30.   As on this scheme bellow:asa1.png

You don't need to nat behind 149.x.x.x ip address.

Have you assigned these 154.x.x.x to the physical interface of the webservers? In which case you don't need nat.

Or do you have a static NAT for each? Translating a private IP address to a unique 154.x.x.x?

Provide your configuration.

ISP provides the routing from 149.x.x.x/30 to 154.x.x.x/24 and rent us one ip from subnet 149.x.x.x/30 and whole subnet 154.x.x.x/24. We should not use the NAT, just forward the traffic from 154.x.x.x/24 via 149.x.x.x/30(toward the ISPs network). Web servers should use the public IPs of subnet 154.x.x.x/24. Also, the clients should resolve web servers public IPs as well

You still haven't confirmed whether the 154.x.x.x addresses are assigned to the webservers interfaces, if so then the traffic is just routed via the next hop. If they are not you will need to translate from the private ip address to the 154.x.x.x address using a one-to-one static nat.

 

Provide your configuration and we can see what is misconfigured.

 

Run packet-tracer from inside to outside to simulate the traffic flow, provide the output for review.

Yes, I've assigned 154.x.x.x IPs to the physical interface of the webservers.

 

Traffic should forwards via the default gateway, agree with you, but probably something I've missed.

Here my ASA configuration:

 

asav-fr# sh run
: Saved

:
: Serial Number: AA57Bc92DD2
: Hardware: ASAv, 16384 MB RAM, CPU Xeon 4100/6100/8100 series 3200 MHz, 1 CPU (8 cores)
:
ASA Version 9.15(1)7
!
hostname asav-fr
enable password ***** pbkdf2
service-module 0 keepalive-timeout 4
service-module 0 keepalive-counter 6
!
license smart reservation
names
no mac-address auto

!
interface GigabitEthernet0/0
description Outside_interface contains
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/0.3
description outside_interface
vlan 3
nameif outside_interface
security-level 0
ip address 149.x.x.2 255.255.255.252
!
interface GigabitEthernet0/1
description Contain Inside_interface
nameif inside_interface
security-level 100
ip address 10.0.0.1 255.255.255.0
!
interface GigabitEthernet0/2
description Interface contains Public pool web-server addresses
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/2.209
description web-srv209
vlan 209
nameif web-srv209
security-level 0
ip address 154.x.x.1 255.255.255.0
!
interface GigabitEthernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/4
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/5
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/6
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/7
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/8
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
no management-only
nameif management
security-level 0
no ip address
!
ftp mode passive
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network any-net
subnet 0.0.0.0 0.0.0.0
access-list outside_interface_access_in extended permit ip any any
access-list web-srv209_access_in extended permit ip any any
access-list web-srv209_access_out extended permit ip any any
pager lines 23
logging enable
logging asdm informational
mtu outside_interface 1500
mtu inside_interface 1500
mtu web-srv209 1500
mtu management 1500
no failover
no failover wait-disable
no monitor-interface outside_interface
no monitor-interface web-srv209
no monitor-interface service-module
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 32768
access-group outside_interface_access_in in interface outside_interface
access-group web-srv209_access_in in interface web-srv209
access-group web-srv209_access_out out interface web-srv209
!
route outside_interface 0.0.0.0 0.0.0.0 149.x.x.1 1
route inside_interface 10.0.0.0 255.255.255.0 10.0.0.2 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
timeout conn-holddown 0:00:15
timeout igp stale-route 0:01:10
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
aaa authentication login-history
http server enable
http 0.0.0.0 0.0.0.0 inside_interface
no snmp-server location
no snmp-server contact
sysopt noproxyarp web-srv209
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpoint _SmartCallHome_ServerCA
no validation-usage
crl configure
crypto ca trustpool policy
auto-import
crypto ca certificate chain _SmartCallHome_ServerCA
certificate ca 0509
308205b7 3082039f a0030201 02020205 09300d06 092a8648 86f70d01 01050500
3045310b 30090603 55040613 02424d31 19301706 0355040a 13105175 6f566164
6973204c 696d6974 6564311b 30190603 55040313 1251756f 56616469 7320526f
6f742043 41203230 1e170d30 36313132 34313832 3730305a 170d3331 31313234
31383233 33335a30 45310b30 09060355 04061302 424d3119 30170603 55040a13
1051756f 56616469 73204c69 6d697465 64311b30 19060355 04031312 51756f56
61646973 20526f6f 74204341 20323082 0222300d 06092a86 4886f70d 01010105
00038202 0f003082 020a0282 0201009a 18ca4b94 0d002daf 03298af0 0f81c8ae
4c19851d 089fab29 4485f32f 81ad321e 9046bfa3 86261a1e fe7e1c18 3a5c9c60
172a3a74 8333307d 615411cb edabe0e6 d2a27ef5 6b6f18b7 0a0b2dfd e93eef0a
c6b310e9 dcc24617 f85dfda4 daff9e49 5a9ce633 e62496f7 3fba5b2b 1c7a35c2
d667feab 66508b6d 28602bef d760c3c7 93bc8d36 91f37ff8 db1113c4 9c7776c1
aeb7026a 817aa945 83e205e6 b956c194 378f4871 6322ec17 6507958a 4bdf8fc6
5a0ae5b0 e35f5e6b 11ab0cf9 85eb44e9 f80473f2 e9fe5c98 8cf573af 6bb47ecd
d45c022b 4c39e1b2 95952d42 87d7d5b3 9043b76c 13f1dedd f6c4f889 3fd175f5
92c391d5 8a88d090 ecdc6dde 89c26571 968b0d03 fd9cbf5b 16ac92db eafe797c
adebaff7 16cbdbcd 252be51f fb9a9fe2 51cc3a53 0c48e60e bdc9b476 0652e611
13857263 0304e004 362b2019 02e874a7 1fb6c956 66f07525 dc67c10e 616088b3
3ed1a8fc a3da1db0 d1b12354 df44766d ed41d8c1 b222b653 1cdf351d dca1772a
31e42df5 e5e5dbc8 e0ffe580 d70b63a0 ff33a10f ba2c1515 ea97b3d2 a2b5bef2
8c961e1a 8f1d6ca4 6137b986 7333d797 969e237d 82a44c81 e2a1d1ba 675f9507
a32711ee 16107bbc 454a4cb2 04d2abef d5fd0c51 ce506a08 31f991da 0c8f645c
03c33a8b 203f6e8d 673d3ad6 fe7d5b88 c95efbcc 61dc8b33 77d34432 35096204
921610d8 9e2747fb 3b21e3f8 eb1d5b02 03010001 a381b030 81ad300f 0603551d
130101ff 04053003 0101ff30 0b060355 1d0f0404 03020106 301d0603 551d0e04
1604141a 8462bc48 4c332504 d4eed0f6 03c41946 d1946b30 6e060355 1d230467
30658014 1a8462bc 484c3325 04d4eed0 f603c419 46d1946b a149a447 3045310b
30090603 55040613 02424d31 19301706 0355040a 13105175 6f566164 6973204c
696d6974 6564311b 30190603 55040313 1251756f 56616469 7320526f 6f742043
41203282 02050930 0d06092a 864886f7 0d010105 05000382 0201003e 0a164d9f
065ba8ae 715d2f05 2f67e613 4583c436 f6f3c026 0c0db547 645df8b4 72c946a5
03182755 89787d76 ea963480 1720dce7 83f88dfc 07b8da5f 4d2e67b2 84fdd944
fc775081 e67cb4c9 0d0b7253 f8760707 4147960c fbe08226 93558cfe 221f6065
7c5fe726 b3f73290 9850d437 7155f692 2178f795 79faf82d 26876656 3077a637
78335210 58ae3f61 8ef26ab1 ef187e4a 5963ca8d a256d5a7 2fbc561f cf39c1e2
fb0aa815 2c7d4d7a 63c66c97 443cd26f c34a170a f890d257 a21951a5 2d9741da
074fa950 da908d94 46e13ef0 94fd1000 38f53be8 40e1b46e 561a20cc 6f588ded
2e458fd6 e9933fe7 b12cdf3a d6228cdc 84bb226f d0f8e4c6 39e90488 3cc3baeb
557a6d80 9924f56c 01fbf897 b0945beb fdd26ff1 77680d35 6423acb8 55a103d1
4d4219dc f8755956 a3f9a849 79f8af0e b911a07c b76aed34 d0b62662 381a870c
f8e8fd2e d3907f07 912a1dd6 7e5c8583 99b03808 3fe95ef9 3507e4c9 626e577f
a75095f7 bac89be6 8ea201c5 d666bf79 61f33c1c e1b9825c 5da0c3e9 d848bd19
a2111419 6eb2861b 683e4837 1a88b75d 965e9cc7 ef276208 e291195c d2f121dd
ba174282 97718153 31a99ff6 7d62bf72 e1a3931d cc8a265a 0938d0ce d70d8016
b478a53a 874c8d8a a5d54697 f22c10b9 bc5422c0 01506943 9ef4b2ef 6df8ecda
f1e3b1ef df918f54 2a0b25c1 2619c452 100565d5 8210eac2 31cd2e
quit
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh version 2
ssh key-exchange group dh-group14-sha1
ssh 0.0.0.0 0.0.0.0 inside_interface
console timeout 0
management-access web-srv209
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
dynamic-access-policy-record DfltAccessPolicy
username cisco password ***** pbkdf2 privilege 15
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map global_policy
class inspection_default
inspect ip-options
inspect netbios
inspect rtsp
inspect sunrpc
inspect tftp
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect esmtp
inspect sqlnet
inspect sip
inspect skinny
inspect snmp
policy-map type inspect dns migrated_dns_map_2
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map type inspect dns migrated_dns_map_1
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
profile License
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination transport-method http
Cryptochecksum:e9aaf1f07e9615b4e5eueihed637e6e
: end

 

remark:

inside_interface 10.0.0.1 is directed to the L3 switch (10.0.0.2) and I'm using it just to get access to SSH/HTTP

Also, all VLANs configured at this L3 switch as well, internal routing is working too well.

@Nazarevych the only thing that stands out is the security level, try changing the security-level of Gi0/2.209 from 0 to 50. 0 is the lowest trusted and usually only the outside interface is set to 0.

 

interface GigabitEthernet0/2.209
description web-srv209
vlan 209
nameif web-srv209
security-level 50

If you still have a problem run packet-tracer, e.g. packet-tracer input web-srv209 tcp 154.x.x.5 3000 8.8.8.8 80

 

Don't use the FW IP .1 as the source, provide the output for review.

Thank you for advice,

I've changed the security-level of web-srv209 interface, but unfornutely results still the same. Here my outup:

 

asav-fr# packet-tracer input web-srv209 tcp 154.x.x.162 3000 8.8.8.8 80

Phase: 1
Type: ACCESS-LIST
Subtype:
Result: ALLOW
Config:
Implicit Rule
Additional Information:
MAC Access list

Phase: 2
Type: INPUT-ROUTE-LOOKUP
Subtype: Resolve Egress Interface
Result: ALLOW
Config:
Additional Information:
Found next-hop 149.x.x.1 using egress ifc outside_interface

Phase: 3
Type: ACCESS-LIST
Subtype: log
Result: ALLOW
Config:
access-group web-srv209_access_in in interface web-srv209
access-list web-srv209_access_in extended permit ip any any
Additional Information:

Phase: 4
Type: NAT
Subtype: per-session
Result: ALLOW
Config:
Additional Information:

Phase: 5
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:

Result:
input-interface: web-srv209
input-status: up
input-line-status: up
output-interface: outside_interface
output-status: up
output-line-status: up
Action: drop
Drop-reason: (rm-conn-limit) RM connection limit reached, Drop-location: frame 0x000055b0dd67e9a3 flow (NA)/NA

Is the drop-reason mean my 100 kbit/s ASA free license limitation restricts this act?

@Nazarevych 

Not much information regarding that message...but the message implies you've reached a limit!!

https://bst.cloudapps.cisco.com/bugsearch/search?kw=(rm-conn-limit)%20RM%20connection%20limit%20reached&pf=prdNm&sb=anfr

 

Do you have many connected devices behind the ASA right now?

How many current connections do you have? - use "show conn" command

If you do, disconnect the inside interface, clear the connections and try again from the web-srv209 network.

 

The error aside. There is no reason why this won't work when you have do have a license. All you are doing is routing from the 154.x.x.x network. You'll only need Dynamic PAT for the networks behind the inside interface.

View solution in original post

For a test, I run just one Linux-based VM that connected to 154.x.x.x network, and only this one located behind ASA

 

Every time I have approximately 100 connections even my inside interface in a shutdown state and also after the 'clear conn' command completed. Regardless my web-srv209 interface is shutdown or no shutdown or with a narrower mask (/30 for instance) I see these connections:

 

TCP outside_interface  154.x.x.143:19912 outside_interface  91.x.x.x:43909, idle 0:00:11, bytes 0, flags SaAB 
TCP outside_interface  154.x.x.143:20170 outside_interface  193.x.x.x:41471, idle 0:00:12, bytes 0, flags SaAB 
TCP outside_interface  154.x.x.210:8883 outside_interface  184.x.x.x:60839, idle 0:00:10, bytes 0, flags SaAB 
.
.
.

the public IPs I see geographically distributed around the world, but the destination network definitely mine (154.x.x.x/24)

Thank you for your advice on the number of connections. After made restricting the amount of them directed inside in my network via outside_interface the routing has been working correctly