cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

4417
Views
0
Helpful
17
Replies
Highlighted
Beginner

Cisco ASA5505 PPPoE no internet - Help needed

We currently use a linux software based firewall called IPCop that sits between our network and router (This is in bridged mode) IPCop conects over PPPoE and everything works fine.

However the system is not reliable and I fear not that secure so have purchased an ASA5505 now I have added the PPPoE info to the device using the ADSM software however although it picks up my external static IP I'm unable to access the internet. On IPCop I only had to enter the broadband credentials and it worked however I feel like I may have to add more to the Cisco, for example do I have to specify DNS servers and do I have to set a static route?

Here is my config file so far (Note I think I have turned on the abilty to ping from internal to external however if someone could confirm that would be great)

Please note I am new to this and most of my config I have done through the ADSM as opposed to the CLI

: Saved
:
ASA Version 8.4(3)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.205.3 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
pppoe client vpdn group UniqueParty
ip address pppoe setroute
!
ftp mode passive
object network obj_any
subnet 0.0.0.0 0.0.0.0
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
!
object network obj_any
nat (inside,outside) dynamic interface
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.205.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ca trustpoint _SmartCallHome_ServerCA
crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group UniqueParty request dialout pppoe
vpdn group UniqueParty localname C******@hg28.btclick.com
vpdn group UniqueParty ppp authentication chap
vpdn username C******@hg28.btclick.com password *****

dhcpd auto_config outside
!
dhcpd address 192.168.205.7-192.168.205.254 inside
dhcpd auto_config outside interface inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
!
service-policy global_policy global
prompt hostname context
service call-home
call-home reporting anonymous
call-home
contact-email-addr mmcelhenny@

profile CiscoTAC-1
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:2b4d23a148be5a3b2adc677b0a16dc94
: end
no asdm history enable

17 REPLIES 17
Highlighted
Cisco Employee

config looks good so far.

Are you getting an ip address on your outside interface? pls share the output of "show int ip brief"

Are you getting a default route? pls share the output of "show route"

Can you ping 4.2.2.2 from an internal host?

Is the ASA configured as a DHCP server or you are having an internal DHCP server/static IP?

Highlighted

Hi Jennifer,

Yes the outside interface in the ADSM goes from status [PPPoE] to my external static IP so I know the authentication is working.

As this is a live environment I'm unabel to switch the internet over to the Cisco ASA until after 5pm UK time so once I do that I will post back with the results of those questions you asked me.

Finally I have DHCP turned off on the the internal interface as our own domain controllers issue IP address's. Bascially I have my internet line going into my router which is set to bridged then an ethernet cable going from here to port 0 on the ASA, the an ethernet cable going from Port 1 to our main office switch.

Computers are given IP's from domain controller and each PC's is given the gateway address of 192.168.205.3 which is the lan IP of the ASA. (Its also the LAN IP of our current firewall IPCop but I shut this down whilst I have the ASA live)

Hope this makes sense!

Mark

Highlighted

Right I've done some more testing and it appears that I can connect to the PPPoE fine and I can ping IP addresses the problem is I can't ping host names so looks like a DNS issue should the Cisco be picking up DNS info automatically?

I tried enabling DNS on the outside interface and added a known BT DNS server and through the Ping tool in ADSM I was able to ping by host name however I was still unable to ping the host from the command prompt on my PC or able to access any websites.

My test laptop that is connected to the ASA is currently configured with static info (Normally it would be DHCP via our domain controllers) so has a gateway of 192.168.205.3 and DNS server of 192.168.205.3 (This is the LAN IP of the ASA) I'm presuming that this is correct.

Here is the output from the commands you asked me to run:

UUKFIREWALL001# show int ip brief
Interface                  IP-Address      OK? Method Status                Prot
ocol
Ethernet0/0                unassigned      YES unset  up                    up

Ethernet0/1                unassigned      YES unset  down                  down

Ethernet0/2                unassigned      YES unset  up                    up

Ethernet0/3                unassigned      YES unset  down                  down

Ethernet0/4                unassigned      YES unset  down                  down

Ethernet0/5                unassigned      YES unset  down                  down

Ethernet0/6                unassigned      YES unset  down                  down

Ethernet0/7                unassigned      YES unset  down                  down

Internal-Data0/0           unassigned      YES unset  up                    up

Internal-Data0/1           unassigned      YES unset  up                    up

Vlan1                      192.168.205.3   YES CONFIG up                    up

Vlan2                      81.137.203.172  YES CONFIG up                    up

Virtual0                   127.0.0.1       YES unset  up                    up

UUKFIREWALL001# sh route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 217.32.145.1 to network 0.0.0.0

Ping 4.2.2.2 came back with 100% sucess.

Any further info would be great!

Highlighted

sh vpdn

sh vpdn session

Sent from Cisco Technical Support iPad App

Highlighted

When I type both of those commands in it says they are incomplete.

Highlighted

sh vpdn session state

Sent from Cisco Technical Support iPad App

Highlighted

That's weird, looks incorrect.

The public IP assigned is 81.137.203.172, but your default gateway is 217.32.145.1, completely different subnet.

Can you try to remove the pppoe command and re-add it:

interface vlan2

  no ip address pppoe setroute

  ip address pppoe setroute

And check the output from the command advised earlier again.

Highlighted

Jennifer, with PPPoE the DG does not have to in the same subnet.

Sent from Cisco Technical Support iPad App

Highlighted

As I've metioned before as this is a live system I'm not able to just plug teh CIsco in with it not working so will try the command suggested by c.spescha tomorrow evening.

With regards to the gateway IP when I switched back to our IPCop firewall last night I checked what it had as the gateway IP and it is the same as what the Cisco was picking up:

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:81.137.203.172  P-t-P:217.32.145.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP  MTU:1492  Metric:1
          RX packets:120006 errors:0 dropped:0 overruns:0 frame:0
          TX packets:121539 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:132608509 (126.4 MB)  TX bytes:21163664 (20.1 MB)

Routing Table Entries:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
217.32.145.1    0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
1.1.1.0         0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.205.0   0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         217.32.145.1    0.0.0.0         UG    0      0        0 ppp0
Highlighted

I've also been told that my config is missing this line:

global (Outside) 1 interface

Could adding this line solve my DNS resolving issue?

Cheers

Mark

Highlighted

No, that line "global (Outside) 1 interface" is old version of code (8.2 and lower), and as you are running version 8.4, that command doesn't exist anymore. Your NAT statement is already correct.

If DNS is the issue, pls add the DNS to your DHCP server as your internal DHCP server is the one assigning IP address to your internal host. BTW, don't turn off the internal DHCP server as you should keep using it to assign IP address including the DNS server information.

Highlighted

Hi are you saying I should add the ip addresses of our ISP DNS servers to our DHCP server? The only reason I ask is that when running the IPCop firewall we don't need our ISP DNS server entries on the DHCP server yet we are still able to resolve host names.

I'll give you our current setup for DHCP PC's

All the PC's on the network are assigned an IP address between 192.168.205.32 to 192.168.205.200 they are given a subnet of 255.255.255.0 a default gateway of 192.168.205.3 (Currently the IPCop firewall) and DNS servers of 192.168.205.6 (DC does DHCP and DNS) and 192.168.205.8 (DC only does DNS) Both Domain controllers only have each other as DNS servers and have 192.168.205.3 as the gateway. My understanding is that when I access the internet from my PC it goes to my two DC's for DNS lookup if it can't find the info in our local DNS table it then goes out the DC's gateway and retrieves it from our ISP's DNS servers so any request for something outside the network would go to our ISP'S DNS servers, I don't have the ISP DNS servers setup on any server or even in the IPCop firewall. All I have setup in IPCop is the PPPoE client and under DNS servers it is selected as automatic.

All I am trying to do is replace the IPCop firewall with the Cisco ASA hence why I have given it the same LAN IP so nothing needs changing. I thought it would be just a matter of doing a similar thing set up the lan side and then setup the PPPoE client on the WAN side however like I say although it connects fine but it is unable to resolve DNS.

My test laptop has its DNS server pointing to the firewall directly as it is plugged into the Cisco directly as opposed to through the switch.

Also enabling DHCP on the Cisco Lan side would surely mean that PC's could potentially pick up IP address's from the CIsco instead of our own DHCP server in which case it could allocate and already in use IP address causing a conflict?

Sorry for going into so much detail but just tyring to give you the full picture of wht we have and also what I would like!

Highlighted

You would also need to enable DHCPD on the inside interface so the ASA is actually acting as a DHCP server for inside network.

dhcpd enable inside

Need to also turn off your other DHCP server when you use ASA as the DHCP server.

Highlighted

Our network is part of a bigger network so we would not be able to use the Cisco ASA's DHCP client over our own to be fair most big companies will use there own DHCP server so the fact that to get his working means doing what you suggested is a definite no go.

If this is the only way to get it working over PPPoE then I will have to look at a different method.

If I was to switch the ADSL modem out of bridged mode and back into an ADSL modem can I place the CIsco ASA between our corporate network and ADSL modem? If so how would I go about configuring the ASA as again DHCP would still need to be turned off on the ASA like wise on the modem, they would both be assigned static LAN IP's in the same subent as our corporate network:

192.168.205.xxx

Content for Community-Ad