cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2230
Views
20
Helpful
9
Replies
jhubel@midwave
Beginner

Fatal error: Update to version <number> is not complete. Please complete update to <number>

Hi all -

 

I have an ASA 5515 sensor running software v5.4.0 (build 763).  On my Defense Center (which is running 5.4.1), I tried to push out a sensor update to version 5.4.0.11 without first reading the release notes.  Naturally, I got this error:

"Fatal error: This patch is for IMS versions greater than or equal to 5.4.0.5 and less than 5.4.0.10."

 

No worries, I read the release notes and decided I would go to 5.4.0.3 first.  So, I tried to push that out and I get this message:

"Fatal error: Update to version 5.4.0.11 is not complete. Please complete update to 5.4.0.11"

 

I've rebooted the sensor to no avail.  Short of reimaging, how else can I purge the update to 5.4.0.11 so I can instead get the upgrade to 5.4.0.3 to start?

 

Any help is much appreciated!

9 REPLIES 9
r.mikes
Beginner

Hi,

 

have you found any solution ?

 

I have the same problem. I can't patch from 5.4.0.3 to 5.4.0.4 after unsuccessful try to update to 5.4.0.11 .

Any other idea than recovery ?

 

Regards

Roman

Hi,

If you are doing an upgrade and it fails do not reboot the devices contact Cisco TAC.
Have seen this problem multiple times and sometimes it ends up with a corrupted DB and then you need to re-install everything from backup.

Contact Cisco TAC and see if they can help you.

br, Micke

 

P.S. I have learnt the hard way to read Firepower release notes very carefully, as it's not like in good old days just to install a new version.

No, I was not able to solve the problem.  I ended up reimaging the sensor.

Anyone solved the problem ?

Is possible to solve the issue without re-image the module ?

Hi Rafaella,

 

it seams re-imaging is the only solution.

 

Regards

Roman

Hello Team,

 

I had a couple of customer that had the similar error. I tried everything, from the earlier update, editing a couple of database entries and more, but at the end the only resolution was a reimage.

As someone mentioned, do not reboot, open a P1 or P2 SR.

 

If you do need to reimage, ensure to get a screenshot of all your device settings, so it makes the reimage/reconfiguration easier.

Damon Kalajzich
Beginner

Delete the upgrade lock file

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvh53425/?rfs=iqvred

its the .update_version_lock_file

 

Can you tell us the correct path for the .update_version_lock_file ?

It should be in /var/log/sf/

Content for Community-Ad