Showing results for 
Search instead for 
Did you mean: 

FTD change ssh timeout?


Hi all,  FTD keeps logging me out (after about 5 min i think).  would like to set

ssh timeout 60


is there a way to do that?

(we're using FMC to manage FTD)


Thanks in advance

7 Replies 7


You can manage this from FMC > Device > Platform Settings > Timeout

***** please remember to rate useful posts

I've looked there so many times. sadly, ssh isn't listed on that page

Hey r.walthall,

I'm in the same boat.  And it's not listed on there for me either.  

Did you ever find out where that is?

Thank you!

Configure Global Timeouts

You can set the global idle timeout durations for the connection and translation slots of various protocols. If the slot has not been used for the idle time specified, the resource is returned to the free pool.

You can also set a time out for console sessions with the device.


Step 1

Choose Devices > Platform Settings and create or edit the threat defense policy.

Step 2

Select Timeouts.

Step 3

Configure the timeouts you want to change.

For any given setting, select Custom to define your own value, Default to return to the system default value. In most cases, the maximum timeout is 1193 hours.

You can disable some timeouts by selecting Disable.

  • Console Timeout—The idle time until a connection to the console is closed, range is 0 or 5 to 1440 minutes. The default is 0, which means the session does not time out. If you change the value, existing console sessions use the old timeout value. The new value applies to new connections only.

Hi @Marvin Rhoads 

does this console timeout applies to the ssh session to the ftd?


Daniel Gutierrez

@Daniel Jacob Gutierrez it only applies to console serial port - not ssh. I don't believe we can set the ssh timeout currently.

@Marvin Rhoads  thanks!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: