cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
336
Views
2
Helpful
7
Replies

FTP Connexion issue

Damien2
Beginner
Beginner

Hello

I am stuck when trying to use FTP protocol between my Computer and my ASA 5505 using Putty.
I am trying to download the "asa923-k8.bin" file from my ASA (192.168.2.254) to my PC (at this place: C:\Users\Admin\).

On ASA, into the INSIDE section, I've created a rule to permit FTP and FTP-DATA traffic.
When passing the command into CLI I get a "Permission denied" error message.

See the error:

ciscoasa# copy ftp://cisco:cisco123@192.168.2.254/asa923-k8.bin disk0:/asa923-$
Address or name of remote host [192.168.2.254]? 192.168.2.254
Source username? xxxx (correct username)
Source password? xxxx (correct password)
Source filename [asa923-k8.bin]? asa923-k8.bin
Destination filename [asa923-k8.bin]? C:\Users\Admin\asa923-k8.bin
Accessing ftp://cisco:cisco123@192.168.2.254/asa923-k8.bin...
%Error opening ftp://cisco:cisco123@192.168.2.254/asa923-k8.bin (Permission denied)


Below my confguration:

interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
interface Ethernet0/2
!
interface Ethernet0/3
switchport access vlan 3
shutdown
!
interface Ethernet0/4
shutdown
!
interface Ethernet0/5
shutdown
!
interface Ethernet0/6
switchport access vlan 3
shutdown
!
interface Ethernet0/7
switchport access vlan 3
shutdown
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.2.254 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 192.168.1.50 255.255.255.0
!
interface Vlan3
no forward interface Vlan1
nameif DMZ
security-level 0
ip address 192.168.3.254 255.255.255.0
!
ftp mode passive
dns domain-lookup outside
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network INTERNET
subnet 192.168.1.0 255.255.255.0
description Connexion Orange Box
object network LAN-PRIVE
subnet 192.168.2.0 255.255.255.0
description Lan prive
access-list RESEAU_PRIVE_access_in extended permit icmp any any
access-list RESEAU_PRIVE_access_in extended permit ip any any
access-list RESEAU_EXTERNE_access_in extended permit icmp any any
access-list RESEAU_EXTERNE_access_in extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu DMZ 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network obj_any
nat (inside,outside) dynamic interface
access-group RESEAU_PRIVE_access_in in interface inside
access-group RESEAU_EXTERNE_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.1.10 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication http console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 outside
http 192.168.2.0 255.255.255.0 inside
http 192.168.3.0 255.255.255.0 DMZ
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpoint _SmartCallHome_ServerCA
no validation-usage
crl configure
crypto ca trustpool policy
telnet timeout 5
no ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

threat-detection basic-threat
threat-detection scanning-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ssl server-version any
username cisco password xxxxxxxxxxxxx encrypted privilege 15
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!

ACL

ciscoasa# show access-list
access-list cached ACL log flows: total 0, denied 0 (deny-flow-max 4096)
alert-interval 300
access-list RESEAU_PRIVE_access_in; 4 elements; name hash: 0x67900528
access-list RESEAU_PRIVE_access_in line 1 extended permit icmp any any (hitcnt=922) 0x3c3b4189
access-list RESEAU_PRIVE_access_in line 2 extended permit ip any any (hitcnt=11984) 0x44b06c92
access-list RESEAU_PRIVE_access_in line 3 extended permit tcp object LAN-PRIVE any object-group DM_INLINE_TCP_1 (hitcnt=0) 0xefe3b9e9
access-list RESEAU_PRIVE_access_in line 3 extended permit tcp 192.168.2.0 255.255.255.0 any eq ftp (hitcnt=0) 0x9454988a
access-list RESEAU_PRIVE_access_in line 3 extended permit tcp 192.168.2.0 255.255.255.0 any eq ftp-data (hitcnt=0) 0x37076d66
access-list RESEAU_EXTERNE_access_in; 2 elements; name hash: 0xe040391b
access-list RESEAU_EXTERNE_access_in line 1 extended permit icmp any any (hitcnt=0) 0x13c5ed7a
access-list RESEAU_EXTERNE_access_in line 2 extended permit ip any any (hitcnt=162) 0x71d1f8d3
ciscoasa#

Many thanks for your help
Damien

1 Accepted Solution

Accepted Solutions

Damien2
Beginner
Beginner

Hello

Many thanks for your posts.

MHM: I am using inside IP because is the ASA's ASDM IP address.

Marius:

1. I confirm a FileZilla FTP server is installed on my PC
2. I can ping from my PC to the ASA Firewall => so I guess I do not need to create a rule into the Windows.
3. I've tried the below command and it didn't worked out
copy disk0:/asa923-k8.bin ftp://cisco:cisco123@192.168.2.254/asa923-k8.bin

Still get: %Error opening ftp://cisco:cisco123@192.168.2.254/asa923-k8.bin (Permission denied)


I've finally fixed my issue using the "ASDM File Transfer" option.

See the tutorial: https://ccnpsecuritywannabe.blogspot.com/2020/05/file-transfer-between-local-pc-and.html

I will appreciate your observation regarding my use of the inside IP address.


Many thanks for your help anyway.

Damien

View solution in original post

7 Replies 7

are this issue solved ?
MHM

No the issue is not fixed at all, I couldn't find the root cause. Can you help ?

Why you use inside IP as server IP in your command?

As I know the command is 

Username:password@serverIP

Also make sure the path in server for asa image file.

MHM

See my reply below

your copy FTP command should be reversed, copy disk0:/asa923-k8.bin ftp://cisco:cisco123@192.168.2.254/asa923-k8.bin if you are trying to copy from the ASA to your local PC.  Also, you do need an FTP server running on your PC and allow this connection in your local firewall on the PC if there is one enabled.

--
Please remember to select a correct answer and rate helpful posts

See below

Damien2
Beginner
Beginner

Hello

Many thanks for your posts.

MHM: I am using inside IP because is the ASA's ASDM IP address.

Marius:

1. I confirm a FileZilla FTP server is installed on my PC
2. I can ping from my PC to the ASA Firewall => so I guess I do not need to create a rule into the Windows.
3. I've tried the below command and it didn't worked out
copy disk0:/asa923-k8.bin ftp://cisco:cisco123@192.168.2.254/asa923-k8.bin

Still get: %Error opening ftp://cisco:cisco123@192.168.2.254/asa923-k8.bin (Permission denied)


I've finally fixed my issue using the "ASDM File Transfer" option.

See the tutorial: https://ccnpsecuritywannabe.blogspot.com/2020/05/file-transfer-between-local-pc-and.html

I will appreciate your observation regarding my use of the inside IP address.


Many thanks for your help anyway.

Damien

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: