cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
665
Views
0
Helpful
0
Replies

HELP! - Cisco ASAv Deployment on AWS

Mohammed Islam
Beginner
Beginner

Hi all,

I am looking for some guidance on the ASA1000v deployment in AWS cloud platform.  I have tried following Cisco's instruction but am having issues.  The image being used is of AMI from the market place.  My environment is as follows;

1 VPC with 2 subnets

192.168.0.0/24 - outside - public

192.168.1.0/24 - inside - private

Elastic IP attached to outside NIC

Security group forwards ALL traffic to outside NIC

'day0-config' includes as per Cisco's instructions:-

ASA Version 9.4.1
!
interface gigabitethernet0/0
nameif outside
security-level 0
ip address 192.168.0.254 255.255.255.0
no shutdown
interface gigabitethernet0/1
nameif inside
security-level 100
ip address 192.168.1.254 255.255.255.0
no shutdown
http server enable
http 0.0.0.0 0.0.0.0 outside
crypto key generate rsa modulus 1024
username cisco password cisco
username admin password cisco
ssh 0.0.0.0 0.0.0.0 outside
aaa authentication ssh console LOCAL

When I specify the day0-config its throws up errors for the additonal interfaces specified above (inside).  I even tried allocating another NIC during the provisioning of the Elastic instance, but still the same problem.  AWS instance also shows 1/2 status check, i.e. failing the 2nd check.

Any help would be much appreciated.

Mo

0 Replies 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers