cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

3769
Views
15
Helpful
19
Replies
ralf.rottmann
Beginner

Host in DMZ cannot get outside (ASA 5505)

Hi there,

Based on the configuration pasted below, we believe the host (10.0.2.200 / 255.255.255.0 GW: 10.0.2.1 with external DNS servers configured) should have access to the web. However, it cannot resolve any names nor can it connect outside. Any idea why? Your help is greatly appreciated.

Here is the config:

ciscoasa# show running-configuration

                             ^

ERROR: % Invalid input detected at '^' marker.

ciscoasa# show runn

ciscoasa# show running-config

: Saved

:

ASA Version 8.4(3)

!

hostname ciscoasa

enable password *** encrypted

passwd *** encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

switchport access vlan 12

!

interface Vlan1

nameif inside

security-level 100

ip address 10.0.1.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address 195.14.245.70 255.255.255.224

!

interface Vlan12

nameif dmz

security-level 50

ip address 10.0.2.1 255.255.255.0

!

ftp mode passive

dns domain-lookup inside

dns domain-lookup outside

dns server-group DefaultDNS

name-server 194.8.194.60

name-server 213.168.112.60

object network obj_any

subnet 0.0.0.0 0.0.0.0

pager lines 24

logging enable

logging asdm informational

mtu inside 1500

mtu outside 1500

mtu dmz 1500

no failover

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

!

object network obj_any

nat (inside,outside) dynamic interface

route outside 0.0.0.0 0.0.0.0 195.14.245.65 1

timeout xlate 3:00:00

timeout pat-xlate 0:00:30

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

aaa authentication ssh console LOCAL

http server enable

http 10.0.1.0 255.255.255.0 inside

http 0.0.0.0 0.0.0.0 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart

crypto ca trustpoint _SmartCallHome_ServerCA

crl configure

crypto ca certificate chain _SmartCallHome_ServerCA

certificate ca 6ecc7aa5a7032009b8cebcf4e952d491

    ***

  quit

telnet timeout 5

ssh 10.0.1.0 255.255.255.0 inside

ssh 0.0.0.0 0.0.0.0 outside

ssh timeout 5

console timeout 0

dhcpd dns 194.8.194.60 213.168.112.60

dhcpd auto_config inside

!

threat-detection basic-threat

threat-detection statistics

threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200

webvpn

username *** password *** encrypted privilege 15

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

class class-default

  user-statistics accounting

!

service-policy global_policy global

prompt hostname context

call-home reporting anonymous

hpm topN enable

Cryptochecksum:***

: end

2 ACCEPTED SOLUTIONS

Accepted Solutions

You need to add:

object network obj_any_dmz

  subnet 0.0.0.0 0.0.0.0

  nat (dmz,outside) dynamic interface.

Thanks,
Varun Rao
Security Team,
Cisco TAC

Thanks,
Varun Rao

View solution in original post

Yes, once you delete it, you need to add this:

object network obj_any_dmz

  subnet 0.0.0.0 0.0.0.0

  nat (dmz,outside) dynamic interface.

Thanks,
Varun Rao

View solution in original post

19 REPLIES 19
Kevin P Sheahan
Contributor

Hi,

You are currently nat'ing inside traffic to go outside, you need to do the same to allow your DMZ to get out.

nat (dmz,outside) dynamic interface

Kind Regards,

Kevin

**Please rate helpful posts and remember to mark your question as answered once resolved!

Kind Regards, Kevin Sheahan, CCIE # 41349

Wow, that was a speedy response. Thanks!

Could you explain how I do that on a) CLI and b) ASDM? That would be just fantastic!

Copy and paste the line below in your CLI.

nat (dmz,outside) dynamic interface

Sent from Cisco Technical Support iPhone App

Kind Regards, Kevin Sheahan, CCIE # 41349

Getting an error:

gcxfw(config)# nat (dmz,outside) dynamic interface

                                 ^

ERROR: % Invalid input detected at '^' marker.

Ok,

Try this...

nat (dmz,outside) 2 source dynamic any interface

Make sure you copy and paste or type it verbatim.. there is a in between "nat" and "(dmz,outside)".

Kind Regards, Kevin Sheahan, CCIE # 41349

The command did work but the host stil seems to be unable to go outside...

You need to add:

object network obj_any_dmz

  subnet 0.0.0.0 0.0.0.0

  nat (dmz,outside) dynamic interface.

Thanks,
Varun Rao
Security Team,
Cisco TAC

Thanks,
Varun Rao

Varun, thanks for checking back in. :-)

I'll add that in a moment. How can I rewoke this one before:

nat (dmz,outside) 2 source dynamic any interface

Best,

-Ralf

Just put a "no" in front of it in the config mode.

Thanks,
Varun Rao
Security Team,
Cisco TAC

Thanks,
Varun Rao
ralf.rottmann
Beginner

And repeat the exact command?

Sent from Cisco Technical Support iPhone App

Yes, once you delete it, you need to add this:

object network obj_any_dmz

  subnet 0.0.0.0 0.0.0.0

  nat (dmz,outside) dynamic interface.

Thanks,
Varun Rao

Worked like a charm. Could you briefly explain what the command does?

Sent from Cisco Technical Support iPad App

Hi,

The command just nats all your traffic from the DMZ interface to the outside interface of the ASA, glad it helped.

Thanks,
Varun Rao
Security Team,
Cisco TAC

Thanks,
Varun Rao

Thanks again. I thought NAT is only required for inbound traffic. Why do I have to NAT outgoing connections?

Create
Recognize Your Peers
Content for Community-Ad