cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
194
Views
0
Helpful
1
Replies

NAT from guest network not working - ASA5512

Michael Murray
Explorer
Explorer

People from the guest subnet 192.168.244.0/24 are unable to connect to the Internet. They can hit the default gateway (.1) but nothing beyond. I'm guessing it has something to do with NAT but I don't see it. What am I missing?

 


ASA Version 9.1(2) 
!
hostname asa
names
!
interface GigabitEthernet0/0
 nameif inside
 security-level 100
 ip address 172.18.0.2 255.255.255.0 
!
interface GigabitEthernet0/1
 nameif outside
 security-level 0
 ip address 1.1.38.34 255.255.255.0 
!
interface GigabitEthernet0/2
 nameif guest
 security-level 0
 ip address 192.168.244.1 255.255.255.0 
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 management-only
 nameif management
 security-level 100
 ip address 10.128.22.1 255.255.255.0 
!
boot system disk0:/asa912-smp-k8.bin
ftp mode passive

object network OBJ_GENERIC_ALL
 subnet 0.0.0.0 0.0.0.0
object network obj-inside
 subnet 172.18.0.0 255.255.255.0
object network obj-guest
 subnet 192.168.244.0 255.255.255.0
object network obj-172.18.0.0
 subnet 172.18.0.0 255.255.255.0
object network obj-10.26.0.0
 subnet 10.26.0.0 255.255.255.0
object network obj-10.26.251.0
 subnet 10.26.251.0 255.255.255.0
object network obj-172.19.0.0
 subnet 172.19.0.0 255.255.255.0
object network obj-10.26.192.0
 subnet 10.26.192.0 255.255.255.0
access-list inbound extended permit icmp any any unreachable 
access-list inbound extended permit icmp any any echo 
access-list inbound extended permit icmp any any time-exceeded 
access-list outside_1_cryptomap extended permit ip 172.18.0.0 255.255.255.0 10.26.0.0 255.255.255.0 
access-list outside_1_cryptomap extended permit ip 172.18.0.0 255.255.255.0 10.26.251.0 255.255.255.0 
access-list outside_1_cryptomap extended permit ip 172.19.0.0 255.255.255.0 10.26.251.0 255.255.255.0 
access-list outside_1_cryptomap extended permit ip 172.18.0.0 255.255.255.0 10.26.192.0 255.255.255.0 
access-list outside_1_cryptomap extended permit ip 172.19.0.0 255.255.255.0 10.26.192.0 255.255.255.0 

pager lines 24
logging buffered errors
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu guest 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-713.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static obj-172.18.0.0 obj-172.18.0.0 destination static obj-10.26.251.0 obj-10.26.251.0
nat (inside,outside) source static obj-172.18.0.0 obj-172.18.0.0 destination static obj-10.26.0.0 obj-10.26.0.0
nat (inside,outside) source static obj-172.19.0.0 obj-172.19.0.0 destination static obj-10.26.251.0 obj-10.26.251.0
nat (inside,outside) source static obj-172.18.0.0 obj-172.18.0.0 destination static obj-10.26.192.0 obj-10.26.192.0
nat (inside,outside) source static obj-172.19.0.0 obj-172.19.0.0 destination static obj-10.26.192.0 obj-10.26.192.0
!
object network obj-inside
 nat (inside,outside) dynamic interface
object network obj-guest
 nat (guest,outside) dynamic interface
!
nat (inside,outside) after-auto source dynamic any interface

route outside 0.0.0.0 0.0.0.0 1.1.38.1 1
route inside 172.19.0.0 255.255.255.0 172.18.0.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL 
http server enable
http 10.128.22.0 255.255.255.0 management
http 172.18.0.0 255.255.255.0 inside
http 172.19.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set ESP-3DES esp-3des esp-md5-hmac 
crypto ipsec security-association pmtu-aging infinite
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer 2.2.253.82 

crypto map outside_map 1 set ikev1 transform-set ESP-3DES
crypto map outside_map interface outside
crypto ca trustpool policy
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
crypto ikev1 policy 20
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 172.18.0.0 255.255.255.0 inside
ssh 172.19.0.0 255.255.255.0 inside
ssh 3.3.136.112 255.255.255.240 outside
ssh timeout 30
ssh key-exchange group dh-group1-sha1
console timeout 0
management-access inside

dhcpd address 10.128.22.20-10.128.22.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ssl encryption rc4-sha1 aes128-sha1 aes256-sha1 3des-sha1
username pix password p1yi36.m5IQK//nZ encrypted privilege 15
tunnel-group 2.2.253.82 type ipsec-l2l
tunnel-group 2.2.253.82 ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
Cryptochecksum:e6d2b32c3423f31ce9436a084b384d1f
: end

1 REPLY 1

andre.ortega
Enthusiast
Enthusiast

Hello Michael,

Try to add this command: same-security-traffic permit inter-interface.

Also, create an ACL to allow traffic (perhaps it isn't necessary in this case, but it may be advisable).

 

access-list FWGUEST extended permit ip any any

access-group FWGUEST in interface guest

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: