cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3924
Views
0
Helpful
11
Replies

outside to inside access problem

ranasaadnoori
Level 1
Level 1

hi,

i have an asa 5520 firewall transparent mode i configured samba on my server i have hosts from outside and need them to login to shared files no server theres a ping from server vlan to hosts i configured an outbound access list on server interface but don't get reply from server an users cant login to shared folder


					
				
			
			
				
			
			
				
2 Accepted Solutions

Accepted Solutions

You should not be NATing to the outside host IP.  use the interface command instead of an IP. like this:

object network PrintOut
host 192.168.160.10 
nat (hp-printer,outside) static interface service tcp 9100 9100

also run a packet tracer in both directions:

packet-tracer input hp-printer tcp 192.168.160.10 9100 192.168.200.6 9100 detail

packet-tracer input outside tcp 192.168.200.6 9100 <interface IP> 9100

This will give us an idea where the problem is.

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to select a correct answer and rate helpful posts

View solution in original post

But did you allow the traffic in the ACL on the outside interface? remember to replace the ACL name with the actual ACL name if you decide to use the following example.

access-list outside_access_in extended permit tcp host 192.168.200.6 host 192.168.160.10 eq 9100

access-group outside_access_in in interface outside

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to select a correct answer and rate helpful posts

View solution in original post

11 Replies 11

FYI. The configuration you posted is not for a Transparent firewall.

But If you are going to keep the ASA in routed mode you need to add static PAT for the server you want to access from the outside (translate it to the outside interface) and specify the real and translated ports.  Quite simple to do in the ASDM if you are using that.

Then you will need to add an ACL allowing the required traffic and assign it to the interface where traffic is being sourced from.

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to select a correct answer and rate helpful posts

Thank you for the correction i am not really good at firewalls i usually look for code in device manuals i don't use asdm can you further explain, if i am right u mean i should add port number to

my previous nat :

nat (any,any) static 192.168.110.2

Thank you for replying

Yes add port number to the nat statement and add an access list allowing traffic towards the servers on the required port.

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to select a correct answer and rate helpful posts

hi,

as you explained earlier i did try do give access to print on inside printer 192.168.160.10

from outside host 192.168.200.6

added the following but did not work

object network PrintOut
host 192.168.160.10 
nat (hp-printer,outside) static 192.168.200.6 service tcp 9100 9100


access-list allowprint extended permit tcp host 192.168.200.6 192.168.160.10 eq 9100
access-group allowprint in interface hp-printer

but could not print from outside host

You should not be NATing to the outside host IP.  use the interface command instead of an IP. like this:

object network PrintOut
host 192.168.160.10 
nat (hp-printer,outside) static interface service tcp 9100 9100

also run a packet tracer in both directions:

packet-tracer input hp-printer tcp 192.168.160.10 9100 192.168.200.6 9100 detail

packet-tracer input outside tcp 192.168.200.6 9100 <interface IP> 9100

This will give us an idea where the problem is.

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to select a correct answer and rate helpful posts

Hi,

Bellow my packet tracer output and i did ping outside host 192.168.200.6 from printer vlan and got a reply

#packet-tracer input hp-printer tcp 192.168.160.10 9100 192.168.200.6 9100 detail


Phase: 1
Type: ACCESS-LIST
Subtype:
Result: ALLOW
Config:
Implicit Rule
Additional Information:
Forward Flow based lookup yields rule:
in id=0xce970e90, priority=1, domain=permit, deny=false
hits=125, user_data=0x0, cs_id=0x0, l3_type=0x8
src mac=0000.0000.0000, mask=0000.0000.0000
dst mac=0000.0000.0000, mask=0100.0000.0000
input_ifc=hp-printer, output_ifc=any

Phase: 2
Type: ROUTE-LOOKUP
Subtype: input
Result: ALLOW
Config:
Additional Information:
in 0.0.0.0 0.0.0.0 outside

Phase: 3
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:
Forward Flow based lookup yields rule:
in id=0xce974b98, priority=0, domain=inspect-ip-options, deny=true
hits=43, user_data=0x0, cs_id=0x0, reverse, flags=0x0, protocol=0
src ip/id=0.0.0.0, mask=0.0.0.0, port=0
dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0
input_ifc=hp-printer, output_ifc=any

Phase: 4
Type: NAT
Subtype:
Result: ALLOW
Config:
object network Printer1
nat (hp-printer,outside) static interface service tcp 9100 9100
Additional Information:
Static translate 192.168.160.10/9100 to 10.20.20.2/9100
Forward Flow based lookup yields rule:
in id=0xcabafba8, priority=6, domain=nat, deny=false
hits=1, user_data=0xce9f17d8, cs_id=0x0, use_real_addr, flags=0x0, protocol=6
src ip/id=192.168.160.10, mask=255.255.255.255, port=9100
dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0
input_ifc=hp-printer, output_ifc=outside

Phase: 5
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:
Reverse Flow based lookup yields rule:
in id=0xce899bd0, priority=0, domain=inspect-ip-options, deny=true
hits=4278, user_data=0x0, cs_id=0x0, reverse, flags=0x0, protocol=0
src ip/id=0.0.0.0, mask=0.0.0.0, port=0
dst ip/id=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0
input_ifc=outside, output_ifc=any

Phase: 6
Type: FLOW-CREATION
Subtype:
Result: ALLOW
Config:
Additional Information:
New flow created with id 4477, packet dispatched to next module
Module information for forward flow ...
snp_fp_tracer_drop
snp_fp_inspect_ip_options
snp_fp_tcp_normalizer
snp_fp_translate
snp_fp_adjacency
snp_fp_fragment
snp_ifc_stat

Module information for reverse flow ...
snp_fp_tracer_drop
snp_fp_inspect_ip_options
snp_fp_translate
snp_fp_tcp_normalizer
snp_fp_adjacency
snp_fp_fragment
snp_ifc_stat

Result:
input-interface: hp-printer
input-status: up
input-line-status: up
output-interface: outside
output-status: up
output-line-status: up
Action: allow

# packet-tracer input outside tcp 192.168.200.6 9100 192.168.160.1 9100

Phase: 1
Type: ACCESS-LIST
Subtype:
Result: ALLOW
Config:
Implicit Rule
Additional Information:
MAC Access list

Phase: 2
Type: ROUTE-LOOKUP
Subtype: input
Result: ALLOW
Config:
Additional Information:
in 192.168.160.1 255.255.255.255 identity

Phase: 3
Type: UN-NAT
Subtype: static
Result: ALLOW
Config:
object network printer
nat (any,any) static 192.168.160.10
Additional Information:
NAT divert to egress interface identity
Untranslate 192.168.160.1/9100 to 192.168.160.1/9100

Phase: 4
Type: ACCESS-LIST
Subtype:
Result: DROP
Config:
Implicit Rule
Additional Information:

Result:
input-interface: outside
input-status: up
input-line-status: up
output-interface: NP Identity Ifc
output-status: up
output-line-status: up
Action: drop
Drop-reason: (acl-drop) Flow is denied by configured rule

why is it dropped is it access list issue

But did you allow the traffic in the ACL on the outside interface? remember to replace the ACL name with the actual ACL name if you decide to use the following example.

access-list outside_access_in extended permit tcp host 192.168.200.6 host 192.168.160.10 eq 9100

access-group outside_access_in in interface outside

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to select a correct answer and rate helpful posts

did apply the rule did not work i did not write this configuration but if u can see theres already a nat between printer & outside which means i dont need extra nat on port 

nat (proxy,outside) source dynamic any interface
nat (student's-laptops,outside) source dynamic any interface
nat(server, student's-laptops) source dynamic any interface
nat (server,outside) source dynamic any interface
nat (IC&ID,server) source dynamic any interface
nat (IC&ID,outside) source dynamic any interface
!
object network printer
nat (any,any) static 192.168.160.10

as u can see in previous configuration  also as i said i can ping 192.168.200.6 from printer vlan what is the problem? should i delete all nat ru;es and keep only configuration u mentioned

Just noticed that you packet tracer is not correct.  you have specified the interface IP of the hp-printer but you need to specify the IP address of the ingress interface (in this case it would seem it is the outside interface).

packet-tracer input outside tcp 192.168.200.6 9100 10.20.20.2 9100

Also, I am not talking about NAT now.  You need to also allow the traffic, that is originating from the outside, to pass through the ASA with the use of an access-list.

I am assuming that you are sending print requests from the outside interface to the hp-printer network?

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to select a correct answer and rate helpful posts

hi ,

Thank you i did solve my problem and print and share are ok 

beatinger
Level 1
Level 1

I have a similar problem.  I have been able to setup my Cisco ASA5540 for Internet access from inside servers to the outside (i.e., I can hit websites, and ping hosts to the outside), but I cannot figure out how to allow access from outside public IPs, to NATed IPs on the inside network.  I feel that the problem is related to no mapping between outside IPs to the inside IPs, which have been assigned to servers.  There used to be a "static route" command, which has not been deprecated.  This is my current, very simple configuration:

 

ciscoasa5540# show config
: Saved
:
: Serial Number: JMX1112L1JH
: Hardware: ASA5540-K8, 2560 MB RAM, CPU Pentium 4 2000 MHz
: Written by enable_15 at 19:15:49.949 UTC Wed Aug 21 2019
!
ASA Version 9.1(7)32
!
hostname ciscoasa5540
domain-name edenhosting.net
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface GigabitEthernet0/0
nameif outside
security-level 0
ip address 12.43.6.90 255.255.255.0
!
interface GigabitEthernet0/1
nameif inside
security-level 100
ip address 10.1.252.254 255.255.255.0
!
interface GigabitEthernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
management-only
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
!
ftp mode passive
dns server-group DefaultDNS
domain-name edenhosting.net
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network IIS85Server
host 10.1.252.249
access-list outside_access_in extended permit icmp any any
access-list outside_access_in extended permit tcp any4 host 10.1.252.249 eq www
access-list outside_access_in extended permit tcp any4 host 10.1.252.249 eq https
pager lines 24
logging enable
logging asdm informational
mtu management 1500
mtu inside 1500
mtu outside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network obj_any
nat (inside,outside) dynamic interface
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 12.43.6.81 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpoint _SmartCallHome_ServerCA
no validation-usage
crl configure
crypto ca trustpool policy
crypto ca certificate chain _SmartCallHome_ServerCA
certificate ca 18dad19e267de8bb4a2158cdcc6b3b4a
308204d3 308203bb a0030201 02021018 dad19e26 7de8bb4a 2158cdcc 6b3b4a30
0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d30
36313130 38303030 3030305a 170d3336 30373136 32333539 35395a30 81ca310b
30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
74776f72 6b313a30 38060355 040b1331 28632920 32303036 20566572 69536967
6e2c2049 6e632e20 2d20466f 72206175 74686f72 697a6564 20757365 206f6e6c
79314530 43060355 0403133c 56657269 5369676e 20436c61 73732033 20507562
6c696320 5072696d 61727920 43657274 69666963 6174696f 6e204175 74686f72
69747920 2d204735 30820122 300d0609 2a864886 f70d0101 01050003 82010f00
3082010a 02820101 00af2408 08297a35 9e600caa e74b3b4e dc7cbc3c 451cbb2b
e0fe2902 f95708a3 64851527 f5f1adc8 31895d22 e82aaaa6 42b38ff8 b955b7b1
b74bb3fe 8f7e0757 ecef43db 66621561 cf600da4 d8def8e0 c362083d 5413eb49
ca595485 26e52b8f 1b9febf5 a191c233 49d84363 6a524bd2 8fe87051 4dd18969
7bc770f6 b3dc1274 db7b5d4b 56d396bf 1577a1b0 f4a225f2 af1c9267 18e5f406
04ef90b9 e400e4dd 3ab519ff 02baf43c eee08beb 378becf4 d7acf2f6 f03dafdd
75913319 1d1c40cb 74241921 93d914fe ac2a52c7 8fd50449 e48d6347 883c6983
cbfe47bd 2b7e4fc5 95ae0e9d d4d143c0 6773e314 087ee53f 9f73b833 0acf5d3f
3487968a ee53e825 15020301 0001a381 b23081af 300f0603 551d1301 01ff0405
30030101 ff300e06 03551d0f 0101ff04 04030201 06306d06 082b0601 05050701
0c046130 5fa15da0 5b305930 57305516 09696d61 67652f67 69663021 301f3007
06052b0e 03021a04 148fe5d3 1a86ac8d 8e6bc3cf 806ad448 182c7b19 2e302516
23687474 703a2f2f 6c6f676f 2e766572 69736967 6e2e636f 6d2f7673 6c6f676f
2e676966 301d0603 551d0e04 1604147f d365a7c2 ddecbbf0 3009f343 39fa02af
33313330 0d06092a 864886f7 0d010105 05000382 01010093 244a305f 62cfd81a
982f3dea dc992dbd 77f6a579 2238ecc4 a7a07812 ad620e45 7064c5e7 97662d98
097e5faf d6cc2865 f201aa08 1a47def9 f97c925a 0869200d d93e6d6e 3c0d6ed8
e6069140 18b9f8c1 eddfdb41 aae09620 c9cd6415 3881c994 eea28429 0b136f8e
db0cdd25 02dba48b 1944d241 7a05694a 584f60ca 7e826a0b 02aa2517 39b5db7f
e784652a 958abd86 de5e8116 832d10cc defda882 2a6d281f 0d0bc4e5 e71a2619
e1f4116f 10b595fc e7420532 dbce9d51 5e28b69e 85d35bef a57d4540 728eb70e
6b0e06fb 33354871 b89d278b c4655f0d 86769c44 7af6955c f65d3208 33a454b6
183f685c f2424a85 3854835f d1e82cf2 ac11d6a8 ed636a
quit
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!

class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous

 

This has been an extremely difficult setup for me, as the server room is a 70-mile round trip, and I cannot get out there very often, and when I am there, I just can't figure this out.  I spent 8 hours on this today alone.  I did figure out how to get the ASDM working, but it doesn't help much.  Thank you very much for your help!

Review Cisco Networking for a $25 gift card