Yes they have changed alot. Now you configure subinterface commands.
ciscopix(config-if)# interface vlan 100
ciscopix(config-if)# nameif DMZ1
ciscopix(config-if)# security-level 50
ciscopix(config-if)# ip address 192.168.1.1 255.255.255.0
ciscopix(config-if)# no shutdown
ciscopix(config-if)# interface vlan 101
ciscopix(config-if)# nameif DMZ2
ciscopix(config-if)# security-level 75
ciscopix(config-if)# ip address 192.168.2.1 255.255.255.0
ciscopix(config-if)# no shutdown
ciscopix(config-if)# interface ethernet 0/1
ciscopix(config-if)# switchport mode trunk
ciscopix(config-if)# switchport trunk allowed vlan 100-101
ciscopix(config-if)# no shutdown