cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

3035
Views
0
Helpful
3
Replies
uthayaman
Beginner

Priority Queue in ASA sub interface

Hi,

We planned to configure QOS in our ASA. Decided to go for priority queue, but the problem is, asa is cofigured with subinterfaces. If i apply the command priority-queue physica interface name, then this will take care of subinterfaces configured under the physical interface?

Is there any way we can use priority queue for subinterface links.

3 REPLIES 3
varrao
Advocate

Hi,

As per your query,QoS is not supported on a subinterface,  only on the main interface itself. If you configure QoS on an interface  itself, all the sub-interfaces are also affected by the QoS. Here is the doc for it:

http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a008080dfa7.shtml

Hope this helps

Thanks,

Varun

Thanks,
Varun Rao
Mark Walters
Beginner

Hi Guys -

When people choose to configure  subinterfaces on an ASA, as I generally do, they commonly don't  configure the physical interface at all -- no NAMEIF, no IP address,  etc.  In this case you'll need to put a 'NAMEIF' on the physical interface in order to apply the priority queue, which will then be inherited by the  subinterfaces as described above.

Note that the service-policy (that specifies "priority" queueing for some traffic) is still applied to the subinterface.

Example:

interface GigabitEthernet0/0

description [OUTSIDE] MAIN OUTSIDE INTERFACE

speed 1000

duplex full

nameif OUTSIDE_PHYSICAL

security-level 0

no ip address

!

priority-queue OUTSIDE_PHYSICAL

queue-limit 1000

tx-ring-limit 167

!

!

interface GigabitEthernet0/0.99

description OUTSIDE INTERFACE

vlan 99

nameif OUTSIDE

security-level 0

ip address 1.1.1.1 255.255.255.248 standby 1.1.1.2

!

policy-map QOS_OUTSIDE

class IMPORTANT_C

  priority

!

service-policy QOS_OUTSIDE interface OUTSIDE

Cheers!

Mark Walters

CCIE 20571

Hi Mark,

 

Have you ever got your question answered?

 

Cheers,

Dee

Content for Community-Ad

This widget could not be displayed.