cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2295
Views
0
Helpful
2
Replies
Highlighted
Beginner

Sip registration timing out

I have a SPA112 behind a 5500 firewall that connects to a Voip provider on the Internet.  I have issues where people can't call in and it takes a long time to call out.

While investigating, it looks like my SPA is registering every 60 minutes but the SIP connection times out after 2 minutes.  I have a dynamic IP address and am using Pat.  

As I am using inspect sip, I assume that I need to tweak my SIP timers but I'm not sure what I should be tweaking.  The connection in question is:

UDP outside  <ProviderIP>:5060 Phone  <SPA_IP>:5060, idle 0:02:01, bytes 12698, flags Te

firewall# show run | in sip
timeout sip 0:00:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advisor

It sounds like you are

It sounds like you are running into the default ASA timeouts, which are something like:

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

Try changing it to something like:

timeout conn 1:00:00 half-closed 0:10:00 udp 4:00:00 icmp 0:00:02

My preferred solution, instead of the above, would be to enable NAT keepalive on the SPA112.  If it times out after 2 minutes then make the keepalive 1 minute.

View solution in original post

2 REPLIES 2
Highlighted
Advisor

It sounds like you are

It sounds like you are running into the default ASA timeouts, which are something like:

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

Try changing it to something like:

timeout conn 1:00:00 half-closed 0:10:00 udp 4:00:00 icmp 0:00:02

My preferred solution, instead of the above, would be to enable NAT keepalive on the SPA112.  If it times out after 2 minutes then make the keepalive 1 minute.

View solution in original post

Highlighted
Beginner

Thanks.  I increased the

Thanks.  I increased the keepalive and it seems to work perfectly now.