01-26-2011 09:02 AM - edited 03-11-2019 12:40 PM
I'm trying to forward SSH from the outside to a specific server behind this ASA 5505 config. Can anyone lend a hand here.
ASA Version 7.2(4)
!
hostname ciscoasa
enable password !HgPTxF8112Bdb encrypted
passwd JuJ07h/lZ9f52tj1 encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address <MY_IP> 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
access-list access_outside_in extended permit tcp any any range 27350 27483
access-list access_outside_in extended permit tcp any any range 28350 28483
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface ssh 192.168.1.10 ssh netmask 255.255.255.255
route outside 0.0.0.0 0.0.0.0 <MY_GATEWAY.1.1>
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh scopy enable
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.254 inside
dhcpd enable inside
!
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:00cd56e103e324f289d79befce96b903
01-26-2011 09:25 AM
Hi,
The static NAT statement is correct:
static (inside,outside) tcp interface ssh 192.168.1.10 ssh netmask 255.255.255.255
But you're required to permit the traffic:
access-list access_outside_in extended permit tcp any interface eq 22
Federico.
01-26-2011 09:26 AM
Hi
As an Aside note, you wont be able to ssh to the Unit from the outside anymore.
Cheers
Mike
01-26-2011 09:26 AM
You need to add SSH to your ACL.
access-list access_outside_in extended permit tcp host x.x.x.x host y.y.y.y eq 22
Than apply the ACL to your outside interface
access-group access_outside_in in interface outside
Also note that you will lose the ability to ssh to the ASA from the outside.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide